# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py-zope-deprecation
_pkgname=zope.deprecation
pkgver=4.0.2
pkgrel=0
pkgdesc="Zope Deprecation Infrastructure"
url="https://pypi.python.org/pypi/zope.deprecation"
arch="noarch"
license="ZPL2+"
depends="python2"
depends_dev=""
makedepends="python2-dev py-setuptools"
install=""
subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"

_builddir="$srcdir"/$_pkgname-$pkgver
prepare() {
	local i
	cd "$_builddir"
	for i in $source; do
		case $i in
		*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
		esac
	done
}

build() {
	cd "$_builddir"
	python2 setup.py build || return 1
}

package() {
	cd "$_builddir"
	python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
}

md5sums="5f8cecce85f2783f9e020f1288e908fd  zope.deprecation-4.0.2.tar.gz"
sha256sums="02639fbee27bfa22f672eb18e4c173f625799459a4bc0363b86593b1d7977de6  zope.deprecation-4.0.2.tar.gz"
sha512sums="83c1e39269836347e8d315c799c3e199d6291fcfe6dced5c46f430cb03bf98283b28ff676cea720def2984c9871811218dd72e2dba10d88cfe64ad7409b62875  zope.deprecation-4.0.2.tar.gz"