# Contributor: Michael Zhou <zhoumichaely@gmail.com>
# Maintainer:
pkgname=lwm
pkgver=1.2.2
pkgrel=0
pkgdesc="Lightweight Window Manager that tries to keep out of your face"
url="http://www.jfc.org.uk/software/lwm.html"
arch="all"
license="GPL"
depends=""
makedepends="libx11-dev libsm-dev"
install=""
subpackages=""
source="
	http://www.jfc.org.uk/files/$pkgname/$pkgname-$pkgver.tar.gz
	no_xmkmf_makefile.patch
"

_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
	local i
	cd "$_builddir"
	for i in $source; do
		case $i in
		*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
		esac
	done
}

build() {
	cd "$_builddir"
	make -f no_xmkmf_makefile || return 1
}

package() {
	cd "$_builddir"
	install -d "$pkgdir"/usr/bin
	install lwm "$pkgdir"/usr/bin
}

md5sums="1748722a293e03d632b615275ef84498  lwm-1.2.2.tar.gz
cbfa8518daed50927fe4cc8ae5d2e550  no_xmkmf_makefile.patch"