summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-07-25 21:46:43 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-07-25 21:46:43 +0200
commitdc2777293b81314bf6d31c206a5b05a2beed2302 (patch)
treee3d623a2657e2f750d9b82e6caed95602746707e
parenta66abec72346d0bd50d0dad6c02c2fc8023e277a (diff)
downloadlua-aports-dc2777293b81314bf6d31c206a5b05a2beed2302.tar.bz2
lua-aports-dc2777293b81314bf6d31c206a5b05a2beed2302.tar.xz
makefile: add tasks lint and check
-rw-r--r--Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 192ad88..943ce80 100644
--- a/Makefile
+++ b/Makefile
@@ -27,3 +27,8 @@ install: $(addprefix bin/,$(binfiles)) $(addprefix aports/,$(aportsfiles))
for file in $(binfiles); do \
install -m755 bin/$$file $(DESTDIR)$(bindir)/$${file%.lua} || exit 1; \
done
+
+check: lint
+
+lint:
+ luacheck aports bin