summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-06-10 09:22:43 +0000
committerTimo Teräs <timo.teras@iki.fi>2010-06-10 13:27:47 +0300
commit1d5e59ca83531f0e52bd94fbc28ec1e791020ce1 (patch)
tree1fbdad66dd4c007eccc2cce05b98f1b58126c312
parent9c54951a0024fefe80a01bba7e2a009bf369d8f6 (diff)
downloadaports-1d5e59ca83531f0e52bd94fbc28ec1e791020ce1.tar.bz2
aports-1d5e59ca83531f0e52bd94fbc28ec1e791020ce1.tar.xz
main/linux-grsec: fix for hyper-v and PaX
(cherry picked from commit f90d28dd1c6b9515696c7a08bebd6c463e81e00b)
-rw-r--r--main/linux-grsec/APKBUILD4
-rw-r--r--main/linux-grsec/hv-grsec.patch13
2 files changed, 16 insertions, 1 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 16eb88ebb..67b03001e 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=2.6.32.15
_kernver=2.6.32
-pkgrel=4
+pkgrel=5
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs linux-firmware"
@@ -34,6 +34,7 @@ source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
r8169-fix-random-mdio_write-failures.patch
r8169-fix-mdio_read-and-update-mdio_write-according-to-hw-specs.patch
x86-setup-When-restoring-the-screen-update-boot_params-screen_info.patch
+ hv-grsec.patch
kernelconfig.x86
"
subpackages="$pkgname-dev linux-firmware:firmware"
@@ -165,4 +166,5 @@ c7e606c11c05ff03012b21c3fe0ece47 xfrm-fix-policy-unreferencing-on-larval-drop.p
ce4a74190febe13713bab1b886dd5bee r8169-fix-random-mdio_write-failures.patch
b41ee19f13498fb25992fd60cd1126d4 r8169-fix-mdio_read-and-update-mdio_write-according-to-hw-specs.patch
a1bcf76870b63a4a4035a8948fb758e2 x86-setup-When-restoring-the-screen-update-boot_params-screen_info.patch
+bf14850a0036d14bc6177adbdec23a17 hv-grsec.patch
442d7174a9755ed7bba22ebd4918bbe5 kernelconfig.x86"
diff --git a/main/linux-grsec/hv-grsec.patch b/main/linux-grsec/hv-grsec.patch
new file mode 100644
index 000000000..6fde34199
--- /dev/null
+++ b/main/linux-grsec/hv-grsec.patch
@@ -0,0 +1,13 @@
+diff --git a/drivers/staging/hv/Hv.c b/drivers/staging/hv/Hv.c
+index b12237f..9d47edb 100644
+--- a/drivers/staging/hv/Hv.c
++++ b/drivers/staging/hv/Hv.c
+@@ -133,7 +133,7 @@ static u64 HvDoHypercall(u64 Control, void *Input, void *Output)
+ u64 hvStatus = 0;
+ u64 inputAddress = (Input) ? virt_to_phys(Input) : 0;
+ u64 outputAddress = (Output) ? virt_to_phys(Output) : 0;
+- volatile void *hypercallPage = gHvContext.HypercallPage;
++ volatile void *hypercallPage = ktva_ktla(gHvContext.HypercallPage);
+
+ DPRINT_DBG(VMBUS, "Hypercall <control %llx input phys %llx virt %p "
+ "output phys %llx virt %p hypercall %p>",