summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-06 09:52:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-06 09:52:54 +0000
commit87b4e8f6c07c1452c0ba0293ab323ec790675b83 (patch)
tree69b7768f3aa05e5e12d62c7a74544fbf67df1558
parent3f979f3a769a9aee30f7dccf039eaeedc13a5392 (diff)
downloadaports-87b4e8f6c07c1452c0ba0293ab323ec790675b83.tar.bz2
aports-87b4e8f6c07c1452c0ba0293ab323ec790675b83.tar.xz
core/apk-tools: backport support for apk fetch --simulate
-rw-r--r--core/apk-tools/0001-fetch-respect-simulate-option.patch26
-rw-r--r--core/apk-tools/APKBUILD10
2 files changed, 33 insertions, 3 deletions
diff --git a/core/apk-tools/0001-fetch-respect-simulate-option.patch b/core/apk-tools/0001-fetch-respect-simulate-option.patch
new file mode 100644
index 000000000..8d2445834
--- /dev/null
+++ b/core/apk-tools/0001-fetch-respect-simulate-option.patch
@@ -0,0 +1,26 @@
+From 4d940c7932c32ed6885c72b5a2e70101b018ad8c Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Mon, 6 Jul 2009 08:48:25 +0000
+Subject: [PATCH] fetch: respect --simulate option
+
+---
+ src/fetch.c | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/src/fetch.c b/src/fetch.c
+index 84f0b39..501dff1 100644
+--- a/src/fetch.c
++++ b/src/fetch.c
+@@ -82,6 +82,9 @@ static int fetch_package(struct fetch_ctx *fctx,
+ return -1;
+ }
+
++ if (apk_flags & APK_SIMULATE)
++ return 0;
++
+ snprintf(infile, sizeof(infile), "%s/%s-%s.apk",
+ db->repos[i].url, pkg->name->name, pkg->version);
+
+--
+1.6.3.3
+
diff --git a/core/apk-tools/APKBUILD b/core/apk-tools/APKBUILD
index 253059030..ce5fc13d0 100644
--- a/core/apk-tools/APKBUILD
+++ b/core/apk-tools/APKBUILD
@@ -1,11 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
pkgver=2.0_pre13
-pkgrel=0
+pkgrel=1
pkgdesc="Alpine Package Keeper - package manager for alpine"
depends=
makedepends="zlib-dev"
-source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2"
+source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
+ 0001-fetch-respect-simulate-option.patch"
url="http://git.alpinelinux.org/cgit/apk-tools/"
license=GPL-2
@@ -13,6 +14,8 @@ license=GPL-2
build() {
cd "$srcdir/$pkgname-$pkgver"
sed -i -e 's:-Werror::' Make.rules
+ patch -p1 < ../0001-fetch-respect-simulate-option.patch || return 1
+
make || return 1
make DESTDIR="$pkgdir" install
cd "$pkgdir/sbin"
@@ -24,4 +27,5 @@ build() {
ln -s apk apk_version
}
-md5sums="76bec7ece7b210f2f2e1542d06333649 apk-tools-2.0_pre13.tar.bz2"
+md5sums="76bec7ece7b210f2f2e1542d06333649 apk-tools-2.0_pre13.tar.bz2
+7edb66f98ec4ef4398bd5e816e47d286 0001-fetch-respect-simulate-option.patch"