summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-17 11:05:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-17 11:05:46 +0000
commit3ac865d7266d2b58c2c6222114b9263e4e27654d (patch)
tree9643c181d820554b6fbec01ad356658a4a7a9e6b
parentb1461e068f3ce595a1ca40f038f40e906e89a0a5 (diff)
downloadaports-3ac865d7266d2b58c2c6222114b9263e4e27654d.tar.bz2
aports-3ac865d7266d2b58c2c6222114b9263e4e27654d.tar.xz
extra/postfix: pcre handles regexp as well
Fixes #66
-rw-r--r--extra/postfix/APKBUILD6
-rw-r--r--extra/postfix/dynamicmaps.cf3
-rw-r--r--extra/postfix/postfix-pcre.post-install6
3 files changed, 11 insertions, 4 deletions
diff --git a/extra/postfix/APKBUILD b/extra/postfix/APKBUILD
index 534bffb21..0cddde296 100644
--- a/extra/postfix/APKBUILD
+++ b/extra/postfix/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=postfix
pkgver=2.6.2
-pkgrel=0
+pkgrel=2
pkgdesc="Secure and fast drop-in replacement for Sendmail (MTA)"
url="http://www.postfix.org/"
license="IPL-1"
@@ -144,8 +144,8 @@ md5sums="1f0edbd521d2b0473626f4d61e8bb4eb postfix-2.6.2.tar.gz
2bfc3864183694e5484ac073bb0cb7ef postfix.pre-install
0064d45c2c8a46c374b55c4abc46cfb2 postfix.post-install
d45552cfdcd911d0934c0cb7816c4011 postfix-2.6.1-dynamicmaps.patch
-0efff9b4bb493ad2ff0b9915cb244d14 dynamicmaps.cf
+c653c222c8504c6f36d67eb342c8bf51 dynamicmaps.cf
2ebe51a882eb9d6d7866583eb6af3969 postfix-ldap.post-install
2ebe51a882eb9d6d7866583eb6af3969 postfix-mysql.post-install
-2ebe51a882eb9d6d7866583eb6af3969 postfix-pcre.post-install
+5b00c3b4c463102c1876bf343b88189c postfix-pcre.post-install
2ebe51a882eb9d6d7866583eb6af3969 postfix-pgsql.post-install"
diff --git a/extra/postfix/dynamicmaps.cf b/extra/postfix/dynamicmaps.cf
index 49d25480c..b8b8cd25b 100644
--- a/extra/postfix/dynamicmaps.cf
+++ b/extra/postfix/dynamicmaps.cf
@@ -8,7 +8,8 @@
#ldap /usr/lib/postfix/dict_ldap.so dict_ldap_open
#mysql /usr/lib/postfix/dict_mysql.so dict_mysql_open
#pcre /usr/lib/postfix/dict_pcre.so dict_pcre_open
-#pgsq /usr/lib/postfix/dict_pgsql.so dict_pgsql_open
+#regexp /usr/lib/postfix/dict_pcre.so dict_pcre_open
+#pgsql /usr/lib/postfix/dict_pgsql.so dict_pgsql_open
# apk tools will manage the lines below
## AUTO BEGIN ##
diff --git a/extra/postfix/postfix-pcre.post-install b/extra/postfix/postfix-pcre.post-install
index b8d23833b..6962486fe 100644
--- a/extra/postfix/postfix-pcre.post-install
+++ b/extra/postfix/postfix-pcre.post-install
@@ -12,8 +12,14 @@ if cd /usr/lib/postfix/; then
m=${i#dict_}
m=${m%.so}
echo -e "$m\t/usr/lib/postfix/$i\tdict_${m}_open"
+ # pcre also handles regexp
+ if [ "$m" = "pcre" ]; then
+ echo -e "regexp\t/usr/lib/postfix/$i\tdict_${m}_open"
+ fi
+
done
fi
echo '## AUTO END ##'
) >> $conf
+