summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-25 07:09:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-25 07:09:56 +0000
commit66f1463a36f397cc142f861d7327586ce9e59730 (patch)
treed864b930f9edd3c93a857c3c46892fe2a8a3ae00
parent151bdfe1775c0b9ed6782bde97c5e9fb5353d0d6 (diff)
downloadaports-66f1463a36f397cc142f861d7327586ce9e59730.tar.bz2
aports-66f1463a36f397cc142f861d7327586ce9e59730.tar.xz
main/imagemagick: upgrade to 6.7.0.0
and enable libwebp support
-rw-r--r--main/imagemagick/APKBUILD22
-rw-r--r--main/imagemagick/locale.patch61
2 files changed, 78 insertions, 5 deletions
diff --git a/main/imagemagick/APKBUILD b/main/imagemagick/APKBUILD
index d232ba27d..0e6b68689 100644
--- a/main/imagemagick/APKBUILD
+++ b/main/imagemagick/APKBUILD
@@ -1,17 +1,28 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=imagemagick
-pkgver=6.6.9.9
+pkgver=6.7.0.0
_pkgver=${pkgver%.*}-${pkgver##*.}
-pkgrel=1
+pkgrel=0
pkgdesc="A collection of tools and libraries for many image formats"
url="http://www.imagemagick.org/"
arch="all"
license="GPL"
depends=
-makedepends="zlib-dev libpng-dev jpeg-dev freetype-dev perl-dev ghostscript-dev"
+makedepends="zlib-dev libpng-dev jpeg-dev freetype-dev perl-dev ghostscript-dev
+ libwebp-dev"
subpackages="$pkgname-doc $pkgname-dev $pkgname-c++:_cxx"
-source="ftp://ftp.imagemagick.org/pub/ImageMagick/ImageMagick-$_pkgver.tar.gz"
+source="ftp://ftp.imagemagick.org/pub/ImageMagick/ImageMagick-$_pkgver.tar.gz
+ locale.patch"
+
+prepare() {
+ cd "$srcdir/ImageMagick-${_pkgver}"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
build() {
cd "$srcdir/ImageMagick-${_pkgver}"
@@ -54,4 +65,5 @@ _cxx() {
mv "$pkgdir"/usr/lib/libMagick++.so.* "$subpkgdir"/usr/lib/
}
-md5sums="3b240b7316a96cd6a168c14fe670eafc ImageMagick-6.6.9-9.tar.gz"
+md5sums="f845395f6b1c849462c2d55357d8d863 ImageMagick-6.7.0-0.tar.gz
+d8aac6ac384d32184b21bbf0a0e8c57e locale.patch"
diff --git a/main/imagemagick/locale.patch b/main/imagemagick/locale.patch
new file mode 100644
index 000000000..9d83f1169
--- /dev/null
+++ b/main/imagemagick/locale.patch
@@ -0,0 +1,61 @@
+From dcc53fb77f056ffb5c2eb66922b389af65adbfaf Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Wed, 25 May 2011 07:00:00 +0000
+Subject: [PATCH] uclibc locale
+
+uclibc might not have locale_t. We only activate the staic c_locale code
+when we have vprintf_l() which is the only time we will use it.
+---
+ magick/locale.c | 6 ++++++
+ 1 files changed, 6 insertions(+), 0 deletions(-)
+
+diff --git a/magick/locale.c b/magick/locale.c
+index 4b84b2e..ee1c11b 100644
+--- a/magick/locale.c
++++ b/magick/locale.c
+@@ -90,8 +90,10 @@ static SemaphoreInfo
+ static SplayTreeInfo
+ *locale_list = (SplayTreeInfo *) NULL;
+
++#if defined(MAGICKCORE_HAVE_VFPRINTF_L)
+ static volatile locale_t
+ c_locale = (locale_t) NULL;
++#endif
+
+ static volatile MagickBooleanType
+ instantiate_locale = MagickFalse;
+@@ -122,6 +124,7 @@ static MagickBooleanType
+ % locale_t AcquireCLocale(void)
+ %
+ */
++#if defined(MAGICKCORE_HAVE_VFPRINTF_L)
+ static locale_t AcquireCLocale(void)
+ {
+ #if defined(MAGICKCORE_HAVE_NEWLOCALE)
+@@ -133,6 +136,7 @@ static locale_t AcquireCLocale(void)
+ #endif
+ return(c_locale);
+ }
++#endif
+
+ /*
+ %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
+@@ -155,6 +159,7 @@ static locale_t AcquireCLocale(void)
+ */
+ static void DestroyCLocale(void)
+ {
++#if defined(MAGICKCORE_HAVE_VFPRINTF_L)
+ #if defined(MAGICKCORE_HAVE_NEWLOCALE)
+ if (c_locale != (locale_t) NULL)
+ freelocale(c_locale);
+@@ -163,6 +168,7 @@ static void DestroyCLocale(void)
+ _free_locale(c_locale);
+ #endif
+ c_locale=(locale_t) NULL;
++#endif
+ }
+
+ /*
+--
+1.7.5.2
+