summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo Godec <danilo.godec@agenda.si>2011-08-23 12:45:40 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-23 12:21:52 +0000
commit43d15fde74a5a4e0eea2dc4741f369570bf6ed1b (patch)
tree3dd49771acb479ffa6e9e9bc1574b0b3c63d2e11
parent489f5c7effcbc3cdca5d27e5bb95ee3b20bd0067 (diff)
downloadaports-43d15fde74a5a4e0eea2dc4741f369570bf6ed1b.tar.bz2
aports-43d15fde74a5a4e0eea2dc4741f369570bf6ed1b.tar.xz
OpenSwan - a new version 2.6.35 - removed 'ipsec.confd' as it didn't serve any purpose - created a working 'ipsec.initd' - changed the installation target for the 'setup' program, which usually goes in /etc/init.d/ipsec - now it goes to /usr/libexec/ipsec/setup and is called by ipsec.initd
-rw-r--r--testing/openswan/APKBUILD6
-rw-r--r--testing/openswan/ipsec.confd7
-rw-r--r--testing/openswan/ipsec.initd16
-rw-r--r--testing/openswan/setup.patch12
4 files changed, 21 insertions, 20 deletions
diff --git a/testing/openswan/APKBUILD b/testing/openswan/APKBUILD
index c3fd3786d..c1d8bc60a 100644
--- a/testing/openswan/APKBUILD
+++ b/testing/openswan/APKBUILD
@@ -11,7 +11,7 @@ depends=""
makedepends="gmp-dev bison flex coreutils"
install=""
subpackages="$pkgname-doc"
-source="http://www.openswan.org/download/$pkgname-$pkgver.tar.gz ipsec.confd ipsec.initd"
+source="http://www.openswan.org/download/$pkgname-$pkgver.tar.gz ipsec.initd setup.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -46,5 +46,5 @@ package() {
}
md5sums="7909a251fbbb807914545b7f42437013 openswan-2.6.35.tar.gz
-cbcac88f5b728b1441891947a4babbcb ipsec.confd
-aa21293d9fbbbe2a02fb87dba05c4d20 ipsec.initd"
+f019d1fa23627d54462054fedc9de03b ipsec.initd
+fd3cd27f9da9140fabd935377c3d6921 setup.patch"
diff --git a/testing/openswan/ipsec.confd b/testing/openswan/ipsec.confd
deleted file mode 100644
index 486252b03..000000000
--- a/testing/openswan/ipsec.confd
+++ /dev/null
@@ -1,7 +0,0 @@
-# Sample conf.d file for alpine linux
-
-#
-# Specify daemon options here.
-#
-
-sample_opts=""
diff --git a/testing/openswan/ipsec.initd b/testing/openswan/ipsec.initd
index a034601d4..32a06008a 100644
--- a/testing/openswan/ipsec.initd
+++ b/testing/openswan/ipsec.initd
@@ -1,9 +1,10 @@
#!/sbin/runscript
-# Sample init.d file for alpine linux.
+# Openswan ipsec init.d file for alpine linux.
-name=
-daemon=/usr/sbin/$name
+name=ipsec
+daemon=/usr/libexec/ipsec/setup
+pidfile=/var/run/pluto/ipsec_setup.pid
depend() {
need net
@@ -12,18 +13,13 @@ depend() {
start() {
ebegin "Starting ${name}"
- start-stop-daemon --start --quiet \
- --pidfile /var/run/${name}.pid \
- --chuid ${sample_user}:${sample_group} \
- --exec ${daemon} -- ${sample_opts}
+ $daemon start
eend $?
}
stop() {
ebegin "Stopping ${name}"
- start-stop-daemon --stop --quiet \
- --pidfile /var/run/$name.pid \
- --exec ${daemon}
+ $daemon stop
eend $?
}
diff --git a/testing/openswan/setup.patch b/testing/openswan/setup.patch
new file mode 100644
index 000000000..86ff6d80a
--- /dev/null
+++ b/testing/openswan/setup.patch
@@ -0,0 +1,12 @@
+--- openswan-2.6.35-orig/programs/setup/Makefile
++++ openswan-2.6.35/programs/setup/Makefile
+@@ -36,8 +36,7 @@
+ # check the directories we need exist (ie., make install DESTDIR=/tmp/IPsec)
+ @mkdir -p $(RCDIR) $(BINDIR)
+ # install and link everything
+- @$(INSTALL) $(INSTBINFLAGS) setup $(RCDIR)/ipsec
+- @ln -s $(FINALRCDIR)/ipsec $(BINDIR)/setup
++ @$(INSTALL) $(INSTBINFLAGS) setup $(BINDIR)/setup
+
+ install_file_list::
+ @echo $(RCDIR)/ipsec