summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-11-04 15:25:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-11-04 15:25:48 +0000
commit4f637b8b117f138bb8138812671af40e4a0de547 (patch)
treed8041ff6d16a813e723243f80ed8300a60064612
parent556138a22a851dfb6177d22c508a4842a7c82877 (diff)
downloadaports-4f637b8b117f138bb8138812671af40e4a0de547.tar.bz2
aports-4f637b8b117f138bb8138812671af40e4a0de547.tar.xz
testing/truecrypt: new aport
crypto ihttp
-rw-r--r--testing/truecrypt/APKBUILD54
-rw-r--r--testing/truecrypt/execstack-fix.patch60
-rw-r--r--testing/truecrypt/truecrypt-arch-detection.patch15
-rw-r--r--testing/truecrypt/truecrypt.desktop9
4 files changed, 138 insertions, 0 deletions
diff --git a/testing/truecrypt/APKBUILD b/testing/truecrypt/APKBUILD
new file mode 100644
index 000000000..5b2272b26
--- /dev/null
+++ b/testing/truecrypt/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=truecrypt
+pkgver=7.1
+pkgrel=0
+pkgdesc="crypto"
+url="ihttp"
+arch="all"
+license="AS-IS"
+depends=""
+depends_dev=""
+makedepends="nasm fuse-dev wxgtk-dev"
+install=""
+subpackages=""
+source="ftp://ftp.archlinux.org/other/tc/truecrypt-${pkgver}.tar.gz
+ ftp://ftp.archlinux.org/other/tc/pkcs-2.20.tar.gz
+ truecrypt-arch-detection.patch
+ execstack-fix.patch
+ truecrypt.desktop
+ "
+
+_builddir="$srcdir"/truecrypt-7.1-source
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make PKCS11_INC="${srcdir}/pkcs-2.20" VERBOSE=1 \
+ TC_EXTRA_CFLAGS="${CFLAGS}" \
+ TC_EXTRA_CXXFLAGS="${CXXFLAGS}" \
+ TC_EXTRA_LFLAGS="${LDFLAGS} -fno-PIE" \
+ NOSTRIP=1 \
+ || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm755 Main/truecrypt "$pkgdir"/usr/bin/truecrypt || return 1
+ install -Dm644 "$srcdir"/truecrypt.desktop \
+ "$pkgdir"/usr/share/applications/truecrypt.desktop
+}
+
+md5sums="a8268630a870faff07af940f63fb29eb truecrypt-7.1.tar.gz
+ce6a707b79411e82e8e558aa03e764b0 pkcs-2.20.tar.gz
+00ea70fa8437de877b31b027ac2b4060 truecrypt-arch-detection.patch
+78e606e6582dacc3176d59ad4419b6bb execstack-fix.patch
+183b9bf04a943454d4e216130bcbac01 truecrypt.desktop"
diff --git a/testing/truecrypt/execstack-fix.patch b/testing/truecrypt/execstack-fix.patch
new file mode 100644
index 000000000..d72fe0e14
--- /dev/null
+++ b/testing/truecrypt/execstack-fix.patch
@@ -0,0 +1,60 @@
+--- ./Crypto/Aes_hw_cpu.asm.old 2011-06-01 17:12:53.078000001 -0400
++++ ./Crypto/Aes_hw_cpu.asm 2011-06-01 17:12:53.080000002 -0400
+@@ -328,3 +328,12 @@
+
+
+ %endif ; __BITS__ != 16
++ %ifidn __OUTPUT_FORMAT__,elf
++ section .note.GNU-stack noalloc noexec nowrite progbits
++ %endif
++ %ifidn __OUTPUT_FORMAT__,elf32
++ section .note.GNU-stack noalloc noexec nowrite progbits
++ %endif
++ %ifidn __OUTPUT_FORMAT__,elf64
++ section .note.GNU-stack noalloc noexec nowrite progbits
++ %endif
+--- ./Crypto/AesSmall_x86.asm.old 2011-06-01 17:12:53.084000002 -0400
++++ ./Crypto/AesSmall_x86.asm 2011-06-01 17:12:53.086000002 -0400
+@@ -1442,3 +1442,12 @@
+ db v8(0xe1),v8(0x69),v8(0x14),v8(0x63),v8(0x55),v8(0x21),v8(0x0c),v8(0x7d)
+
+ %endif
++ %ifidn __OUTPUT_FORMAT__,elf
++ section .note.GNU-stack noalloc noexec nowrite progbits
++ %endif
++ %ifidn __OUTPUT_FORMAT__,elf32
++ section .note.GNU-stack noalloc noexec nowrite progbits
++ %endif
++ %ifidn __OUTPUT_FORMAT__,elf64
++ section .note.GNU-stack noalloc noexec nowrite progbits
++ %endif
+--- ./Crypto/Aes_x64.asm.old 2011-06-01 17:12:53.090000002 -0400
++++ ./Crypto/Aes_x64.asm 2011-06-01 17:12:53.092000002 -0400
+@@ -905,3 +905,12 @@
+ %endif
+
+ %endif
++ %ifidn __OUTPUT_FORMAT__,elf
++ section .note.GNU-stack noalloc noexec nowrite progbits
++ %endif
++ %ifidn __OUTPUT_FORMAT__,elf32
++ section .note.GNU-stack noalloc noexec nowrite progbits
++ %endif
++ %ifidn __OUTPUT_FORMAT__,elf64
++ section .note.GNU-stack noalloc noexec nowrite progbits
++ %endif
+--- ./Crypto/Aes_x86.asm.old 2011-06-01 17:12:53.096000002 -0400
++++ ./Crypto/Aes_x86.asm 2011-06-01 17:12:53.097000002 -0400
+@@ -644,3 +644,12 @@
+ do_exit
+
+ %endif
++ %ifidn __OUTPUT_FORMAT__,elf
++ section .note.GNU-stack noalloc noexec nowrite progbits
++ %endif
++ %ifidn __OUTPUT_FORMAT__,elf32
++ section .note.GNU-stack noalloc noexec nowrite progbits
++ %endif
++ %ifidn __OUTPUT_FORMAT__,elf64
++ section .note.GNU-stack noalloc noexec nowrite progbits
++ %endif
diff --git a/testing/truecrypt/truecrypt-arch-detection.patch b/testing/truecrypt/truecrypt-arch-detection.patch
new file mode 100644
index 000000000..bc16a2a36
--- /dev/null
+++ b/testing/truecrypt/truecrypt-arch-detection.patch
@@ -0,0 +1,15 @@
+diff -urN truecrypt-7.0a-source/Makefile truecrypt-7.0a-source.fixed/Makefile
+--- truecrypt-7.0a-source/Makefile 2010-09-05 10:32:10.000000000 -0400
++++ truecrypt-7.0a-source.fixed/Makefile 2011-07-05 21:41:50.296437879 -0400
+@@ -120,10 +120,7 @@
+
+ export CPU_ARCH ?= unknown
+
+-ARCH = $(shell uname -p)
+-ifeq "$(ARCH)" "unknown"
+- ARCH = $(shell uname -m)
+-endif
++ARCH = $(shell uname -m)
+
+ ifneq (,$(filter i386 i486 i586 i686 x86,$(ARCH)))
+ CPU_ARCH = x86
diff --git a/testing/truecrypt/truecrypt.desktop b/testing/truecrypt/truecrypt.desktop
new file mode 100644
index 000000000..53626f29f
--- /dev/null
+++ b/testing/truecrypt/truecrypt.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Exec=truecrypt
+Icon=truecrypt
+Comment=On-the-fly encryption
+Terminal=false
+Name=TrueCrypt
+StartupNotify=true
+Categories=System;