summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-11-10 19:02:52 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2011-11-10 18:06:36 +0000
commitaa5ae43b9507434a7a3609d7cd59ecaa8f117c36 (patch)
treef7a7c4c5cbfce5457d0946ba21b42145d8897139
parent61c5308f1e7d05233a0fd4506c9ffb62e8cd9f19 (diff)
downloadaports-aa5ae43b9507434a7a3609d7cd59ecaa8f117c36.tar.bz2
aports-aa5ae43b9507434a7a3609d7cd59ecaa8f117c36.tar.xz
main/linux-grsec: add patch from upstream align af specific flowi structs to long
-rw-r--r--main/linux-grsec/APKBUILD4
-rw-r--r--main/linux-grsec/net-align-af-specific-flowi-structs-to-long.patch50
2 files changed, 53 insertions, 1 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 907caf33c..879c8d9a8 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=3.0.8
_kernver=3.0
-pkgrel=3
+pkgrel=4
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs linux-firmware"
@@ -21,6 +21,7 @@ source="ftp://ftp.kernel.org/pub/linux/kernel/v3.0/linux-$_kernver.tar.bz2
0001-ipv4-fix-ipsec-forward-performance-regression.patch
0004-arp-flush-arp-cache-on-device-change.patch
net-handle-different-key-sizes-between-address-families-in-flow-cache.patch
+ net-align-af-specific-flowi-structs-to-long.patch
kernelconfig.x86
kernelconfig.x86_64
@@ -148,5 +149,6 @@ ebb99ef6ad8cd2d9fd8f49d5c5849057 0001-ip_gre-dont-increase-dev-needed_headroom-
b27bc150f7a3932de28fcb8803809cbc 0001-ipv4-fix-ipsec-forward-performance-regression.patch
776adeeb5272093574f8836c5037dd7d 0004-arp-flush-arp-cache-on-device-change.patch
2b71de1af5539744e2d9f1c37c0ff520 net-handle-different-key-sizes-between-address-families-in-flow-cache.patch
+b41bd511f527e360643453de796376a8 net-align-af-specific-flowi-structs-to-long.patch
464e2356a1983e1ffe261904a1d76338 kernelconfig.x86
d97d1808eebdfb97734dccfbcaea35f2 kernelconfig.x86_64"
diff --git a/main/linux-grsec/net-align-af-specific-flowi-structs-to-long.patch b/main/linux-grsec/net-align-af-specific-flowi-structs-to-long.patch
new file mode 100644
index 000000000..544c06f57
--- /dev/null
+++ b/main/linux-grsec/net-align-af-specific-flowi-structs-to-long.patch
@@ -0,0 +1,50 @@
+From 728871bc05afc8ff310b17dba3e57a2472792b13 Mon Sep 17 00:00:00 2001
+From: David Ward <david.ward@ll.mit.edu>
+Date: Mon, 5 Sep 2011 16:47:23 +0000
+Subject: net: Align AF-specific flowi structs to long
+
+From: David Ward <david.ward@ll.mit.edu>
+
+commit 728871bc05afc8ff310b17dba3e57a2472792b13 upstream.
+
+AF-specific flowi structs are now passed to flow_key_compare, which must
+also be aligned to a long.
+
+Signed-off-by: David Ward <david.ward@ll.mit.edu>
+Signed-off-by: David S. Miller <davem@davemloft.net>
+Cc: Kim Phillips <kim.phillips@freescale.com>
+Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
+
+---
+ include/net/flow.h | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+--- a/include/net/flow.h
++++ b/include/net/flow.h
+@@ -68,7 +68,7 @@ struct flowi4 {
+ #define fl4_ipsec_spi uli.spi
+ #define fl4_mh_type uli.mht.type
+ #define fl4_gre_key uli.gre_key
+-};
++} __attribute__((__aligned__(BITS_PER_LONG/8)));
+
+ static inline void flowi4_init_output(struct flowi4 *fl4, int oif,
+ __u32 mark, __u8 tos, __u8 scope,
+@@ -112,7 +112,7 @@ struct flowi6 {
+ #define fl6_ipsec_spi uli.spi
+ #define fl6_mh_type uli.mht.type
+ #define fl6_gre_key uli.gre_key
+-};
++} __attribute__((__aligned__(BITS_PER_LONG/8)));
+
+ struct flowidn {
+ struct flowi_common __fl_common;
+@@ -127,7 +127,7 @@ struct flowidn {
+ union flowi_uli uli;
+ #define fld_sport uli.ports.sport
+ #define fld_dport uli.ports.dport
+-};
++} __attribute__((__aligned__(BITS_PER_LONG/8)));
+
+ struct flowi {
+ union {