summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2011-11-07 08:57:43 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2011-11-07 08:58:16 +0000
commitdab2a3eaae74c39a1a259d944a66ea893741def0 (patch)
treeba4a9a2e88387b9d5e9bea9cb2ab7e96f15517d8
parent5a05ca12e58993fe875ed8c4d75a31e369981557 (diff)
downloadaports-dab2a3eaae74c39a1a259d944a66ea893741def0.tar.bz2
aports-dab2a3eaae74c39a1a259d944a66ea893741def0.tar.xz
testing/sarg: new aport
-rw-r--r--testing/dbmail/code-cleanups.patch64
-rw-r--r--testing/dbmail/gmime-2.6.patch32
-rw-r--r--testing/sarg/APKBUILD55
3 files changed, 55 insertions, 96 deletions
diff --git a/testing/dbmail/code-cleanups.patch b/testing/dbmail/code-cleanups.patch
deleted file mode 100644
index 83e8f7ea6..000000000
--- a/testing/dbmail/code-cleanups.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From 6af21775b8c560dd9d65cb2465299a9feae34649 Mon Sep 17 00:00:00 2001
-From: Paul J Stevens <paul@nfg.nl>
-Date: Thu, 14 Apr 2011 14:01:32 +0000
-Subject: cleanups
-
----
-diff --git a/debian/rules b/debian/rules
-index 7804a1b..f459149 100755
---- a/debian/rules
-+++ b/debian/rules
-@@ -12,7 +12,7 @@ export SHARED=--enable-static=no
- export MANPAGES=--enable-manpages=yes
- export REAL_CLEAN=
-
--CFLAGS = -Wall -O1
-+CFLAGS = -Wall -std=gnu99 -O1
- LDFLAGS = -lcrypt
-
- # These are used for cross-compiling and for saving the configure script
-@@ -27,10 +27,9 @@ ifneq (,$(findstring devel,$(DEB_BUILD_OPTIONS)))
- export MANPAGES=
- export SHARED=--enable-shared=no
- export STATIC=--enable-static=yes
-- export REAL_CLEAN=mrproper
- export WITH_LDAP=
- export WITH_SIEVE=
-- CFLAGS = -g -std=gnu99
-+ CFLAGS = -Wall -std=gnu99 -g
- endif
- ifneq (,$(findstring ldap,$(DEB_BUILD_OPTIONS)))
- export WITH_LDAP=--with-ldap
-diff --git a/src/dm_http.c b/src/dm_http.c
-index 4b7d2a6..797e63b 100644
---- a/src/dm_http.c
-+++ b/src/dm_http.c
-@@ -193,7 +193,7 @@ void Http_getUsers(T R)
- evbuffer_add_printf(buf, "\n}}\n");
- }
-
-- if (buf->totallen)
-+ if (EVBUFFER_LENGTH(buf))
- Request_send(R, HTTP_OK, "OK", buf);
- else
- Request_error(R, HTTP_SERVUNAVAIL, "Server error");
-@@ -279,7 +279,7 @@ void Http_getMailboxes(T R)
- MailboxState_free(&b);
- }
-
-- if (buf->totallen)
-+ if (EVBUFFER_LENGTH(buf))
- Request_send(R, HTTP_OK, "OK", buf);
- else
- Request_error(R, HTTP_SERVUNAVAIL, "Server error");
-@@ -375,7 +375,7 @@ void Http_getMessages(T R)
- }
- }
-
-- if (buf->totallen)
-+ if (EVBUFFER_LENGTH(buf))
- Request_send(R, HTTP_OK, "OK", buf);
- else
- Request_error(R, HTTP_SERVUNAVAIL, "Server error");
---
-cgit v0.8.3.4
diff --git a/testing/dbmail/gmime-2.6.patch b/testing/dbmail/gmime-2.6.patch
deleted file mode 100644
index 105ec5e6b..000000000
--- a/testing/dbmail/gmime-2.6.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- a/acinclude.m4.orig
-+++ b/acinclude.m4
-@@ -407,7 +407,7 @@
- AC_MSG_ERROR([pkg-config executable not found. Make sure pkg-config is in your path])
- else
- AC_MSG_CHECKING([GMime headers])
-- ac_gmime_cflags=`${gmimeconfig} --cflags gmime-2.4`
-+ ac_gmime_cflags=`${gmimeconfig} --cflags gmime-2.6`
- if test -z "$ac_gmime_cflags"
- then
- AC_MSG_RESULT([no])
-@@ -418,7 +418,7 @@
- fi
-
- AC_MSG_CHECKING([GMime libraries])
-- ac_gmime_libs=`${gmimeconfig} --libs gmime-2.4`
-+ ac_gmime_libs=`${gmimeconfig} --libs gmime-2.6`
- if test -z "$ac_gmime_libs"
- then
- AC_MSG_RESULT([no])
-@@ -427,9 +427,9 @@
- LDFLAGS="$LDFLAGS $ac_gmime_libs"
- AC_MSG_RESULT([$ac_gmime_libs])
- fi
-- ac_gmime_minvers="2.4.6"
-+ ac_gmime_minvers="2.6.0"
- AC_MSG_CHECKING([GMime version >= $ac_gmime_minvers])
-- ac_gmime_vers=`${gmimeconfig} --atleast-version=$ac_gmime_minvers gmime-2.4 && echo yes`
-+ ac_gmime_vers=`${gmimeconfig} --atleast-version=$ac_gmime_minvers gmime-2.6 && echo yes`
- if test -z "$ac_gmime_vers"
- then
- AC_MSG_ERROR([At least GMime version $ac_gmime_minvers is required.])
diff --git a/testing/sarg/APKBUILD b/testing/sarg/APKBUILD
new file mode 100644
index 000000000..96628569a
--- /dev/null
+++ b/testing/sarg/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=sarg
+pkgver=2.3.1
+pkgrel=0
+pkgdesc="SARG Squid Analysis Report Generator"
+url="http://sarg.sourceforge.net/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc $pkgname-php"
+source="http://sourceforge.net/projects/sarg/files/sarg/sarg-$pkgver/sarg-$pkgver.tar.gz"
+
+_builddir="$srcdir"/sarg-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/sarg \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+php() {
+ pkgdesc="SARG php interface"
+ depends="php"
+ arch="noarch"
+ cd "$_builddir"
+ mkdir -p "$subpkgdir"/usr/share/webapps
+ cp -a sarg-php \
+ "$subpkgdir"/usr/share/webapps
+}
+
+md5sums="bf637b8a820b81e2c55e815934151b4d sarg-2.3.1.tar.gz"