summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2012-12-06 18:50:10 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2012-12-06 18:54:26 +0100
commit31ac7d0b6e5e817a9099399764d84f40c81caad8 (patch)
tree84fa3e62c69474a96688db257f1516739e879f46
parent3b6ebba9ab54d866dbcef646b5170ab2534ee86f (diff)
downloadaports-31ac7d0b6e5e817a9099399764d84f40c81caad8.tar.bz2
aports-31ac7d0b6e5e817a9099399764d84f40c81caad8.tar.xz
main/ruby-unicorn: add init and default redmine config
-rw-r--r--main/ruby-unicorn/APKBUILD19
-rw-r--r--main/ruby-unicorn/redmine.conf.rb.sample103
-rw-r--r--main/ruby-unicorn/unicorn.confd4
-rw-r--r--main/ruby-unicorn/unicorn.initd (renamed from main/redmine/redmine.initd)20
4 files changed, 135 insertions, 11 deletions
diff --git a/main/ruby-unicorn/APKBUILD b/main/ruby-unicorn/APKBUILD
index d31901693..6fb8985aa 100644
--- a/main/ruby-unicorn/APKBUILD
+++ b/main/ruby-unicorn/APKBUILD
@@ -2,7 +2,7 @@
_gemname=unicorn
pkgname=ruby-unicorn
pkgver=4.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Unicorn is an HTTP server for Rack applications"
url="http://unicorn.bogomips.org"
arch="all"
@@ -12,7 +12,10 @@ depends_dev="ruby-dev"
makedepends="$depends_dev ruby-gems"
install=""
subpackages=""
-source="http://gems.rubyforge.org/gems/$_gemname-$pkgver.gem"
+source="http://gems.rubyforge.org/gems/$_gemname-$pkgver.gem
+ redmine.conf.rb.sample
+ unicorn.initd
+ unicorn.confd"
_builddir="$srcdir"/$_realname-$pkgver
build() {
@@ -30,6 +33,16 @@ package() {
rm -rf "$pkgdir"/$_gemdir/cache \
"$pkgdir"/$_geminstdir/ext \
"$pkgdir"/$_geminstdir/.require_paths
+ install -Dm644 "$srcdir"/$_gemname.confd \
+ "$pkgdir"/etc/conf.d/$_gemname
+ install -D -m755 "$srcdir"/$_gemname.initd \
+ "$pkgdir"/etc/init.d/$_gemname
+ # install sample redmine config
+ install -D -m644 "$srcdir"/redmine.conf.rb.sample \
+ "$pkgdir"/etc/unicorn/redmine.conf.rb.sample
}
-md5sums="00f52cd67c3ed7a7e0672104c6df9d7a unicorn-4.4.0.gem"
+md5sums="00f52cd67c3ed7a7e0672104c6df9d7a unicorn-4.4.0.gem
+5b7b9876f14488e5c84503d3d0351fb6 redmine.conf.rb.sample
+3b788ff54077428658e7044fb54c8364 unicorn.initd
+0745d4e1605ff961c83773613c68347d unicorn.confd"
diff --git a/main/ruby-unicorn/redmine.conf.rb.sample b/main/ruby-unicorn/redmine.conf.rb.sample
new file mode 100644
index 000000000..bb98e30f7
--- /dev/null
+++ b/main/ruby-unicorn/redmine.conf.rb.sample
@@ -0,0 +1,103 @@
+# Sample verbose configuration file for Unicorn (not Rack)
+#
+# This configuration file documents many features of Unicorn
+# that may not be needed for some applications. See
+# http://unicorn.bogomips.org/examples/unicorn.conf.minimal.rb
+# for a much simpler configuration file.
+#
+# See http://unicorn.bogomips.org/Unicorn/Configurator.html for complete
+# documentation.
+
+# Use at least one worker per core if you're on a dedicated server,
+# more will usually help for _short_ waits on databases/caches.
+worker_processes 2
+
+# Since Unicorn is never exposed to outside clients, it does not need to
+# run on the standard HTTP port (80), there is no reason to start Unicorn
+# as root unless it's from system init scripts.
+# If running the master process as root and the workers as an unprivileged
+# user, do this to switch euid/egid in the workers (also chowns logs):
+# user "unprivileged_user", "unprivileged_group"
+user "redmine", "redmine"
+
+# Help ensure your application will always spawn in the symlinked
+# "current" directory that Capistrano sets up.
+working_directory "/usr/share/webapps/redmine" # available in 0.94.0+
+
+# listen on both a Unix domain socket and a TCP port,
+# we use a shorter backlog for quicker failover when busy
+listen "/var/run/unicorn.sock", :backlog => 64
+listen 8080, :tcp_nopush => true
+
+# nuke workers after 30 seconds instead of 60 seconds (the default)
+#timeout 30
+
+# feel free to point this anywhere accessible on the filesystem
+pid "/usr/share/webapps/redmine/tmp/pids/unicorn.pid"
+
+# By default, the Unicorn logger will write to stderr.
+# Additionally, ome applications/frameworks log to stderr or stdout,
+# so prevent them from going to /dev/null when daemonized here:
+stderr_path "/var/log/redmine/unicorn.log"
+stdout_path "/var/log/redmine/unicorn.log"
+
+# combine Ruby 2.0.0dev or REE with "preload_app true" for memory savings
+# http://rubyenterpriseedition.com/faq.html#adapt_apps_for_cow
+preload_app true
+GC.respond_to?(:copy_on_write_friendly=) and
+ GC.copy_on_write_friendly = true
+
+# Enable this flag to have unicorn test client connections by writing the
+# beginning of the HTTP headers before calling the application. This
+# prevents calling the application for connections that have disconnected
+# while queued. This is only guaranteed to detect clients on the same
+# host unicorn runs on, and unlikely to detect disconnects even on a
+# fast LAN.
+#check_client_connection false
+
+before_fork do |server, worker|
+ # the following is highly recomended for Rails + "preload_app true"
+ # as there's no need for the master process to hold a connection
+ defined?(ActiveRecord::Base) and
+ ActiveRecord::Base.connection.disconnect!
+
+ # The following is only recommended for memory/DB-constrained
+ # installations. It is not needed if your system can house
+ # twice as many worker_processes as you have configured.
+ #
+ # # This allows a new master process to incrementally
+ # # phase out the old master process with SIGTTOU to avoid a
+ # # thundering herd (especially in the "preload_app false" case)
+ # # when doing a transparent upgrade. The last worker spawned
+ # # will then kill off the old master process with a SIGQUIT.
+ # old_pid = "#{server.config[:pid]}.oldbin"
+ # if old_pid != server.pid
+ # begin
+ # sig = (worker.nr + 1) >= server.worker_processes ? :QUIT : :TTOU
+ # Process.kill(sig, File.read(old_pid).to_i)
+ # rescue Errno::ENOENT, Errno::ESRCH
+ # end
+ # end
+ #
+ # Throttle the master from forking too quickly by sleeping. Due
+ # to the implementation of standard Unix signal handlers, this
+ # helps (but does not completely) prevent identical, repeated signals
+ # from being lost when the receiving process is busy.
+ # sleep 1
+end
+
+after_fork do |server, worker|
+ # per-process listener ports for debugging/admin/migrations
+ # addr = "127.0.0.1:#{9293 + worker.nr}"
+ # server.listen(addr, :tries => -1, :delay => 5, :tcp_nopush => true)
+
+ # the following is *required* for Rails + "preload_app true",
+ defined?(ActiveRecord::Base) and
+ ActiveRecord::Base.establish_connection
+
+ # if preload_app is true, then you may also want to check and
+ # restart any other shared sockets/descriptors such as Memcached,
+ # and Redis. TokyoCabinet file handles are safe to reuse
+ # between any number of forked children (assuming your kernel
+ # correctly implements pread()/pwrite() system calls)
+end
diff --git a/main/ruby-unicorn/unicorn.confd b/main/ruby-unicorn/unicorn.confd
new file mode 100644
index 000000000..28e3df1a2
--- /dev/null
+++ b/main/ruby-unicorn/unicorn.confd
@@ -0,0 +1,4 @@
+# unicorn configuration file
+CONF=""
+# app enviorment. ie developement,production
+ENV="production"
diff --git a/main/redmine/redmine.initd b/main/ruby-unicorn/unicorn.initd
index 3371c6d98..228023cd3 100644
--- a/main/redmine/redmine.initd
+++ b/main/ruby-unicorn/unicorn.initd
@@ -3,8 +3,6 @@
gem_path=$(gem env gemdir)
name="unicorn_rails"
start_script="$gem_path/bin/$name"
-app_dir="/usr/share/webapps/redmine"
-user="redmine"
depend() {
use logger dns
@@ -13,17 +11,17 @@ depend() {
}
start() {
- ebegin "Starting redmine"
+ checkconfig || return 1
+
+ ebegin "Starting unicorn"
start-stop-daemon --start --quiet \
- -u $user \
- -d $app_dir \
$start_script -- \
- -D -E production
+ -D -E $ENV -c $CONF
eend $?
}
stop() {
- ebegin "Stopping redmine"
+ ebegin "Stopping unicorn"
start-stop-daemon --stop \
--name $name
eend $?
@@ -32,9 +30,15 @@ stop() {
reload() {
- ebegin "Reload redmine"
+ ebegin "Reload unicorn"
start-stop-daemon --signal USR2 \
--name $name
eend $?
}
+checkconfig() {
+ if [ -z "$CONF" ]; then
+ eerror "No configuration file set in confd!"
+ return 1
+ fi
+}