summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-03-07 18:21:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-03-07 18:23:46 +0000
commit19ff5e432f3bdee852d9709eb04ff510e6079f95 (patch)
tree1e141dca8616e980719f138c5b61f3804c45c8fc
parentfb04849def7da2ca3d9a2f84367bfbc002eee25d (diff)
downloadaports-19ff5e432f3bdee852d9709eb04ff510e6079f95.tar.bz2
aports-19ff5e432f3bdee852d9709eb04ff510e6079f95.tar.xz
main/xf86-video-xgixp: rebuild against xorg-server-1.14
-rw-r--r--main/xf86-video-xgixp/APKBUILD12
-rw-r--r--main/xf86-video-xgixp/mibstore.patch33
2 files changed, 42 insertions, 3 deletions
diff --git a/main/xf86-video-xgixp/APKBUILD b/main/xf86-video-xgixp/APKBUILD
index 5074db897..c835545b4 100644
--- a/main/xf86-video-xgixp/APKBUILD
+++ b/main/xf86-video-xgixp/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-xgixp
pkgver=1.8.1
-pkgrel=1
+pkgrel=3
pkgdesc="X.org XGIXP video driver"
url="http://xorg.freedesktop.org/"
arch="all"
@@ -9,7 +9,8 @@ license="custom"
subpackages="$pkgname-doc"
depends=
makedepends="xorg-server-dev libdrm-dev xf86driproto glproto mesa-dev"
-source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
+source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2
+ mibstore.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -35,4 +36,9 @@ package() {
rm "$pkgdir"/usr/lib/xorg/modules/drivers/*.la || return 1
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-md5sums="590ec61b6368fee3805623958eb843cb xf86-video-xgixp-1.8.1.tar.bz2"
+md5sums="590ec61b6368fee3805623958eb843cb xf86-video-xgixp-1.8.1.tar.bz2
+a0a94fbe8a52e447239c50b5b10709a0 mibstore.patch"
+sha256sums="e1c6cbbc5756c8bac92334b77863ef406ad8e5ddf07c8af89204299ca0c41d55 xf86-video-xgixp-1.8.1.tar.bz2
+746906ed2b6f8506e022645b0707cd6a806c60cc7ad6408c57d8463d6b0d8dcb mibstore.patch"
+sha512sums="ab45909e4b48cc9dfa3daf5d2cb50dff6ad7d841fe1dc75ea699a7c555d70a6f565d97b7c68f4c58da16ad022b973892e229f8d0f4059c8712cf513c1ec10f84 xf86-video-xgixp-1.8.1.tar.bz2
+903d5dc755e78dd1438eb808beec2b845bebadf7c14e9666a8cde695326a71c5598096854c3cfc915f604c08525d6abe444dfecbe0b08381205898a74fa20a79 mibstore.patch"
diff --git a/main/xf86-video-xgixp/mibstore.patch b/main/xf86-video-xgixp/mibstore.patch
new file mode 100644
index 000000000..bf56d1527
--- /dev/null
+++ b/main/xf86-video-xgixp/mibstore.patch
@@ -0,0 +1,33 @@
+From a84753dd495bcfd724406cae470e17d0c561d0c3 Mon Sep 17 00:00:00 2001
+From: Adam Jackson <ajax@redhat.com>
+Date: Tue, 25 Sep 2012 12:55:05 +0000
+Subject: Remove mibstore.h
+
+Signed-off-by: Adam Jackson <ajax@redhat.com>
+---
+diff --git a/src/xgi_driver.c b/src/xgi_driver.c
+index 580a03a..8ce071b 100644
+--- a/src/xgi_driver.c
++++ b/src/xgi_driver.c
+@@ -53,8 +53,6 @@
+
+ /* initialise a SW cursor */
+ #include "mipointer.h"
+-/* implementing backing store */
+-#include "mibstore.h"
+
+ /* colormap initialization */
+ #include "micmap.h"
+@@ -2041,10 +2039,6 @@ pScrn->pScreen = pScreen;
+ xf86DrvMsg(pScrn->scrnIndex, X_ERROR, "FB Manager init failed \n");
+ }
+
+- /* If backing store is to be supported (as is usually the case), initialise it. */
+- miInitializeBackingStore(pScreen);
+- XGIDebug(DBG_FUNCTION, "[DBG] Jong 06142006-After miInitializeBackingStore()\n");
+-
+ xf86SetBackingStore(pScreen);
+ XGIDebug(DBG_FUNCTION, "[DBG] Jong 06142006-After xf86SetBackingStore()\n");
+
+--
+cgit v0.9.0.2-2-gbebe