summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-03-07 18:19:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-03-07 18:23:46 +0000
commitfb04849def7da2ca3d9a2f84367bfbc002eee25d (patch)
tree896dfc5315f2e0c27d2f7028304391f03f9432b9
parent4ba7acab73a869905a648d34946b33ba963e2298 (diff)
downloadaports-fb04849def7da2ca3d9a2f84367bfbc002eee25d.tar.bz2
aports-fb04849def7da2ca3d9a2f84367bfbc002eee25d.tar.xz
main/xf86-video-vmware: rebuild against xorg-server-1.14
-rw-r--r--main/xf86-video-vmware/APKBUILD11
-rw-r--r--main/xf86-video-vmware/mibrestore.patch59
2 files changed, 67 insertions, 3 deletions
diff --git a/main/xf86-video-vmware/APKBUILD b/main/xf86-video-vmware/APKBUILD
index 77ba891ed..8bda6149f 100644
--- a/main/xf86-video-vmware/APKBUILD
+++ b/main/xf86-video-vmware/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xf86-video-vmware
pkgver=13.0.0
-pkgrel=0
+pkgrel=2
pkgdesc="X.org VMWare video driver"
url="http://xorg.freedesktop.org/"
arch="all"
@@ -11,7 +11,7 @@ depends=
makedepends="pkgconfig xorg-server-dev videoproto renderproto xproto libdrm-dev
fontsproto xf86dgaproto xineramaproto randrproto xextproto libxi-dev"
-patches=""
+patches="mibrestore.patch"
source="http://xorg.freedesktop.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2
$patches"
@@ -37,4 +37,9 @@ package() {
rm "$pkgdir"/usr/lib/xorg/modules/*/*.la || return 1
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-md5sums="b72be57517cbc7a56362f2ee0f092269 xf86-video-vmware-13.0.0.tar.bz2"
+md5sums="b72be57517cbc7a56362f2ee0f092269 xf86-video-vmware-13.0.0.tar.bz2
+26baa4516d64878e3b982dc0a9deefd1 mibrestore.patch"
+sha256sums="44919ecd88654f2ab40a1732b5ea6a1dbd1c696b4b0748e68e8b5f1a3486bca6 xf86-video-vmware-13.0.0.tar.bz2
+f016b5e605f806caf43f7d532a58474af3a7bc41baa2ed3b745248dcc2b13413 mibrestore.patch"
+sha512sums="4106c17469dc1d7fd3d6a9acd5c45d0cdae0d7c8c5ad9463d24de138fd67dbdf09cd32e0665063822d12dad512b27ccd16497097484551778fffabf7db8d5cfe xf86-video-vmware-13.0.0.tar.bz2
+4a9d6d1903cd8eea555f33578222d7cf019f4ba4523aecc2df9d1f6ce0fe050a4a73f0026280d5a11902cd37277d35a83f9d2ae9faed0f60fd07b33541e3552a mibrestore.patch"
diff --git a/main/xf86-video-vmware/mibrestore.patch b/main/xf86-video-vmware/mibrestore.patch
new file mode 100644
index 000000000..822c6bcb9
--- /dev/null
+++ b/main/xf86-video-vmware/mibrestore.patch
@@ -0,0 +1,59 @@
+From b91093db9412b35c7c930f88bc41402d212dd91d Mon Sep 17 00:00:00 2001
+From: Adam Jackson <ajax@redhat.com>
+Date: Wed, 9 Jan 2013 23:10:16 -0500
+Subject: [PATCH] Remove mibstore.h
+
+Signed-off-by: Adam Jackson <ajax@redhat.com>
+---
+ saa/saa_priv.h | 1 -
+ src/vmware.c | 2 --
+ vmwgfx/vmwgfx_driver.c | 1 -
+ 3 files changed, 4 deletions(-)
+
+diff --git a/saa/saa_priv.h b/saa/saa_priv.h
+index 6652054..5d81453 100644
+--- a/saa/saa_priv.h
++++ b/saa/saa_priv.h
+@@ -48,7 +48,6 @@
+ #include "pixmapstr.h"
+ #include "windowstr.h"
+ #include "servermd.h"
+-#include "mibstore.h"
+ #include "colormapst.h"
+ #include "gcstruct.h"
+ #include "input.h"
+diff --git a/src/vmware.c b/src/vmware.c
+index 41201f1..6b74e14 100644
+--- a/src/vmware.c
++++ b/src/vmware.c
+@@ -23,7 +23,6 @@ char rcsId_vmware[] =
+ #include "xf86Pci.h" /* pci */
+
+ #include "mipointer.h" /* sw cursor */
+-#include "mibstore.h" /* backing store */
+ #include "micmap.h" /* mi color map */
+ #include "vgaHW.h" /* VGA hardware */
+ #include "fb.h"
+@@ -1483,7 +1482,6 @@ VMWAREScreenInit(SCREEN_INIT_ARGS_DECL)
+ * If backing store is to be supported (as is usually the case),
+ * initialise it.
+ */
+- miInitializeBackingStore(pScreen);
+ xf86SetBackingStore(pScreen);
+ xf86SetSilkenMouse(pScreen);
+
+diff --git a/vmwgfx/vmwgfx_driver.c b/vmwgfx/vmwgfx_driver.c
+index 9959ffb..7863ba2 100644
+--- a/vmwgfx/vmwgfx_driver.c
++++ b/vmwgfx/vmwgfx_driver.c
+@@ -1036,7 +1036,6 @@ drv_screen_init(SCREEN_INIT_ARGS_DECL)
+ (ms->only_hw_presents) ? "enabled" : "disabled");
+ }
+
+- miInitializeBackingStore(pScreen);
+ xf86SetBackingStore(pScreen);
+ xf86SetSilkenMouse(pScreen);
+ miDCInitialize(pScreen, xf86GetPointerScreenFuncs());
+--
+1.8.0.2
+