summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-04-14 08:48:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-04-14 08:51:09 +0000
commitdf0f8b4f9ac278bf02d3f2234ab83376bba27161 (patch)
tree4cb0df6878d46a9ae12b1008df640c06d2768104
parentc1247b451a2d1b5a2a0df46e48c114b66a938aec (diff)
downloadaports-df0f8b4f9ac278bf02d3f2234ab83376bba27161.tar.bz2
aports-df0f8b4f9ac278bf02d3f2234ab83376bba27161.tar.xz
main/aports-build: add config option for which formats we do releases
For now this only indicates if we want make release or not.
-rw-r--r--main/aports-build/APKBUILD14
-rw-r--r--main/aports-build/aports-build9
-rw-r--r--main/aports-build/aports-build.confd3
3 files changed, 15 insertions, 11 deletions
diff --git a/main/aports-build/APKBUILD b/main/aports-build/APKBUILD
index c80a0de07..124d2144b 100644
--- a/main/aports-build/APKBUILD
+++ b/main/aports-build/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=aports-build
pkgver=0.6
-pkgrel=1
+pkgrel=2
pkgdesc="MQTT based build-on-git-push scripts for Alpine Linux"
url="http://alpinelinux.org"
arch="noarch"
@@ -39,12 +39,12 @@ package() {
"$pkgdir"/etc/conf.d/aports-build || return 1
}
-md5sums="881bc1da8b754a0fa78c585c96939376 aports-build
+md5sums="e3aecf9b43607646e154de430517fdbf aports-build
784238e965ca025c0c6ed13c8af01613 aports-build.initd
-cdc49e0ef145de72131972a575f20e7b aports-build.confd"
-sha256sums="3c365dfe7e4b535fd6e00aa77f926f6b137e15cb66979e7ad2e74f570aa56372 aports-build
+711d8f441b97c54a9561c08925d16d75 aports-build.confd"
+sha256sums="493040e52324529d8d7e3bb9243788484d9f52a2bb63f9081ac87c00f24c8df5 aports-build
88215b5969e5ffeda549c6e31de4563569ddee2ac3220c381d40f382d43f8323 aports-build.initd
-519744cdb4be83e5da1c22d4aa93c7ef97d66e03565e84b710bc21c94b82047e aports-build.confd"
-sha512sums="243dfd8d8325695b73123c6c3f6eb338ed47eed281ae21439a9642c17375fac6b490a16ec4a2fdb88ae2ab6f148c6da7181ad013f1fd95c9cfa84d804d32ab43 aports-build
+e14940240ffac141b98903214af858c93a36b5a9f133b97a81871f9d56efff6b aports-build.confd"
+sha512sums="8f418758b955b1eea67e9d48e4c4f7aa1a6c3230871c5f4bf1a15349dd07cae7d74a84ffeec1e59c94b2568f8549e63dcb47a22552710184ba53c3908b13e97d aports-build
2ef2fa6de4118209ab93a56216f106ac32078df762f4d67e900976c28bea96d44806f4679ef966472a3eb05fdaf1648aab17c0eaa897e8a06b1272766f29d22b aports-build.initd
-fbe8ed4b1fbfc979de62302873e99c67bab751a7fcd921c3b23815f535cedb34c717e82b3c223f88e06498a573cbd147a73db7bf5adbb5e1947ac75fcb8edcb4 aports-build.confd"
+60c62f25834fce29df73b0e64b733c8b9bbd362c130d04ba33f8dbf042b6b7fbb6193beb84ba9c811b3aef1997675bbb3eeedbbf935e4ae005370c4b4a013d26 aports-build.confd"
diff --git a/main/aports-build/aports-build b/main/aports-build/aports-build
index 1ed209920..8c972a922 100644
--- a/main/aports-build/aports-build
+++ b/main/aports-build/aports-build
@@ -107,6 +107,7 @@ done
shift $(( $OPTIND - 1 ))
while true; do
+ local do_release=false
cd $aports || return 1
# check if we need to rebuild
log "pulling git"
@@ -118,6 +119,9 @@ while true; do
_current_tag=$(git describe --abbrev=0)
if [ "$_old_tag" != "$_current_tag" ]; then
log "$_old_tag -> $_current_tag"
+ if [ -n "$release_formats" ]; then
+ do_release=true
+ fi
fi
if [ "$_old" = "$_current" ] && [ -f /tmp/uploaded ] && [ -z "$force" ] && [ "$_current_tag" = "$_old_tag" ]; then
break
@@ -126,7 +130,7 @@ while true; do
force=
# check if we need make new release
- if [ "$_current_tag" != "$_old_tag" ]; then
+ if $do_release; then
_new_release=1
# we want build the realease from this tag
git checkout "$_current_tag"
@@ -168,8 +172,7 @@ while true; do
# report to irc that we are done
send_irc "files from $_current uploaded"
- # if
- if [ "$_current_tag" != "$_old_tag" ]; then
+ if $do_release; then
if new_release ${_current_tag#v}; then
send_irc "release $_current_tag uploaded"
fi
diff --git a/main/aports-build/aports-build.confd b/main/aports-build/aports-build.confd
index a43d1c39d..1a7320978 100644
--- a/main/aports-build/aports-build.confd
+++ b/main/aports-build/aports-build.confd
@@ -7,4 +7,5 @@ git_branch=master
# prefix for url where logs can be found
# logurlprefix=http://bld1.alpinelinux.org/buildlogs
-
+# list of release formats. unset for no release
+# release_formats="iso"