summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-05-14 14:55:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-05-14 15:05:23 +0000
commit79df80b23fcb065914d045cc68ebc355c5a7952d (patch)
treea936c2a1aa5c1231d4bc6202d76c3d708dabe156
parentd47fd4efdbbbb95011b1001c2053413310a061a4 (diff)
downloadaports-79df80b23fcb065914d045cc68ebc355c5a7952d.tar.bz2
aports-79df80b23fcb065914d045cc68ebc355c5a7952d.tar.xz
main/avahi-ui: new aport
We splitted out the ui libs and tools to avoid the circular deps: avahi -> gtk -> cups -> avahi
-rw-r--r--main/avahi-ui/APKBUILD107
-rw-r--r--main/avahi-ui/avahi-0.6.31-no-deprecations.patch100
-rw-r--r--main/avahi-ui/gnome-nettool.pngbin0 -> 4509 bytes
-rw-r--r--main/avahi-ui/musl-fix.patch65
-rw-r--r--main/avahi-ui/system-avahi.patch30
5 files changed, 302 insertions, 0 deletions
diff --git a/main/avahi-ui/APKBUILD b/main/avahi-ui/APKBUILD
new file mode 100644
index 000000000..146e1a0c7
--- /dev/null
+++ b/main/avahi-ui/APKBUILD
@@ -0,0 +1,107 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=avahi-ui
+pkgver=0.6.31
+pkgrel=5
+pkgdesc="Gtk user interface library for Avahi"
+url="http://www.avahi.org/"
+arch="all"
+license="LGPL2+"
+depends=""
+depends_dev="gtk+3.0-dev gtk+2.0-dev gdbm-dev avahi-dev"
+makedepends="$depends_dev py-gobject3-dev py-gtk-dev py-dbus-dev intltool
+ gobject-introspection-dev expat-dev libdaemon-dev glib-dev dbus-dev
+ libcap-dev py-gdbm
+ autoconf automake libtool"
+install=""
+subpackages="$pkgname-dev $pkgname-tools $pkgname-gtk3"
+patches="musl-fix.patch
+ avahi-0.6.31-no-deprecations.patch
+ system-avahi.patch"
+source="http://www.avahi.org/download/avahi-$pkgver.tar.gz
+ $patches
+ gnome-nettool.png"
+
+_subdirs="avahi-ui avahi-python"
+_builddir="$srcdir"/avahi-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $patches; do
+ patch -p1 -i "$srcdir"/$i || return 1
+ done
+ update_config_sub || return 1
+ libtoolize --force && aclocal -I m4 && autoconf \
+ && automake --add-missing
+}
+
+build() {
+ cd "$_builddir"
+ # we dont build autoipd since dhcpcd does same job
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-autoipd \
+ --disable-qt3 \
+ --disable-qt4 \
+ --enable-gtk3 \
+ --disable-mono \
+ --disable-monodoc \
+ --disable-doxygen-doc \
+ --disable-xmltoman \
+ --disable-compat-libdns_sd \
+ --disable-compat-howl \
+ --with-distro="gentoo" \
+ --with-systemdsystemunitdir=/lib/systemd/system \
+ --disable-static \
+ --enable-shared \
+ || return 1
+ for i in $_subdirs; do
+ (cd $i && make) || return 1
+ done
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/bin || return 1
+ for i in avahi-ui avahi-python; do
+ ( cd $i && make DESTDIR="$pkgdir" install) || return 1
+ done
+ rm -r "$pkgdir"/usr/lib/*.la \
+ "$pkgdir"/usr/lib/py* || return 1
+}
+
+tools() {
+ pkgdesc="UI tools for mDNS browsing"
+ depends="py-gtk py-dbus py-gdbm py-avahi"
+ mkdir -p "$subpkgdir"/usr/bin
+ cd "$pkgdir"/usr/bin
+ mv avahi-bookmarks avahi-discover avahi-discover-standalone b* \
+ "$subpkgdir"/usr/bin/
+ install -D -m 644 "$srcdir"/gnome-nettool.png \
+ "$subpkgdir"/usr/share/pixmaps/gnome-nettool.png
+}
+
+gtk3() {
+ pkgdesc="Gtk3 user interface library for Avahi"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libavahi-ui-gtk3.so.* \
+ "$subpkgdir"/usr/lib/
+}
+
+md5sums="2f22745b8f7368ad5a0a3fddac343f2d avahi-0.6.31.tar.gz
+9557450128d0e4324405af2c625dc8c7 musl-fix.patch
+c3f9cdb20bfbaa575f86e2fe4a7783bf avahi-0.6.31-no-deprecations.patch
+880936938b6793b5fe675622eb513838 system-avahi.patch
+42c2905307c7a5dc6ac4b75f4c3d65a3 gnome-nettool.png"
+sha256sums="8372719b24e2dd75de6f59bb1315e600db4fd092805bd1201ed0cb651a2dab48 avahi-0.6.31.tar.gz
+c43a60cf9cddb3cc8c88c13d78dbf0c6a7f1e3ff1f73e1305d465547cadd6a58 musl-fix.patch
+a30a5c3fbf07e1035021f92735ef7cbfbfd6e5a2324daca4cd034321f037ec9d avahi-0.6.31-no-deprecations.patch
+7731752997475c358129d6f716b1b76e715642c21184844666f51a3b040a12d8 system-avahi.patch
+88cbac3316fd0ad10bb7d054dcd53ab822517a1d9bbb70a31cd754dcd59e94b9 gnome-nettool.png"
+sha512sums="53eb00d570a274d841e1e6ad07da077950089ae39b4f7aa21fcd21cc5320b30b506b43e7e57e56198e155cc7bd289b779a48b2b2fc002dc6194a946110451858 avahi-0.6.31.tar.gz
+09ae19b3c8641cdbeaabf1af69852e297d7445dfaf259b43d9de8a04c5d31722ecb2fb921feb44925a5364e69bd514c47be90f532493b087879abf9f53a8fe11 musl-fix.patch
+488699dd1d3cc39c4efc972ac6e9afa306208a23fe028454951c8009a34f974dbd19f16d6737bfea93660559728080508e06e32de0718db4f2dda9624031002a avahi-0.6.31-no-deprecations.patch
+99723e66889601044ac5ca919e79aa328083cb377bb3d270f3e8d2baee27505f967949f72faa0424756e5f18b1359fd7f7fb30636861d47455ff7b92ed48bcfa system-avahi.patch
+d8e92fcdd82759f8de536ebfa356fe208c27b2d998ce5bb51d585dffc163dc16228be4a7108644fe1a11defbe750244bc8105a430b1397297cdef4cb83ab0db5 gnome-nettool.png"
diff --git a/main/avahi-ui/avahi-0.6.31-no-deprecations.patch b/main/avahi-ui/avahi-0.6.31-no-deprecations.patch
new file mode 100644
index 000000000..83b13cda6
--- /dev/null
+++ b/main/avahi-ui/avahi-0.6.31-no-deprecations.patch
@@ -0,0 +1,100 @@
+<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
+ "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
+<html xmlns='http://www.w3.org/1999/xhtml' xml:lang='en' lang='en'>
+<head>
+<title>avahi.git - avahi</title>
+<meta name='generator' content='cgit v0.10.1'/>
+<meta name='robots' content='index, nofollow'/>
+<link rel='stylesheet' type='text/css' href='/cgit-data/cgit.css'/>
+<link rel='shortcut icon' href='/favicon.ico'/>
+<link rel='alternate' title='Atom feed' href='http://pkgs.fedoraproject.org/cgit/avahi.git/atom/avahi-0.6.31-no-deprecations.patch?h=master' type='application/atom+xml'/>
+</head>
+<body>
+<div id='cgit'><table id='header'>
+<tr>
+<td class='logo' rowspan='2'><a href='/cgit/'><img src='/cgit-data/cgit.png' alt='cgit logo'/></a></td>
+<td class='main'><a href='/cgit/'>index</a> : <a title='avahi.git' href='/cgit/avahi.git/'>avahi.git</a></td><td class='form'><form method='get' action=''>
+<select name='h' onchange='this.form.submit();'>
+<option value='f10'>f10</option>
+<option value='f11'>f11</option>
+<option value='f12'>f12</option>
+<option value='f13'>f13</option>
+<option value='f14'>f14</option>
+<option value='f15'>f15</option>
+<option value='f16'>f16</option>
+<option value='f17'>f17</option>
+<option value='f18'>f18</option>
+<option value='f19'>f19</option>
+<option value='f20'>f20</option>
+<option value='f7'>f7</option>
+<option value='f8'>f8</option>
+<option value='f9'>f9</option>
+<option value='master' selected='selected'>master</option>
+<option value='olpc2'>olpc2</option>
+</select> <input type='submit' name='' value='switch'/></form></td></tr>
+<tr><td class='sub'>avahi</td><td class='sub right'>Jesse Keating</td></tr></table>
+<table class='tabs'><tr><td>
+<a href='/cgit/avahi.git/'>summary</a><a href='/cgit/avahi.git/refs/'>refs</a><a href='/cgit/avahi.git/log/avahi-0.6.31-no-deprecations.patch'>log</a><a class='active' href='/cgit/avahi.git/tree/avahi-0.6.31-no-deprecations.patch'>tree</a><a href='/cgit/avahi.git/commit/avahi-0.6.31-no-deprecations.patch'>commit</a><a href='/cgit/avahi.git/diff/avahi-0.6.31-no-deprecations.patch'>diff</a><a href='/cgit/avahi.git/stats/avahi-0.6.31-no-deprecations.patch'>stats</a></td><td class='form'><form class='right' method='get' action='/cgit/avahi.git/log/avahi-0.6.31-no-deprecations.patch'>
+<select name='qt'>
+<option value='grep'>log msg</option>
+<option value='author'>author</option>
+<option value='committer'>committer</option>
+<option value='range'>range</option>
+</select>
+<input class='txt' type='text' size='10' name='q' value=''/>
+<input type='submit' value='search'/>
+</form>
+</td></tr></table>
+<div class='path'>path: <a href='/cgit/avahi.git/tree/'>root</a>/<a href='/cgit/avahi.git/tree/avahi-0.6.31-no-deprecations.patch'>avahi-0.6.31-no-deprecations.patch</a></div><div class='content'>blob: 9ca9d38dec7cfc91b5446d6f2da21c847703cb54 (<a href='/cgit/avahi.git/plain/avahi-0.6.31-no-deprecations.patch'>plain</a>)
+<table summary='blob content' class='blob'>
+<tr><td class='linenumbers'><pre><a id='n1' href='#n1'>1</a>
+<a id='n2' href='#n2'>2</a>
+<a id='n3' href='#n3'>3</a>
+<a id='n4' href='#n4'>4</a>
+<a id='n5' href='#n5'>5</a>
+<a id='n6' href='#n6'>6</a>
+<a id='n7' href='#n7'>7</a>
+<a id='n8' href='#n8'>8</a>
+<a id='n9' href='#n9'>9</a>
+<a id='n10' href='#n10'>10</a>
+<a id='n11' href='#n11'>11</a>
+<a id='n12' href='#n12'>12</a>
+<a id='n13' href='#n13'>13</a>
+<a id='n14' href='#n14'>14</a>
+<a id='n15' href='#n15'>15</a>
+<a id='n16' href='#n16'>16</a>
+<a id='n17' href='#n17'>17</a>
+<a id='n18' href='#n18'>18</a>
+<a id='n19' href='#n19'>19</a>
+<a id='n20' href='#n20'>20</a>
+<a id='n21' href='#n21'>21</a>
+<a id='n22' href='#n22'>22</a>
+</pre></td>
+<td class='lines'><pre><code>--- avahi-0.6.31/avahi-ui/Makefile.am.orig 2013-09-21 16:47:28.677659361 +0200
++++ avahi-0.6.31/avahi-ui/Makefile.am 2013-09-21 16:47:34.852520537 +0200
+@@ -15,7 +15,7 @@
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+ # USA.
+
+-AM_CFLAGS=-I$(top_srcdir) -DG_DISABLE_DEPRECATED=1 -DGDK_DISABLE_DEPRECATED=1 -DGTK_DISABLE_DEPRECATED=1
++AM_CFLAGS=-I$(top_srcdir)
+
+ # This cool debug trap works on i386/gcc only
+ AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
+--- avahi-0.6.31/configure.ac.orig 2013-09-21 16:46:43.750669413 +0200
++++ avahi-0.6.31/configure.ac 2013-09-21 16:47:02.566246400 +0200
+@@ -92,7 +92,7 @@
+ AC_MSG_CHECKING([whether stack-smashing protection is available])
+ ssp_old_cflags="$CFLAGS"
+ ssp_old_ldflags="$LDFLAGS"
+- CFLAGS="$CFLAGS -Werror -fstack-protector-all -fPIC"
++ CFLAGS="$CFLAGS -fstack-protector-all -fPIC"
+ LDFLAGS="$LDFLAGS -Wl,-z,defs"
+ cat confdefs.h &gt; conftest.c
+ cat &gt;&gt;conftest.c &lt;&lt;_ACEOF
+</code></pre></td></tr></table>
+</div> <!-- class=content -->
+<div class='footer'>generated by cgit v0.10.1 at 2014-05-14 13:49:24 (GMT)</div>
+</div> <!-- id=cgit -->
+</body>
+</html>
diff --git a/main/avahi-ui/gnome-nettool.png b/main/avahi-ui/gnome-nettool.png
new file mode 100644
index 000000000..227d0678a
--- /dev/null
+++ b/main/avahi-ui/gnome-nettool.png
Binary files differ
diff --git a/main/avahi-ui/musl-fix.patch b/main/avahi-ui/musl-fix.patch
new file mode 100644
index 000000000..a331e6453
--- /dev/null
+++ b/main/avahi-ui/musl-fix.patch
@@ -0,0 +1,65 @@
+diff --git a/avahi-common/simple-watch.c b/avahi-common/simple-watch.c
+index 8df18dd..08d8090 100644
+--- a/avahi-common/simple-watch.c
++++ b/avahi-common/simple-watch.c
+@@ -21,7 +21,7 @@
+ #include <config.h>
+ #endif
+
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <assert.h>
+ #include <string.h>
+ #include <errno.h>
+diff --git a/avahi-common/simple-watch.h b/avahi-common/simple-watch.h
+index 72c1905..db87122 100644
+--- a/avahi-common/simple-watch.h
++++ b/avahi-common/simple-watch.h
+@@ -22,7 +22,7 @@
+
+ /** \file simple-watch.h Simple poll() based main loop implementation */
+
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <avahi-common/cdecl.h>
+ #include <avahi-common/watch.h>
+
+diff --git a/avahi-common/thread-watch.c b/avahi-common/thread-watch.c
+index c0cadeb..ecb202b 100644
+--- a/avahi-common/thread-watch.c
++++ b/avahi-common/thread-watch.c
+@@ -21,7 +21,7 @@
+ #include <config.h>
+ #endif
+
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <assert.h>
+ #include <string.h>
+ #include <errno.h>
+diff --git a/avahi-common/thread-watch.h b/avahi-common/thread-watch.h
+index dec0cf3..1b44ccb 100644
+--- a/avahi-common/thread-watch.h
++++ b/avahi-common/thread-watch.h
+@@ -22,7 +22,7 @@
+
+ /** \file thread-watch.h Threaded poll() based main loop implementation */
+
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <avahi-common/cdecl.h>
+ #include <avahi-common/watch.h>
+
+diff --git a/avahi-common/watch.h b/avahi-common/watch.h
+index 86e63d3..eea12ec 100644
+--- a/avahi-common/watch.h
++++ b/avahi-common/watch.h
+@@ -22,7 +22,7 @@
+
+ /** \file watch.h Simplistic main loop abstraction */
+
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <sys/time.h>
+
+ #include <avahi-common/cdecl.h>
diff --git a/main/avahi-ui/system-avahi.patch b/main/avahi-ui/system-avahi.patch
new file mode 100644
index 000000000..0f8a500da
--- /dev/null
+++ b/main/avahi-ui/system-avahi.patch
@@ -0,0 +1,30 @@
+--- ./avahi-ui/Makefile.am.orig
++++ ./avahi-ui/Makefile.am
+@@ -54,12 +54,12 @@
+ libavahi_ui_la_SOURCES = \
+ avahi-ui.h avahi-ui.c
+ libavahi_ui_la_CFLAGS = $(AM_CFLAGS) $(GTK20_CFLAGS)
+-libavahi_ui_la_LIBADD = $(AM_LDADD) ../avahi-common/libavahi-common.la ../avahi-client/libavahi-client.la ../avahi-glib/libavahi-glib.la $(GTK20_LIBS)
++libavahi_ui_la_LIBADD = $(AM_LDADD) -lavahi-common -lavahi-client -lavahi-glib $(GTK20_LIBS)
+ libavahi_ui_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LIBAVAHI_UI_VERSION_INFO)
+
+ libavahi_ui_gtk3_la_SOURCES = $(libavahi_ui_la_SOURCES)
+ libavahi_ui_gtk3_la_CFLAGS = $(AM_CFLAGS) $(GTK30_CFLAGS)
+-libavahi_ui_gtk3_la_LIBADD = $(AM_LDADD) ../avahi-common/libavahi-common.la ../avahi-client/libavahi-client.la ../avahi-glib/libavahi-glib.la $(GTK30_LIBS)
++libavahi_ui_gtk3_la_LIBADD = $(AM_LDADD) -lavahi-common -lavahi-client -lavahi-glib $(GTK30_LIBS)
+ libavahi_ui_gtk3_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LIBAVAHI_UI_VERSION_INFO)
+
+ if HAVE_GDBM
+@@ -86,10 +86,10 @@
+
+ if HAVE_GTK3
+ bssh_CFLAGS = $(AM_CFLAGS) $(GTK30_CFLAGS)
+-bssh_LDADD = $(AM_LDADD) $(GTK30_LIBS) ../avahi-client/libavahi-client.la ../avahi-common/libavahi-common.la libavahi-ui-gtk3.la
++bssh_LDADD = $(AM_LDADD) $(GTK30_LIBS) -lavahi-client -lavahi-common libavahi-ui-gtk3.la
+ else
+ bssh_CFLAGS = $(AM_CFLAGS) $(GTK20_CFLAGS)
+-bssh_LDADD = $(AM_LDADD) $(GTK20_LIBS) ../avahi-client/libavahi-client.la ../avahi-common/libavahi-common.la libavahi-ui.la
++bssh_LDADD = $(AM_LDADD) $(GTK20_LIBS) -lavahi-client -lavahi-common libavahi-ui.la
+ endif
+
+ install-exec-local: