summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-05-14 12:30:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-05-14 12:30:11 +0000
commit80f720842cd5180f29fa6a314f77b4cf2166c5d3 (patch)
tree3cfe0c3dd1edbdf2c36f3e118e07a9a162115c87
parent696f9071e1f0df6531cb3a1d82c79c6cb9830039 (diff)
downloadaports-80f720842cd5180f29fa6a314f77b4cf2166c5d3.tar.bz2
aports-80f720842cd5180f29fa6a314f77b4cf2166c5d3.tar.xz
main/perl-file-slurp-tiny: new aport
A simple, sane and efficient file slurper http://search.cpan.org/dist/File-Slurp-Tiny/
-rw-r--r--main/perl-file-slurp-tiny/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/main/perl-file-slurp-tiny/APKBUILD b/main/perl-file-slurp-tiny/APKBUILD
new file mode 100644
index 000000000..e2c836b7a
--- /dev/null
+++ b/main/perl-file-slurp-tiny/APKBUILD
@@ -0,0 +1,40 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-file-slurp-tiny
+_pkgreal=File-Slurp-Tiny
+pkgver=0.003
+pkgrel=0
+pkgdesc="A simple, sane and efficient file slurper"
+url="http://search.cpan.org/dist/File-Slurp-Tiny/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/L/LE/LEONT/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="b3c1c485b5bc40f7e94acfd983d7a871 File-Slurp-Tiny-0.003.tar.gz"
+sha256sums="ded61a7ab96db8c6a14466a5984091a60af9b384b3355d06aeaa6433ac977c02 File-Slurp-Tiny-0.003.tar.gz"
+sha512sums="28ad2e9d0030ce66ffa133aab403585d3ad42336d2e74e2dc5ed76976f4a2824cab5193b6fcb480cb8fc847887657242615b7fde2069df966097bfa2da2788ae File-Slurp-Tiny-0.003.tar.gz"