summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-06-22 13:03:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-06-22 13:05:29 +0000
commit73d8e4235c6df6fd5e4be5c7aafcbf210f000465 (patch)
tree3eb678548acb9bef334cebf166c6a79e57be183b
parente0530d1207a7f290215cf136421a90f52746b2d3 (diff)
downloadaports-73d8e4235c6df6fd5e4be5c7aafcbf210f000465.tar.bz2
aports-73d8e4235c6df6fd5e4be5c7aafcbf210f000465.tar.xz
main/wireshark: upgrade to 1.2.9
-rw-r--r--main/wireshark/APKBUILD8
-rw-r--r--main/wireshark/wireshark-1.2.8-zlib-1.2.5-capture.patch30
2 files changed, 3 insertions, 35 deletions
diff --git a/main/wireshark/APKBUILD b/main/wireshark/APKBUILD
index 7aeb2803e..f1ab53087 100644
--- a/main/wireshark/APKBUILD
+++ b/main/wireshark/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jeremy Thomerson <jeremy@thomersonfamily.com>
-# Maintainer: Jeremy Thomerson <jeremy@thomersonfamily.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wireshark
-pkgver=1.2.8
+pkgver=1.2.9
pkgrel=0
pkgdesc="network protocol analyzer - GTK version"
url="http://www.wireshark.org"
@@ -13,7 +13,6 @@ install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-common tshark"
source="http://www.wireshark.org/download/src/${pkgname}-${pkgver}.tar.bz2
wireshark-1.1.2--as-needed.patch
- wireshark-1.2.8-zlib-1.2.5-capture.patch
wireshark.desktop
wireshark.png"
@@ -73,8 +72,7 @@ tshark() {
mv "$pkgdir"/usr/bin/tshark "$subpkgdir"/usr/bin/tshark
}
-md5sums="3a75d4f62317e52b8b39a1e9e37f1553 wireshark-1.2.8.tar.bz2
+md5sums="a4240c36f1e668d85b703eacb7c0a95e wireshark-1.2.9.tar.bz2
cc87d7eb31f256df751b3371b1c426e9 wireshark-1.1.2--as-needed.patch
-cc4fbe2db149f2ee42dd0593944a69fe wireshark-1.2.8-zlib-1.2.5-capture.patch
504ede44c02b2a52f6cbd3bffdf93b8d wireshark.desktop
e771800a8c977fe223583a453bc27397 wireshark.png"
diff --git a/main/wireshark/wireshark-1.2.8-zlib-1.2.5-capture.patch b/main/wireshark/wireshark-1.2.8-zlib-1.2.5-capture.patch
deleted file mode 100644
index 312002740..000000000
--- a/main/wireshark/wireshark-1.2.8-zlib-1.2.5-capture.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-http://anonsvn.wireshark.org/viewvc?view=rev&revision=32715
-
---- trunk/wiretap/wtap.c 2010/05/07 19:24:32 32714
-+++ trunk/wiretap/wtap.c 2010/05/07 19:45:47 32715
-@@ -35,6 +35,10 @@
- #include <unistd.h>
- #endif
-
-+#ifdef HAVE_LIBZ
-+#include <zlib.h>
-+#endif
-+
- #include "wtap-int.h"
- #include "wtap.h"
-
-@@ -646,6 +650,14 @@
- */
- wth->phdr.pkt_encap = wth->file_encap;
-
-+#if defined(ZLIB_VERNUM) && ZLIB_VERNUM == 0x1250
-+ /* Reset EOF */
-+ /* g_log(NULL, G_LOG_LEVEL_DEBUG, "wtap_read: eof before seek: %d", gzeof(wth->fh)); */
-+ if (gzeof(wth->fh))
-+ gzseek(wth->fh, 0, SEEK_CUR);
-+ /* g_log(NULL, G_LOG_LEVEL_DEBUG, "wtap_read: eof after seek: %d", gzeof(wth->fh)); */
-+#endif
-+
- if (!wth->subtype_read(wth, err, err_info, data_offset))
- return FALSE; /* failure */
-