summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-06-23 11:27:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-06-23 11:27:22 +0000
commitb1a4c88352b29815f3c063c52cea94836d6f1d1c (patch)
tree9268d57257d694b467f14466e5bd8affcd28228a
parent09ac997eb9fd1bcf235f6ccde6a5bc4c97e1839e (diff)
downloadaports-b1a4c88352b29815f3c063c52cea94836d6f1d1c.tar.bz2
aports-b1a4c88352b29815f3c063c52cea94836d6f1d1c.tar.xz
main/libxcomposite: upgrade to 0.4.2
-rw-r--r--main/libxcomposite/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/main/libxcomposite/APKBUILD b/main/libxcomposite/APKBUILD
index cad842738..b858bc4d3 100644
--- a/main/libxcomposite/APKBUILD
+++ b/main/libxcomposite/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libxcomposite
-pkgver=0.4.1
-pkgrel=1
+pkgver=0.4.2
+pkgrel=0
pkgdesc="X11 Composite extension library"
url="http://xorg.freedesktop.org/"
license="custom"
@@ -11,14 +11,18 @@ makedepends="pkgconfig libxfixes-dev libxext-dev compositeproto"
source="http://xorg.freedesktop.org//releases/individual/lib/libXcomposite-$pkgver.tar.bz2"
depends_dev="xproto compositeproto libxfixes-dev libx11-dev libxext-dev"
-build ()
-{
- cd "$srcdir"/libXcomposite-$pkgver
+_builddir="$srcdir"/libXcomposite-$pkgver
+build() {
+ cd "$_builddir"
./configure --prefix=/usr \
--sysconfdir=/etc
make || return 1
+}
+
+package() {
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
install -D -m644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-md5sums="0f1367f57fdf5df17a8dd71d0fa68248 libXcomposite-0.4.1.tar.bz2"
+md5sums="e38dc98509149083f6c31b49b484e63c libXcomposite-0.4.2.tar.bz2"