summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2010-06-22 11:05:06 +0000
committerLeonardo Arena <rnalrd@gmail.com>2010-06-22 11:05:06 +0000
commite36c61c0f09d9c36a33edfd2fae36f0e7c480336 (patch)
tree37252f9196bedb0508abad9c15e2fab41891d3ed
parent7f3e24f7bca077309280bf8fb96d76470f622ada (diff)
downloadaports-e36c61c0f09d9c36a33edfd2fae36f0e7c480336.tar.bz2
aports-e36c61c0f09d9c36a33edfd2fae36f0e7c480336.tar.xz
testing/libusb-compat: new aport
-rw-r--r--testing/libusb-compat/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/libusb-compat/APKBUILD b/testing/libusb-compat/APKBUILD
new file mode 100644
index 000000000..48143085d
--- /dev/null
+++ b/testing/libusb-compat/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname=libusb-compat
+pkgver=0.1.3
+pkgrel=0
+pkgdesc="Compatibility library for use by user level applications to access USB devices regardless of OS"
+url="http://www.libusb.org/"
+license="LGPL v2.1"
+depends=
+makedepends=
+install=
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/project/libusb/libusb-compat-0.1/$pkgname-$pkgver/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="570ac2ea085b80d1f74ddc7c6a93c0eb libusb-compat-0.1.3.tar.bz2"