summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-09-17 06:52:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-09-23 08:17:43 +0000
commit516e3e24f6463a9674c3e6948996f517d396d083 (patch)
treed9b4a8f661b0ee387ee9ac8ae7da1b0ead0cd360
parent5ca3bbde6d1460508455d1b0fe293c29262cb155 (diff)
downloadaports-516e3e24f6463a9674c3e6948996f517d396d083.tar.bz2
aports-516e3e24f6463a9674c3e6948996f517d396d083.tar.xz
main/libc0.9.32: disable debugging symbols
(cherry picked from commit 863d7fd7cd6a72171014520a04ab41774b9eb055)
-rw-r--r--main/libc0.9.32/APKBUILD10
-rw-r--r--main/libc0.9.32/uclibcconfig.x864
2 files changed, 6 insertions, 8 deletions
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index 83d89a5b7..12a01fa13 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -3,7 +3,7 @@ _abiver=0.9.32
pkgname=libc$_abiver
_gitver=1009151331
pkgver=${_abiver}_alpha0_git$_gitver
-pkgrel=0
+pkgrel=1
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -12,12 +12,10 @@ subpackages="uclibc-dev:dev uclibc-utils:utils"
depends_dev="linux-headers=>2.6.32"
replaces=uclibc
-DEBUG=y
if [ -n "$DEBUG" ]; then
options="!strip"
fi
-
_snapurl="http://git.uclibc.org/uClibc/snapshot/master.tar.bz2"
_snapfile="$pkgname-$pkgver.tar.bz2"
source="http://build.alpinelinux.org:8010/distfiles/$_snapfile
@@ -82,7 +80,7 @@ build() {
fi
cp "$_config" .config
if [ -n "$DEBUG" ]; then
- sed -i -e 's/# DODEBUG is not set/DODEBUG=y' \
+ sed -i -e 's/# DODEBUG is not set/DODEBUG=y/' \
-e 's/DOSTRIP=y/# DOSTRIP is not set/' \
.config
fi
@@ -124,5 +122,5 @@ md5sums="966c830f294a8ab5069cc03a61e1b2ed libc0.9.32-0.9.32_alpha0_git100915133
ba6e0370d1fc19e5903696de412507ef 0001-config-parser-do-not-assume-that-realloc-return-same.patch
19d923997f9625ce6f16d8128bbcba65 0002-getservice-getservent_r-must-return-ERANGE-when-buff.patch
99b817778f4ef3a1b194740ea08990b4 0003-config-parser-always-initialize-line-pointer.patch
-2ca97ab4b49f920247f335184bb02c1c uclibcconfig.x86
-2ca97ab4b49f920247f335184bb02c1c uclibcconfig.i486"
+cffecb42bdec2da7cac718fa66cacbbe uclibcconfig.x86
+cffecb42bdec2da7cac718fa66cacbbe uclibcconfig.i486"
diff --git a/main/libc0.9.32/uclibcconfig.x86 b/main/libc0.9.32/uclibcconfig.x86
index 3baabc771..977f023b4 100644
--- a/main/libc0.9.32/uclibcconfig.x86
+++ b/main/libc0.9.32/uclibcconfig.x86
@@ -250,8 +250,8 @@ UCLIBC_BUILD_NOEXECSTACK=y
#
CROSS_COMPILER_PREFIX=""
UCLIBC_EXTRA_CFLAGS=""
-DODEBUG=y
-# DOSTRIP is not set
+# DODEBUG is not set
+DOSTRIP=y
# DOASSERTS is not set
# SUPPORT_LD_DEBUG is not set
# SUPPORT_LD_DEBUG_EARLY is not set