summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-10-11 07:05:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-05-03 12:16:31 +0000
commit515faa72e61cb132c4a279c16ba40b0941a21e02 (patch)
tree684c8fb5fb7bf58b6aa5b76b76407770797dca9a
parent66847bef4e2eddaff6f8b24a2482627fe2250945 (diff)
downloadaports-515faa72e61cb132c4a279c16ba40b0941a21e02.tar.bz2
aports-515faa72e61cb132c4a279c16ba40b0941a21e02.tar.xz
main/subversion: upgrade to 1.7.7
(cherry picked from commit 24794fd52d46a1d56ae3d95d324bd5570a5eaa85) Conflicts: main/subversion/APKBUILD
-rw-r--r--main/subversion/APKBUILD6
-rw-r--r--main/subversion/subversion-perl-deplibs.patch38
2 files changed, 24 insertions, 20 deletions
diff --git a/main/subversion/APKBUILD b/main/subversion/APKBUILD
index 0a7b6c463..45c0563ff 100644
--- a/main/subversion/APKBUILD
+++ b/main/subversion/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=subversion
-pkgver=1.7.4
+pkgver=1.7.7
pkgrel=0
pkgdesc="Replacement for CVS, another versioning system (svn)"
url="http://subversion.tigris.org/"
@@ -82,8 +82,8 @@ pl() {
mv "$pkgdir"/usr/lib/*perl* "$subpkgdir"/usr/lib/
}
-md5sums="99ace9433be21a4793fc1cdbf2fdea09 subversion-1.7.4.tar.bz2
+md5sums="5a42b7d0f1366a8d60f9ad7d5890295d subversion-1.7.7.tar.bz2
e1127cb722daecb3c89adbaf9eed7adf subversion-1.7.0-deplibs.patch
-cb2697049b57cab4d7d07336c2a339d3 subversion-perl-deplibs.patch
+39dd787af4f9ca05ab85ce94f4471687 subversion-perl-deplibs.patch
d084a7558053784886bc858b94fa9186 svnserve.confd
bedaa1837021bc7654eae333fa9a21f0 svnserve.initd"
diff --git a/main/subversion/subversion-perl-deplibs.patch b/main/subversion/subversion-perl-deplibs.patch
index e9757a286..13840a68e 100644
--- a/main/subversion/subversion-perl-deplibs.patch
+++ b/main/subversion/subversion-perl-deplibs.patch
@@ -1,21 +1,9 @@
---- subversion-1.7.2/subversion/bindings/swig/perl/native/Makefile.PL.in.orig
-+++ subversion-1.7.2/subversion/bindings/swig/perl/native/Makefile.PL.in
-@@ -49,11 +49,7 @@
- my $cflags = '@CFLAGS@';
- my $apr_cflags = '@SVN_APR_INCLUDES@';
- my $apu_cflags = '@SVN_APRUTIL_INCLUDES@';
--
--# According to the log of r7937, the flags guarded by the conditional break
--# the build on FreeBSD if not conditionalized.
--my $apr_ldflags = '@SVN_APR_LIBS@'
-- if $^O eq 'darwin' or $^O eq 'cygwin';
-+my $apr_ldflags = '@SVN_APR_LIBS@';
-
- chomp $apr_shlib_path_var;
+diff --git a/configure.ac b/configure.ac
+index 3481299..e0efde9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -327,7 +327,7 @@ AC_SUBST(LT_NO_UNDEFINED)
---- subversion-1.7.2/configure.ac.orig
-+++ subversion-1.7.2/configure.ac
-@@ -328,6 +328,6 @@
AC_MSG_CHECKING([whether to avoid circular linkage at all costs])
case $host in
- *-*-cygwin*)
@@ -23,3 +11,19 @@
AC_MSG_RESULT([yes])
AC_DEFINE([SVN_AVOID_CIRCULAR_LINKAGE_AT_ALL_COSTS_HACK], 1,
[Define if circular linkage is not possible on this platform.])
+diff --git a/subversion/bindings/swig/perl/native/Makefile.PL.in b/subversion/bindings/swig/perl/native/Makefile.PL.in
+index 27d507c..d496273 100644
+--- a/subversion/bindings/swig/perl/native/Makefile.PL.in
++++ b/subversion/bindings/swig/perl/native/Makefile.PL.in
+@@ -55,10 +55,7 @@ my $apu_cflags = '@SVN_APRUTIL_INCLUDES@';
+ # SWIG is using C++ style comments in an extern "C" code.
+ $cflags =~ s/-ansi\s+//g;
+
+-# According to the log of r7937, the flags guarded by the conditional break
+-# the build on FreeBSD if not conditionalized.
+-my $apr_ldflags = '@SVN_APR_LIBS@'
+- if $^O eq 'darwin' or $^O eq 'cygwin';
++my $apr_ldflags = '@SVN_APR_LIBS@';
+
+ chomp $apr_shlib_path_var;
+