summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-07-03 07:27:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-07-03 07:31:03 +0000
commita9bb24ef0967369f34dd8760ce8de52d9819a6a0 (patch)
tree6933a4442f89b76706653c5f96caca56eb0ca8b7
parentfd641092f593d069b998a466b54b882d9c8d7910 (diff)
downloadaports-a9bb24ef0967369f34dd8760ce8de52d9819a6a0.tar.bz2
aports-a9bb24ef0967369f34dd8760ce8de52d9819a6a0.tar.xz
main/<various>: build fix for GCC_SPECS
should not include the full path
-rw-r--r--main/dahdi-linux-grsec/APKBUILD2
-rw-r--r--main/linux-grsec/APKBUILD2
-rw-r--r--main/linux-scst/APKBUILD2
-rw-r--r--main/linux-vanilla/APKBUILD2
-rw-r--r--main/linux-virt-grsec/APKBUILD2
-rw-r--r--main/linux-vserver/APKBUILD2
-rw-r--r--main/mplayer/APKBUILD2
-rw-r--r--main/open-vm-tools-grsec/APKBUILD2
-rw-r--r--main/xtables-addons-grsec/APKBUILD2
-rw-r--r--main/zsnes/APKBUILD2
10 files changed, 10 insertions, 10 deletions
diff --git a/main/dahdi-linux-grsec/APKBUILD b/main/dahdi-linux-grsec/APKBUILD
index c8a351325..9852a7b18 100644
--- a/main/dahdi-linux-grsec/APKBUILD
+++ b/main/dahdi-linux-grsec/APKBUILD
@@ -58,7 +58,7 @@ prepare() {
build() {
cd "$srcdir/$_realname-$_dahdiver"
- export GCC_SPECS=/usr/share/gcc/hardenednopie.specs
+ export GCC_SPECS=hardenednopie.specs
make KVERS="${_abi_release}" DYNFS="yes" MODULES_EXTRA="zaphfc" \
|| return 1
}
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 7e148c401..37a80a337 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -79,7 +79,7 @@ menuconfig() {
build() {
cd "$srcdir"/build
- export GCC_SPECS=/usr/share/gcc/hardenednopie.specs
+ export GCC_SPECS=hardenednopie.specs
make CC="${CC:-gcc}" \
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-Alpine" \
|| return 1
diff --git a/main/linux-scst/APKBUILD b/main/linux-scst/APKBUILD
index 80fc87c7f..adcf61262 100644
--- a/main/linux-scst/APKBUILD
+++ b/main/linux-scst/APKBUILD
@@ -63,7 +63,7 @@ menuconfig() {
build() {
cd "$srcdir"/build
- export GCC_SPECS=/usr/share/gcc/hardenednopie.specs
+ export GCC_SPECS=hardenednopie.specs
make CC="${CC:-gcc}" \
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-Alpine" \
|| return 1
diff --git a/main/linux-vanilla/APKBUILD b/main/linux-vanilla/APKBUILD
index 3e422af98..59a80ffa0 100644
--- a/main/linux-vanilla/APKBUILD
+++ b/main/linux-vanilla/APKBUILD
@@ -71,7 +71,7 @@ menuconfig() {
build() {
cd "$srcdir"/build
- export GCC_SPECS=/usr/share/gcc/hardenednopie.specs
+ export GCC_SPECS=hardenednopie.specs
make CC="${CC:-gcc}" \
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-Alpine" \
|| return 1
diff --git a/main/linux-virt-grsec/APKBUILD b/main/linux-virt-grsec/APKBUILD
index 1b009fe5d..e67c7c99b 100644
--- a/main/linux-virt-grsec/APKBUILD
+++ b/main/linux-virt-grsec/APKBUILD
@@ -78,7 +78,7 @@ menuconfig() {
build() {
cd "$srcdir"/build
- export GCC_SPECS=/usr/share/gcc/hardenednopie.specs
+ export GCC_SPECS=hardenednopie.specs
make CC="${CC:-gcc}" \
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-Alpine" \
|| return 1
diff --git a/main/linux-vserver/APKBUILD b/main/linux-vserver/APKBUILD
index 3865e54bd..59f9ea0af 100644
--- a/main/linux-vserver/APKBUILD
+++ b/main/linux-vserver/APKBUILD
@@ -67,7 +67,7 @@ menuconfig() {
build() {
cd "$srcdir"/build
- export GCC_SPECS=/usr/share/gcc/hardenednopie.specs
+ export GCC_SPECS=hardenednopie.specs
make CC="${CC:-gcc}" \
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-Alpine" \
|| return 1
diff --git a/main/mplayer/APKBUILD b/main/mplayer/APKBUILD
index d55b50c50..668b38e5f 100644
--- a/main/mplayer/APKBUILD
+++ b/main/mplayer/APKBUILD
@@ -30,7 +30,7 @@ prepare() {
build() {
cd "$_builddir"
- export GCC_SPECS=/usr/share/gcc/hardenednopie.specs
+ export GCC_SPECS=hardenednopie.specs
./configure --prefix=/usr \
--disable-gui \
--disable-gif \
diff --git a/main/open-vm-tools-grsec/APKBUILD b/main/open-vm-tools-grsec/APKBUILD
index c21ed06d8..78755b57a 100644
--- a/main/open-vm-tools-grsec/APKBUILD
+++ b/main/open-vm-tools-grsec/APKBUILD
@@ -58,7 +58,7 @@ prepare() {
}
build() {
- export GCC_SPECS=/usr/share/gcc/hardenednopie.specs
+ export GCC_SPECS=hardenednopie.specs
cd "$_builddir"
./configure --without-pam \
--without-x \
diff --git a/main/xtables-addons-grsec/APKBUILD b/main/xtables-addons-grsec/APKBUILD
index 5daf8110c..44d71dd63 100644
--- a/main/xtables-addons-grsec/APKBUILD
+++ b/main/xtables-addons-grsec/APKBUILD
@@ -45,7 +45,7 @@ build() {
--with-kbuild=/usr/src/linux-headers-${_abi_release}
cd extensions
- export GCC_SPECS=/usr/share/gcc/hardenednopie.specs
+ export GCC_SPECS=hardenednopie.specs
make CC="${CC:-gcc}" modules || return 1
}
diff --git a/main/zsnes/APKBUILD b/main/zsnes/APKBUILD
index a0d52404e..955314d90 100644
--- a/main/zsnes/APKBUILD
+++ b/main/zsnes/APKBUILD
@@ -27,7 +27,7 @@ build ()
cd "$srcdir"/${pkgname}_${pkgver%.*}_${pkgver#*.}/src
aclocal && autoconf || return 1
- export GCC_SPECS=/usr/share/gcc/hardenednopie.specs
+ export GCC_SPECS=hardenednopie.specs
./configure --prefix=/usr \
--mandir=/usr/share/man \
x_libraries=/usr/lib \