summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Smith <mcs@darkregion.net>2011-04-08 06:01:14 -0500
committerMatt Smith <mcs@darkregion.net>2011-04-08 06:01:52 -0500
commit6492a2a28c74f6dfe7c6ca0ee97ad6fd69f42189 (patch)
treecf2bc78075a5d3f00569559b1067c5855dcd1f45
parent27ff6791aece4d831cf2994293a740f6cbb5988c (diff)
downloadaports-6492a2a28c74f6dfe7c6ca0ee97ad6fd69f42189.tar.bz2
aports-6492a2a28c74f6dfe7c6ca0ee97ad6fd69f42189.tar.xz
testing/phpmyadmin: removed custom htaccess, updated post-install script
-rw-r--r--testing/phpmyadmin/APKBUILD13
-rw-r--r--testing/phpmyadmin/htaccess3
-rw-r--r--testing/phpmyadmin/phpmyadmin.post-install23
3 files changed, 14 insertions, 25 deletions
diff --git a/testing/phpmyadmin/APKBUILD b/testing/phpmyadmin/APKBUILD
index 8a1529c25..97244325b 100644
--- a/testing/phpmyadmin/APKBUILD
+++ b/testing/phpmyadmin/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Matt Smith <mcs@darkregion.net>
pkgname=phpmyadmin
pkgver=3.3.10
-pkgrel=0
+pkgrel=1
pkgdesc="A Web-based PHP tool for administering MySQL"
url="http://www.phpmyadmin.net/"
arch="noarch"
@@ -15,7 +15,6 @@ subpackages="$pkgname-doc"
_fullpkgname=phpMyAdmin-$pkgver-all-languages
source="http://downloads.sourceforge.net/$pkgname/$_fullpkgname.tar.gz
$pkgname.apache2.conf
- htaccess
"
_builddir="$srcdir"/$_fullpkgname
@@ -43,13 +42,6 @@ package() {
cp -ra "$_builddir"/* "$pkgdir"/usr/share/webapps/$pkgname/ \
|| return 1
- # install an htaccess file
- install -m644 "$srcdir"/htaccess "$pkgdir"/etc/$pkgname/ \
- || return 1
- ln -fs /etc/$pkgname/htaccess \
- "$pkgdir"/usr/share/webapps/$pkgname/.htaccess \
- || return 1
-
# install the sample config
install -m660 \
"$pkgdir"/usr/share/webapps/$pkgname/config.sample.inc.php \
@@ -92,5 +84,4 @@ doc() {
}
md5sums="2e93375a92a86ef36e561b0087f6b8e3 phpMyAdmin-3.3.10-all-languages.tar.gz
-2d144825122042b4a2536ad789d66e8e phpmyadmin.apache2.conf
-a83a095fe9e86d1cdd1424f857e26c9b htaccess"
+2d144825122042b4a2536ad789d66e8e phpmyadmin.apache2.conf"
diff --git a/testing/phpmyadmin/htaccess b/testing/phpmyadmin/htaccess
deleted file mode 100644
index 4666b1f4a..000000000
--- a/testing/phpmyadmin/htaccess
+++ /dev/null
@@ -1,3 +0,0 @@
-allow from 127.0.0.1
-allow from ::1
-deny from all
diff --git a/testing/phpmyadmin/phpmyadmin.post-install b/testing/phpmyadmin/phpmyadmin.post-install
index 00cd7d2c7..6403c706c 100644
--- a/testing/phpmyadmin/phpmyadmin.post-install
+++ b/testing/phpmyadmin/phpmyadmin.post-install
@@ -1,15 +1,16 @@
#!/bin/sh
-echo -e "\nphpMyAdmin has been installed to:"
-echo -e " /usr/share/webapps/phpmyadmin"
-echo -e "phpMyAdmin config files have been installed to:"
-echo -e " /etc/phpmyadmin"
-echo -e "If you use apache2:"
-echo -e " - Change ownership of the config directory:"
-echo -e " chown -R apache:apache /etc/phpmyadmin"
-echo -e " - See if you need to modify the following files:"
-echo -e " /etc/apache2/conf.d/phpmyadmin.conf"
-echo -e " /etc/phpmyadmin/htaccess"
-echo -e " - Restart apache2 when done.\n"
+echo "*" >&2
+echo "* phpmyadmin has been installed to:" >&2
+echo "* /usr/share/webapps/phpmyadmin" >&2
+echo "* phpmyadmin config file has been installed to:" >&2
+echo "* /etc/phpmyadmin/config.inc.php" >&2
+echo "* If you use apache2:" >&2
+echo "* 1) Change the ownership of the config directory:" >&2
+echo "* chown -R apache:apache /etc/phpmyadmin" >&2
+echo "* 2) See if you need to modify the apache2 config:" >&2
+echo "* /etc/apache2/conf.d/phpmyadmin.conf" >&2
+echo "* 3) Restart apache2 if changes were made in step 2." >&2
+echo "*" >&2
exit 0