summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-06-21 09:14:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-21 09:14:58 +0000
commitaf4306109b58e890c58fe6a6bcb5c4b98c0f6164 (patch)
treebf5bbc3b54c57fdee787e2f1a7b8945b37164343
parent0d1939dee287f1ee4874737760dcaca6c27ea32c (diff)
downloadaports-af4306109b58e890c58fe6a6bcb5c4b98c0f6164.tar.bz2
aports-af4306109b58e890c58fe6a6bcb5c4b98c0f6164.tar.xz
testing/lua-ev: new aport
Lua bindings to libev https://github.com/brimworks/lua-ev
-rw-r--r--testing/lua-ev/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/lua-ev/APKBUILD b/testing/lua-ev/APKBUILD
new file mode 100644
index 000000000..a9a46d060
--- /dev/null
+++ b/testing/lua-ev/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-ev
+pkgver=1.3
+pkgrel=0
+pkgdesc="Lua bindings to libev"
+url="https://github.com/brimworks/lua-ev"
+arch="all"
+license="MIT"
+depends=
+makedepends="lua-dev cmake libev-dev wget"
+install=
+subpackages="$pkgname-doc"
+source="https://github.com/downloads/brimworks/lua-ev/lua-ev-v$pkgver.tar.gz"
+
+_builddir="$srcdir"/lua-ev-v$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DINSTALL_CMOD=/usr/lib/lua/5.1/ \
+ . || return 1
+ make || return 1
+ install -Dm644 README "$pkgdir"/usr/share/doc/$pkgname/README
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="4b3703d82711407be6ca5ef793b0cf57 lua-ev-v1.3.tar.gz"