summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2014-12-08 16:37:28 +0200
committerKaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>2014-12-08 16:37:33 +0200
commit491d4e86baf9fcf4c526f827a70fc8d70b4fd899 (patch)
tree5b99e070bc1c370d59128f943ee8d58ec4b565c1
parent760934f05b012d865c323a7e4aaf593e3302b008 (diff)
downloadaports-491d4e86baf9fcf4c526f827a70fc8d70b4fd899.tar.bz2
aports-491d4e86baf9fcf4c526f827a70fc8d70b4fd899.tar.xz
main/augeas: more fixes to Shellvars lense
parse e.g. main/ruby/APKBUILD
-rw-r--r--main/augeas/0001-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch5
-rw-r--r--main/augeas/0002-Shellvars-allow-wrapping-loop-condition-to-multiple-.patch42
-rw-r--r--main/augeas/0003-Shellvars-guard-against-comments.patch25
-rw-r--r--main/augeas/0004-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch (renamed from main/augeas/0002-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch)29
-rw-r--r--main/augeas/0005-Shellvars-allow-quotes-in-loop-conditions.patch54
-rw-r--r--main/augeas/0006-Shellvars-case-support-quotes-and-spaces-in-pattern-.patch56
-rw-r--r--main/augeas/0007-Shellvars-Allow-almost-any-command.patch (renamed from main/augeas/0003-Shellvars-Allow-almost-any-command.patch)20
-rw-r--r--main/augeas/0008-Shellvars-test-case-for-wrapping-command-arguments.patch (renamed from main/augeas/0004-Shellvars-test-case-for-wrapping-command-arguments.patch)8
-rw-r--r--main/augeas/0009-Shellvars-case-support-on-same-line-with-multiple-co.patch (renamed from main/augeas/0005-Shellvars-case-support-on-same-line-with-multiple-co.patch)14
-rw-r--r--main/augeas/0010-Shellvars-allow-the-builtin.patch41
-rw-r--r--main/augeas/APKBUILD60
11 files changed, 298 insertions, 56 deletions
diff --git a/main/augeas/0001-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch b/main/augeas/0001-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
index b3d7012ae..264f86584 100644
--- a/main/augeas/0001-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
+++ b/main/augeas/0001-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
@@ -1,7 +1,8 @@
-From 937653cbb1f9681a575e0fa5e8f2d0e59fd9ab5c Mon Sep 17 00:00:00 2001
+From 3c55c13c294b031d2210331c3d6c3b12b3640618 Mon Sep 17 00:00:00 2001
From: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
Date: Thu, 4 Dec 2014 14:31:26 +0200
-Subject: [PATCH 1/5] Shellvars: allow partial quoting, mixing multiple styles
+Subject: [PATCH 01/10] Shellvars: allow partial quoting, mixing multiple
+ styles
---
lenses/shellvars.aug | 8 ++++----
diff --git a/main/augeas/0002-Shellvars-allow-wrapping-loop-condition-to-multiple-.patch b/main/augeas/0002-Shellvars-allow-wrapping-loop-condition-to-multiple-.patch
new file mode 100644
index 000000000..29f73e6ae
--- /dev/null
+++ b/main/augeas/0002-Shellvars-allow-wrapping-loop-condition-to-multiple-.patch
@@ -0,0 +1,42 @@
+From 742ca2f1ca69e55e2534cab92f7aad437ec987fa Mon Sep 17 00:00:00 2001
+From: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+Date: Mon, 8 Dec 2014 13:16:14 +0200
+Subject: [PATCH 02/10] Shellvars: allow wrapping loop condition to multiple
+ lines
+
+---
+ lenses/shellvars.aug | 2 +-
+ lenses/tests/test_shellvars.aug | 4 ++++
+ 2 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/lenses/shellvars.aug b/lenses/shellvars.aug
+index 60091a9..40a527f 100644
+--- a/lenses/shellvars.aug
++++ b/lenses/shellvars.aug
+@@ -31,7 +31,7 @@ module Shellvars =
+ let xchgs = Build.xchgs
+ let semicol = del /;?/ ""
+
+- let char = /[^`;() '"\t\n\\]|\\\\./
++ let char = /[^`;() '"\t\n\\]|\\\\(.|\n)/
+ let dquot =
+ let char = /[^"\\]|\\\\./ | Rx.cl
+ in "\"" . char* . "\"" (* " Emacs, relax *)
+diff --git a/lenses/tests/test_shellvars.aug b/lenses/tests/test_shellvars.aug
+index e4fd79f..a61bb29 100644
+--- a/lenses/tests/test_shellvars.aug
++++ b/lenses/tests/test_shellvars.aug
+@@ -493,6 +493,10 @@ fi\n" =
+ { "MALLOC_PERTURB_" = "$(($RANDOM % 255 + 1))"
+ { "export" } }
+
++ (* Allow wrapping loop condition to multiple lines *)
++ test Shellvars.lns get "for x in foo \\\nbar\\\nbaz; do y=$x; done\n" =
++ { "@for" = "x in foo \\\nbar\\\nbaz" { "y" = "$x" } }
++
+ (* Local Variables: *)
+ (* mode: caml *)
+ (* End: *)
+--
+1.8.3.1
+
diff --git a/main/augeas/0003-Shellvars-guard-against-comments.patch b/main/augeas/0003-Shellvars-guard-against-comments.patch
new file mode 100644
index 000000000..720ac5bd1
--- /dev/null
+++ b/main/augeas/0003-Shellvars-guard-against-comments.patch
@@ -0,0 +1,25 @@
+From f12488a278364a5a743faf2369766fee54db123c Mon Sep 17 00:00:00 2001
+From: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+Date: Mon, 8 Dec 2014 12:43:51 +0200
+Subject: [PATCH 03/10] Shellvars: guard against comments
+
+---
+ lenses/shellvars.aug | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lenses/shellvars.aug b/lenses/shellvars.aug
+index 40a527f..ae2ec90 100644
+--- a/lenses/shellvars.aug
++++ b/lenses/shellvars.aug
+@@ -31,7 +31,7 @@ module Shellvars =
+ let xchgs = Build.xchgs
+ let semicol = del /;?/ ""
+
+- let char = /[^`;() '"\t\n\\]|\\\\(.|\n)/
++ let char = /[^`;()'"\n\\# \t]#*|\\\\(.|\n)/
+ let dquot =
+ let char = /[^"\\]|\\\\./ | Rx.cl
+ in "\"" . char* . "\"" (* " Emacs, relax *)
+--
+1.8.3.1
+
diff --git a/main/augeas/0002-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch b/main/augeas/0004-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch
index 5dea08e26..ce5eff162 100644
--- a/main/augeas/0002-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch
+++ b/main/augeas/0004-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch
@@ -1,38 +1,41 @@
-From 0563e64fdd8c8ce3b97d58909697ff7f61c29adb Mon Sep 17 00:00:00 2001
+From a2c84aed6a77bc93020ff38b97b8c436e9a5e903 Mon Sep 17 00:00:00 2001
From: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
Date: Thu, 4 Dec 2014 18:25:12 +0200
-Subject: [PATCH 2/5] Shellvars: allow wrapping builtin arguments to multiple
+Subject: [PATCH 04/10] Shellvars: allow wrapping builtin arguments to multiple
lines
---
- lenses/shellvars.aug | 2 +-
- lenses/tests/test_shellvars.aug | 4 ++++
- 2 files changed, 5 insertions(+), 1 deletion(-)
+ lenses/shellvars.aug | 4 +---
+ lenses/tests/test_shellvars.aug | 5 +++++
+ 2 files changed, 6 insertions(+), 3 deletions(-)
diff --git a/lenses/shellvars.aug b/lenses/shellvars.aug
-index 60091a9..645d6ed 100644
+index ae2ec90..e318328 100644
--- a/lenses/shellvars.aug
+++ b/lenses/shellvars.aug
-@@ -44,7 +44,7 @@ module Shellvars =
+@@ -43,9 +43,7 @@ module Shellvars =
+ let dollar_arithm = /\$\(\([^\)#\n]*\)\)/
let anyquot = (char|dquot|squot|dollar_assign|dollar_arithm)+ | bquot | dbquot
-
+-
- let to_semicol_re = /[^#; \t\n][^#;\n]+[^#; \t\n]|[^#; \t\n]+/
-+ let to_semicol_re = /([^#; \t\n\\]|\\\\.)(([^#;\n\\]|\\\\(.|\n))*([^#; \t\n\\]|\\\\.))?/
- let sto_to_semicol = store to_semicol_re
+- let sto_to_semicol = store to_semicol_re
++ let sto_to_semicol = store (anyquot . (Rx.space . anyquot)*)
let sto_to_semicol_quot =
+ let no_semicol_re = /[^"'#;\n]/
diff --git a/lenses/tests/test_shellvars.aug b/lenses/tests/test_shellvars.aug
-index e4fd79f..65c2927 100644
+index a61bb29..90e529b 100644
--- a/lenses/tests/test_shellvars.aug
+++ b/lenses/tests/test_shellvars.aug
-@@ -165,6 +165,10 @@ unset ONBOOT # We do not want this var
+@@ -165,6 +165,11 @@ unset ONBOOT # We do not want this var
{ "@builtin" = "exit" }
{ "@builtin" = "exit" { "args" = "2" } }
+ (* Allow wrapping builtin arguments to multiple lines *)
-+ test Shellvars.lns get "ulimit -c \\\nunlimited\n" =
++ test Shellvars.lns get "ulimit -c \\\nunlimited\nulimit \\\n -x 123\n" =
+ { "@builtin" = "ulimit" { "args" = "-c \\\nunlimited" } }
++ { "@builtin" = "ulimit" { "args" = "\\\n -x 123" } }
+
(* Test semicolons *)
test lns get "VAR1=\"this;is;a;test\"\nVAR2=this;\n" =
diff --git a/main/augeas/0005-Shellvars-allow-quotes-in-loop-conditions.patch b/main/augeas/0005-Shellvars-allow-quotes-in-loop-conditions.patch
new file mode 100644
index 000000000..d4dcdb9a5
--- /dev/null
+++ b/main/augeas/0005-Shellvars-allow-quotes-in-loop-conditions.patch
@@ -0,0 +1,54 @@
+From 1e842317de344335cf6f0b947156b401df1daae4 Mon Sep 17 00:00:00 2001
+From: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+Date: Mon, 8 Dec 2014 14:28:16 +0200
+Subject: [PATCH 05/10] Shellvars: allow quotes in loop conditions
+
+---
+ lenses/shellvars.aug | 8 +-------
+ lenses/tests/test_shellvars.aug | 4 ++++
+ 2 files changed, 5 insertions(+), 7 deletions(-)
+
+diff --git a/lenses/shellvars.aug b/lenses/shellvars.aug
+index e318328..3671186 100644
+--- a/lenses/shellvars.aug
++++ b/lenses/shellvars.aug
+@@ -45,12 +45,6 @@ module Shellvars =
+ let anyquot = (char|dquot|squot|dollar_assign|dollar_arithm)+ | bquot | dbquot
+ let sto_to_semicol = store (anyquot . (Rx.space . anyquot)*)
+
+- let sto_to_semicol_quot =
+- let no_semicol_re = /[^"'#;\n]/
+- in let no_semicol_spc_re = /[^"'#; \t\n]/
+- in let multi_chars = no_semicol_spc_re . (no_semicol_re|anyquot)+ . no_semicol_spc_re
+- in store (no_semicol_spc_re | multi_chars)
+-
+ (* Array values of the form '(val1 val2 val3)'. We do not handle empty *)
+ (* arrays here because of typechecking headaches. Instead, they are *)
+ (* treated as a simple value *)
+@@ -108,7 +102,7 @@ module Shellvars =
+ let generic_cond_start (start_kw:string) (lbl:string)
+ (then_kw:string) (contents:lens) =
+ keyword_label start_kw lbl . Sep.space
+- . sto_to_semicol_quot . semicol_eol
++ . sto_to_semicol . semicol_eol
+ . keyword then_kw . eol
+ . contents
+
+diff --git a/lenses/tests/test_shellvars.aug b/lenses/tests/test_shellvars.aug
+index 90e529b..8d8f34d 100644
+--- a/lenses/tests/test_shellvars.aug
++++ b/lenses/tests/test_shellvars.aug
+@@ -502,6 +502,10 @@ fi\n" =
+ test Shellvars.lns get "for x in foo \\\nbar\\\nbaz; do y=$x; done\n" =
+ { "@for" = "x in foo \\\nbar\\\nbaz" { "y" = "$x" } }
+
++ (* Allow quotes in loop conditions *)
++ test Shellvars.lns get "for x in \"$@\"; do y=$x; done\n" =
++ { "@for" = "x in \"$@\"" { "y" = "$x" } }
++
+ (* Local Variables: *)
+ (* mode: caml *)
+ (* End: *)
+--
+1.8.3.1
+
diff --git a/main/augeas/0006-Shellvars-case-support-quotes-and-spaces-in-pattern-.patch b/main/augeas/0006-Shellvars-case-support-quotes-and-spaces-in-pattern-.patch
new file mode 100644
index 000000000..c02c1bc8b
--- /dev/null
+++ b/main/augeas/0006-Shellvars-case-support-quotes-and-spaces-in-pattern-.patch
@@ -0,0 +1,56 @@
+From d66b7bcff272868ae367bcd66e78e07263c1748d Mon Sep 17 00:00:00 2001
+From: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+Date: Mon, 8 Dec 2014 15:17:46 +0200
+Subject: [PATCH 06/10] Shellvars: case: support quotes and spaces in pattern
+ lists
+
+---
+ lenses/shellvars.aug | 2 +-
+ lenses/tests/test_shellvars.aug | 18 ++++++++++++++++++
+ 2 files changed, 19 insertions(+), 1 deletion(-)
+
+diff --git a/lenses/shellvars.aug b/lenses/shellvars.aug
+index 3671186..0c25ff9 100644
+--- a/lenses/shellvars.aug
++++ b/lenses/shellvars.aug
+@@ -130,7 +130,7 @@ module Shellvars =
+
+ let case (entry:lens) (entry_noeol:lens) =
+ let case_entry = [ label "@case_entry"
+- . Util.indent . store /[^ \t\n\)]+/
++ . Util.indent . sto_to_semicol
+ . Util.del_str ")" . eol
+ . ( entry+ | entry_noeol )?
+ . Util.indent . Util.del_str ";;" . eol ] in
+diff --git a/lenses/tests/test_shellvars.aug b/lenses/tests/test_shellvars.aug
+index 8d8f34d..ee23698 100644
+--- a/lenses/tests/test_shellvars.aug
++++ b/lenses/tests/test_shellvars.aug
+@@ -506,6 +506,24 @@ fi\n" =
+ test Shellvars.lns get "for x in \"$@\"; do y=$x; done\n" =
+ { "@for" = "x in \"$@\"" { "y" = "$x" } }
+
++ (* case: support quotes and spaces in pattern lists *)
++ test lns get "case $ARG in
++ \"foo bar\")
++ Foo=0
++ ;;
++ baz | quux)
++ Foo=1
++ ;;
++esac\n" =
++ { "@case" = "$ARG"
++ { "@case_entry" = "\"foo bar\""
++ { "Foo" = "0" }
++ }
++ { "@case_entry" = "baz | quux"
++ { "Foo" = "1" }
++ }
++ }
++
+ (* Local Variables: *)
+ (* mode: caml *)
+ (* End: *)
+--
+1.8.3.1
+
diff --git a/main/augeas/0003-Shellvars-Allow-almost-any-command.patch b/main/augeas/0007-Shellvars-Allow-almost-any-command.patch
index 34bb5982e..3775fc592 100644
--- a/main/augeas/0003-Shellvars-Allow-almost-any-command.patch
+++ b/main/augeas/0007-Shellvars-Allow-almost-any-command.patch
@@ -1,7 +1,7 @@
-From 23498cfa489397a60cc0667352fd144d3cdd905d Mon Sep 17 00:00:00 2001
+From 1fbc9768290383ee6de28416ab033ec07831ae95 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Rapha=C3=ABl=20Pinson?= <raphink@gmail.com>
Date: Thu, 24 Apr 2014 16:10:50 +0200
-Subject: [PATCH 3/5] Shellvars: Allow (almost) any command
+Subject: [PATCH 07/10] Shellvars: Allow (almost) any command
Note: this may have edge effects in recursive sublenses
that augparse cannot check.
@@ -24,10 +24,10 @@ index 73b5332..4501226 100644
* Sshd: Allow all types of entries in Match groups (GH issue #75)
* Sssd: Allow ; for comments
diff --git a/lenses/shellvars.aug b/lenses/shellvars.aug
-index 645d6ed..a50c0f6 100644
+index 0c25ff9..3b98c23 100644
--- a/lenses/shellvars.aug
+++ b/lenses/shellvars.aug
-@@ -102,6 +102,11 @@ module Shellvars =
+@@ -94,6 +94,11 @@ module Shellvars =
. Util.del_str "return"
. ( Util.del_ws_spc . store Rx.integer )?
@@ -39,7 +39,7 @@ index 645d6ed..a50c0f6 100644
(************************************************************************
* Group: CONDITIONALS AND LOOPS
-@@ -166,6 +171,7 @@ module Shellvars =
+@@ -158,6 +163,7 @@ module Shellvars =
| entry_eol_item bare_export
| entry_eol_item builtin
| entry_eol_item return
@@ -47,7 +47,7 @@ index 645d6ed..a50c0f6 100644
let entry_noeol =
let entry_item (item:lens) = [ item ] in
-@@ -175,6 +181,7 @@ module Shellvars =
+@@ -167,6 +173,7 @@ module Shellvars =
| entry_item bare_export
| entry_item builtin
| entry_item return
@@ -56,12 +56,12 @@ index 645d6ed..a50c0f6 100644
let rec rec_entry =
let entry = comment | entry_eol | rec_entry in
diff --git a/lenses/tests/test_shellvars.aug b/lenses/tests/test_shellvars.aug
-index 65c2927..fd9e299 100644
+index ee23698..f955b3e 100644
--- a/lenses/tests/test_shellvars.aug
+++ b/lenses/tests/test_shellvars.aug
-@@ -497,6 +497,17 @@ fi\n" =
- { "MALLOC_PERTURB_" = "$(($RANDOM % 255 + 1))"
- { "export" } }
+@@ -524,6 +524,17 @@ esac\n" =
+ }
+ }
+(* Test: Shellvars.lns
+ Parse (almost) any command *)
diff --git a/main/augeas/0004-Shellvars-test-case-for-wrapping-command-arguments.patch b/main/augeas/0008-Shellvars-test-case-for-wrapping-command-arguments.patch
index 87c244c0b..9b76775fa 100644
--- a/main/augeas/0004-Shellvars-test-case-for-wrapping-command-arguments.patch
+++ b/main/augeas/0008-Shellvars-test-case-for-wrapping-command-arguments.patch
@@ -1,17 +1,17 @@
-From 6b6b88a3725159771ac9c822d04d406a8b0c56e8 Mon Sep 17 00:00:00 2001
+From 3531dcef9587c17577a8bae63525a9f63d72162c Mon Sep 17 00:00:00 2001
From: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
Date: Thu, 4 Dec 2014 18:29:58 +0200
-Subject: [PATCH 4/5] Shellvars: test case for wrapping command arguments
+Subject: [PATCH 08/10] Shellvars: test case for wrapping command arguments
---
lenses/tests/test_shellvars.aug | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/lenses/tests/test_shellvars.aug b/lenses/tests/test_shellvars.aug
-index fd9e299..5b9fdba 100644
+index f955b3e..c1892cd 100644
--- a/lenses/tests/test_shellvars.aug
+++ b/lenses/tests/test_shellvars.aug
-@@ -500,13 +500,19 @@ fi\n" =
+@@ -527,13 +527,19 @@ esac\n" =
(* Test: Shellvars.lns
Parse (almost) any command *)
test Shellvars.lns get "echo foobar 'and this is baz'
diff --git a/main/augeas/0005-Shellvars-case-support-on-same-line-with-multiple-co.patch b/main/augeas/0009-Shellvars-case-support-on-same-line-with-multiple-co.patch
index 420d29fa2..bc13be9b4 100644
--- a/main/augeas/0005-Shellvars-case-support-on-same-line-with-multiple-co.patch
+++ b/main/augeas/0009-Shellvars-case-support-on-same-line-with-multiple-co.patch
@@ -1,7 +1,7 @@
-From 9764767e2c633bcedf91d3d7a9ec2542e4658ff0 Mon Sep 17 00:00:00 2001
+From 26253c2b82f489c03330b022a05ab89bf9a28312 Mon Sep 17 00:00:00 2001
From: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
Date: Thu, 4 Dec 2014 21:51:03 +0200
-Subject: [PATCH 5/5] Shellvars: case: support ;; on same line with multiple
+Subject: [PATCH 09/10] Shellvars: case: support ;; on same line with multiple
commands
---
@@ -10,12 +10,12 @@ Subject: [PATCH 5/5] Shellvars: case: support ;; on same line with multiple
2 files changed, 20 insertions(+), 1 deletion(-)
diff --git a/lenses/shellvars.aug b/lenses/shellvars.aug
-index a50c0f6..b683cc0 100644
+index 3b98c23..9cef3fd 100644
--- a/lenses/shellvars.aug
+++ b/lenses/shellvars.aug
-@@ -145,7 +145,7 @@ module Shellvars =
+@@ -137,7 +137,7 @@ module Shellvars =
let case_entry = [ label "@case_entry"
- . Util.indent . store /[^ \t\n\)]+/
+ . Util.indent . sto_to_semicol
. Util.del_str ")" . eol
- . ( entry+ | entry_noeol )?
+ . entry* . entry_noeol?
@@ -23,10 +23,10 @@ index a50c0f6..b683cc0 100644
[ keyword_label "case" "@case" . Sep.space
. store (char+ | ("\"" . char+ . "\""))
diff --git a/lenses/tests/test_shellvars.aug b/lenses/tests/test_shellvars.aug
-index 5b9fdba..0ff1b1a 100644
+index c1892cd..f38fd30 100644
--- a/lenses/tests/test_shellvars.aug
+++ b/lenses/tests/test_shellvars.aug
-@@ -478,6 +478,25 @@ esac\n" =
+@@ -479,6 +479,25 @@ esac\n" =
{ "@case_entry" = "1"
{ "TestVar" = "\"test1\"" } } }
diff --git a/main/augeas/0010-Shellvars-allow-the-builtin.patch b/main/augeas/0010-Shellvars-allow-the-builtin.patch
new file mode 100644
index 000000000..f6a0e7050
--- /dev/null
+++ b/main/augeas/0010-Shellvars-allow-the-builtin.patch
@@ -0,0 +1,41 @@
+From 5f8f638b4da32a9b7ccd797b32e956a4887b5e79 Mon Sep 17 00:00:00 2001
+From: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+Date: Mon, 8 Dec 2014 15:10:28 +0200
+Subject: [PATCH 10/10] Shellvars: allow the [ builtin
+
+---
+ lenses/shellvars.aug | 2 +-
+ lenses/tests/test_shellvars.aug | 4 ++++
+ 2 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/lenses/shellvars.aug b/lenses/shellvars.aug
+index 9cef3fd..07c7a52 100644
+--- a/lenses/shellvars.aug
++++ b/lenses/shellvars.aug
+@@ -78,7 +78,7 @@ module Shellvars =
+ . del /\.|source/ "." . label ".source"
+ . Util.del_ws_spc . store /[^;=# \t\n]+/
+
+- let shell_builtin_cmds = "ulimit" | "shift" | "exit"
++ let shell_builtin_cmds = "ulimit" | "shift" | "exit" | "["
+
+ let builtin =
+ Util.indent . label "@builtin"
+diff --git a/lenses/tests/test_shellvars.aug b/lenses/tests/test_shellvars.aug
+index f38fd30..68a77ad 100644
+--- a/lenses/tests/test_shellvars.aug
++++ b/lenses/tests/test_shellvars.aug
+@@ -165,6 +165,10 @@ unset ONBOOT # We do not want this var
+ { "@builtin" = "exit" }
+ { "@builtin" = "exit" { "args" = "2" } }
+
++ (* Allow the [ builtin *)
++ test Shellvars.lns get "[ -f $FILENAME ]\n" =
++ { "@builtin" = "[" { "args" = "-f $FILENAME ]" } }
++
+ (* Allow wrapping builtin arguments to multiple lines *)
+ test Shellvars.lns get "ulimit -c \\\nunlimited\nulimit \\\n -x 123\n" =
+ { "@builtin" = "ulimit" { "args" = "-c \\\nunlimited" } }
+--
+1.8.3.1
+
diff --git a/main/augeas/APKBUILD b/main/augeas/APKBUILD
index 906601625..fb27e7c5b 100644
--- a/main/augeas/APKBUILD
+++ b/main/augeas/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=augeas
pkgver=1.3.0
-pkgrel=0
+pkgrel=1
pkgdesc="A configuration editing tool"
url="http://augeas.net"
arch="all"
@@ -14,10 +14,15 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-tests $pkgname-libs"
source="http://download.augeas.net/augeas-$pkgver.tar.gz
0001-Dnsmasq-add-structure-to-address-and-server-options.patch
0001-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
- 0002-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch
- 0003-Shellvars-Allow-almost-any-command.patch
- 0004-Shellvars-test-case-for-wrapping-command-arguments.patch
- 0005-Shellvars-case-support-on-same-line-with-multiple-co.patch"
+ 0002-Shellvars-allow-wrapping-loop-condition-to-multiple-.patch
+ 0003-Shellvars-guard-against-comments.patch
+ 0004-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch
+ 0005-Shellvars-allow-quotes-in-loop-conditions.patch
+ 0006-Shellvars-case-support-quotes-and-spaces-in-pattern-.patch
+ 0007-Shellvars-Allow-almost-any-command.patch
+ 0008-Shellvars-test-case-for-wrapping-command-arguments.patch
+ 0009-Shellvars-case-support-on-same-line-with-multiple-co.patch
+ 0010-Shellvars-allow-the-builtin.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -70,22 +75,37 @@ libs() {
md5sums="c8890b11a04795ecfe5526eeae946b2d augeas-1.3.0.tar.gz
b140791828aec2037c411164102ef8cd 0001-Dnsmasq-add-structure-to-address-and-server-options.patch
-b4cb2352d2291f59cf337a85581155d5 0001-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
-c46a285bbb12463a8464d94e1aa83477 0002-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch
-e53532cb842babf3b785369d23437005 0003-Shellvars-Allow-almost-any-command.patch
-c14dfc123474916f8329a9cf94eb9209 0004-Shellvars-test-case-for-wrapping-command-arguments.patch
-73c032499a48ed2d5847a9a627131eb5 0005-Shellvars-case-support-on-same-line-with-multiple-co.patch"
+0b7d8ef1d472a1cd3b5742afcbc40c7b 0001-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
+51c15f48a3086aedcb9b50c379396e9a 0002-Shellvars-allow-wrapping-loop-condition-to-multiple-.patch
+3983d4f2c87fdc3a7462648bf28ac1f7 0003-Shellvars-guard-against-comments.patch
+99230241ab44da842ae551ee1fd21acd 0004-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch
+1618007011bc4cb767d8a2b2e419d223 0005-Shellvars-allow-quotes-in-loop-conditions.patch
+6ea468c64e0fa8c70eb3439a8650900f 0006-Shellvars-case-support-quotes-and-spaces-in-pattern-.patch
+559ce327e30c663ac13a9d654d95ab36 0007-Shellvars-Allow-almost-any-command.patch
+f65d801a398dd8124b59f9db8b65ffdb 0008-Shellvars-test-case-for-wrapping-command-arguments.patch
+e48785687b03c48022426182fbba785e 0009-Shellvars-case-support-on-same-line-with-multiple-co.patch
+07fcbed83f7f507beeac919aa96eb7c4 0010-Shellvars-allow-the-builtin.patch"
sha256sums="80763031af76515a8ea66013ddc3c466742a15d2e907c7c8e2e3b7410262e2af augeas-1.3.0.tar.gz
0cb29dfdef3f293c5a4db06704072a6672ce728c82d4b2a7260da341522efc37 0001-Dnsmasq-add-structure-to-address-and-server-options.patch
-23a952a8f77e86656d009ad417f109e6e31b1635beb49ff6fcc232bbea6236f4 0001-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
-914ccac060da5a164c7a37e2cfdb05ea20b583a9bb84631b5bafb9ae37f18214 0002-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch
-95775c884e42e89136511afcc96802f1ac60872ef4933800b88c92b01413dad9 0003-Shellvars-Allow-almost-any-command.patch
-d53ab29203e2d443317e6ac848b0ba421d774bb08c80719863841897e8695c02 0004-Shellvars-test-case-for-wrapping-command-arguments.patch
-3ced5d61df3c509c68c135bbe78f855adf92b5bf1cfa25aa6c4ffeb25a930cff 0005-Shellvars-case-support-on-same-line-with-multiple-co.patch"
+3824c87fca915f2ace1acbcbaed075d8e77268d239d5159aa8603907558f638f 0001-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
+e05119d39bba5dd49bf6fa887f38ba3825e308efd9e8dc491694414f740b9737 0002-Shellvars-allow-wrapping-loop-condition-to-multiple-.patch
+65968c3e23dd711757aa991f7f5c27b9d72754d73310f585c43896e8e086d7b8 0003-Shellvars-guard-against-comments.patch
+f266d39442cdbc4a173cbe79acf37831e822da49989ab7336b5cf23d1cfebf0c 0004-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch
+8d81847ca3c3a3d9d4a22cf3022ad03b4dc09e02acddd2a7dbe694c9fa2ae547 0005-Shellvars-allow-quotes-in-loop-conditions.patch
+82ac0494819f6b97587c1028a468b7d29d1abcd92ba81ea991c4c830b4cdb813 0006-Shellvars-case-support-quotes-and-spaces-in-pattern-.patch
+182e6e511e21de8379cee76f14bc16ce999a5dd1a8cecbef6ea67ee7d7a471f1 0007-Shellvars-Allow-almost-any-command.patch
+ef71befc9759945fc953b28c7e81db63057a58297c8dd9642d52ec12e77f105e 0008-Shellvars-test-case-for-wrapping-command-arguments.patch
+745e8d28d038f70b10fbf35d301a6d63e780a2a01ae4c5ff3bf207ce629b3d15 0009-Shellvars-case-support-on-same-line-with-multiple-co.patch
+13017bf58ec6d7d72d2dd5954d2636f47147207543ccd9537bb08e16ae032406 0010-Shellvars-allow-the-builtin.patch"
sha512sums="92cc2cf83faa42e83621fe0f73fe9f7247d802f17da781e51d068056d20b1645de1f0ea0d5070c0d5729a3f6554d64a95e31111bf3e44b959386559619843e79 augeas-1.3.0.tar.gz
f2cdf6fcd84de4f86bc54d89292d3c4c19070b1c6d5149af6a8d7c49678e2a7527b6549ad114e5ccec53d4d9582814153732f69a4c0228243aac96c48a0e1d1d 0001-Dnsmasq-add-structure-to-address-and-server-options.patch
-e89edad7188eff4bffa8710af0f4cb79f4f1c1d37019ebd82b545465abfd276289b79d6980a3a065159d01574ab77bffb8bb0e54daeb05d7e5476f7da73552a7 0001-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
-76552267238f097431b61f2aa381846a850b0cec22072e471fbcbc1bb455dc887a4119b7d5ac592e10c509fda43159ea958f7ab6267c05f7963306aff0502a7c 0002-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch
-6286efd526f8d4ad75198a0fc02732cf560285cf0a51731faf60cf3c0c75a364852fff399dcc99e1102585c39563c2b2518ee2a4e113bafeadf5e4400a0bff59 0003-Shellvars-Allow-almost-any-command.patch
-6d7284139a1ab59fb8d189a1e851592095b511fb88cf1603213d299e0b0ca3b3afcad9ba22da0225cdb3b53a8cb1837047cec04d9a859bfc2fc73f9b78877967 0004-Shellvars-test-case-for-wrapping-command-arguments.patch
-4c1b64373dec24eee0eb11d163468852afcf24336795e116e7501804b7c1273a2bfdc78fe1bce1f327f3b4fa80c560854a71bb56ab44ac1a492f6b0905aeb18a 0005-Shellvars-case-support-on-same-line-with-multiple-co.patch"
+2a231a4f5db8c86b2710e83d4c74062a67980812df367276fc4876ccb01799881da98d95f0385972a7c229e83c18a758c67e7d5a9bef03fe8e3bd549136dcfc9 0001-Shellvars-allow-partial-quoting-mixing-multiple-styl.patch
+af2c9021f4f1286e449b0bcb3e9bee781aa7b9be2835fd48cc3fe4e2ac50d4979af06edc6272fd4fc08eaa93a7e7cc77472ca6f9b093090443657630a6512b5a 0002-Shellvars-allow-wrapping-loop-condition-to-multiple-.patch
+2297640506106bca6f1624474a87fcfc35297570e8bcb877b9ef3f955949346a6a0b542a3642af27bcc399d1e9f439ddcf097ccd59719f38810f9c2df0879943 0003-Shellvars-guard-against-comments.patch
+198aa60cd13dc18a07b3d9468e61616201632a100c008fecfbb25a5bd6d08fc37fc376522f0dff5998a78ac050902113d78f5f6342683049ed4710641cebc6b0 0004-Shellvars-allow-wrapping-builtin-arguments-to-multip.patch
+4f03a4a3c196d7639bf2e68aff4d587f157e2a5e6ecdc9eb62f08eb983e0ac130380b581c6fec9bdc0539c1ce5356af389a7744c8df6f6e7a76faeef160ab1b2 0005-Shellvars-allow-quotes-in-loop-conditions.patch
+b19af8a4bb0ab542b449f50ace8ce9ebb83619bb5587b38f012e98bdf5de6ce9673f12f3af26ac147ccf95d036fa60c437e5f0dbf504016b0831ffcb97ab3962 0006-Shellvars-case-support-quotes-and-spaces-in-pattern-.patch
+c7a7ddc3635371a74ac6b943e5b1adeab8960dc0a2d38625d2c1801ab88a60670eb8ff30b1f0938a461519b1b3199273b91e734c3b368c1d500653d5b6b82a0a 0007-Shellvars-Allow-almost-any-command.patch
+798201a25b3f42e4cfcc071e7066a4a20492f58574cd7baeea14a60569663d2b2775d6afb361900057f5add61be8e6e2a7e5b2ca395711fd13c30fce2590d5cf 0008-Shellvars-test-case-for-wrapping-command-arguments.patch
+0c337e30c77bc41caa0d672cc8db47770a03f4e3ca661b7eacab55bfc66630eef66f23f70f74abc0357890ddf612117405f7512f0b2e993ec4c8e7bb6be2d7c0 0009-Shellvars-case-support-on-same-line-with-multiple-co.patch
+9204f19e3234fc3be5bc59a374f9ac943494c1ee37a3c9c88186e2b6c1780e8376517108fe4a2567c6315bdb475ba5f492f9cb61ff569f79054ed17902368149 0010-Shellvars-allow-the-builtin.patch"