summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-11-21 09:00:50 +0000
committerTimo Teräs <timo.teras@iki.fi>2014-11-21 09:01:41 +0000
commit57983465375010a151353c3513ed4650e92473cb (patch)
tree891835bb76f78911effc61fb14d0c1deef1197a2
parent28a40b21cee915078d7cf8dcdfe6ff978c450212 (diff)
downloadaports-57983465375010a151353c3513ed4650e92473cb.tar.bz2
aports-57983465375010a151353c3513ed4650e92473cb.tar.xz
main/raspberrypi: move from testing, upgrade to latest snapshot
remove now unneeded patches. upstream supports musl.
-rw-r--r--main/raspberrypi/APKBUILD (renamed from testing/raspberrypi/APKBUILD)18
-rw-r--r--testing/raspberrypi/fix-musl.patch49
-rw-r--r--testing/raspberrypi/fix-stdc99.patch24
3 files changed, 5 insertions, 86 deletions
diff --git a/testing/raspberrypi/APKBUILD b/main/raspberrypi/APKBUILD
index 2e295e6e9..77cb839ff 100644
--- a/testing/raspberrypi/APKBUILD
+++ b/main/raspberrypi/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=raspberrypi
-pkgver=0.20140919
-_commitid=ffcc4bd7c4875b71376c4240116e251652c9bec0
+pkgver=0.20141017
+_commitid=4333d6d023a1f0dcc763d0706a1fe6523f9b6005
pkgrel=0
pkgdesc="Raspberry Pi support tools"
url="https://github.com/raspberrypi/userland"
@@ -13,8 +13,6 @@ install=""
options="!fhs"
subpackages="$pkgname-dev $pkgname-libs"
source="raspberrypi-$pkgver.tar.gz::https://github.com/raspberrypi/userland/archive/$_commitid.tar.gz
- fix-musl.patch
- fix-stdc99.patch
"
_sourcedir="$srcdir"/userland-$_commitid
@@ -53,12 +51,6 @@ libs() {
mv "$pkgdir"/opt/vc/lib/* "$subpkgdir"/opt/vc/lib
}
-md5sums="6627660ea21c35859ada7d638247e049 raspberrypi-0.20140919.tar.gz
-49a33897d575a07514b1b8d288361f63 fix-musl.patch
-7da1da67742eac08b7a36b70cea6a50d fix-stdc99.patch"
-sha256sums="a9172bb498a1537dba74df5bcef67a1b83244e45282130b05fd2873c49e15ac0 raspberrypi-0.20140919.tar.gz
-e8cbc558094d745f99a14f354720be0fdf81f2ebc48651fed32c4ae1ef1fd649 fix-musl.patch
-6cd7d652073790b66760eea41042124eb5426b23a515ad6108dc4cb25b9f61b5 fix-stdc99.patch"
-sha512sums="ee50855a2fff41c07761c9f3cabdee658f72a47b71a1ad82d478bde782c7577e9280e76f8b11432a373027f0566acb4349003b654e4a6e63ec70e9b03763fe99 raspberrypi-0.20140919.tar.gz
-8092d59985d7380b533896c6f8aad6f4838e8cf414a8052c43fa4330bc07ce6be7d2d0cc3bc280f3f63b537687cb8f51c93ef608db82fe6638505d03b317581f fix-musl.patch
-1650cf7230da10d0ceedfcae170e93d2c33e799b670392a2cc1e44cf7108c9f46c47b6daa50a608bba4e1683d859d9b70eb7d2070640c956fe6c0d58a29ca89f fix-stdc99.patch"
+md5sums="3cac9d31589cc7d41e8c03d02de76732 raspberrypi-0.20141017.tar.gz"
+sha256sums="8fb517d84f58b8c9c4ec6c8829300066e5a1fae23525a705ea5165ed97a63426 raspberrypi-0.20141017.tar.gz"
+sha512sums="249f8e44ea1048c0e339c3bb47d420845eb487809f2ba2f4896f19b1e955502856151d122a97ad4a82dcc0912e34be33d092447ec8c94bc7666fb5b19bc0fdb1 raspberrypi-0.20141017.tar.gz"
diff --git a/testing/raspberrypi/fix-musl.patch b/testing/raspberrypi/fix-musl.patch
deleted file mode 100644
index 2460d3044..000000000
--- a/testing/raspberrypi/fix-musl.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-diff --git a/interface/vcos/pthreads/vcos_platform.h b/interface/vcos/pthreads/vcos_platform.h
-index 465abd2..9356479 100755
---- a/interface/vcos/pthreads/vcos_platform.h
-+++ b/interface/vcos/pthreads/vcos_platform.h
-@@ -120,9 +120,6 @@ typedef struct
-
- #define VCOS_ONCE_INIT PTHREAD_ONCE_INIT
-
--#if defined(__arm__) && !defined(_HAVE_TIMER_T) && !defined(ANDROID)
--typedef __timer_t timer_t;
--#endif
- typedef struct VCOS_TIMER_T
- {
- pthread_t thread; /**< id of the timer thread */
-diff --git a/interface/vcos/pthreads/vcos_pthreads.c b/interface/vcos/pthreads/vcos_pthreads.c
-index 6ecc7da..9296ebe 100644
---- a/interface/vcos/pthreads/vcos_pthreads.c
-+++ b/interface/vcos/pthreads/vcos_pthreads.c
-@@ -580,7 +580,7 @@ const char ** vcos_get_argv(void)
- */
- uint32_t _vcos_get_ticks_per_second(void)
- {
-- return HZ;
-+ return 100;
- }
-
- VCOS_STATUS_T vcos_once(VCOS_ONCE_T *once_control,
-diff --git a/interface/vmcs_host/linux/vcfilesys.c b/interface/vmcs_host/linux/vcfilesys.c
-index ab65e3e..53c7486 100644
---- a/interface/vmcs_host/linux/vcfilesys.c
-+++ b/interface/vmcs_host/linux/vcfilesys.c
-@@ -49,7 +49,7 @@ SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- #include <ctype.h>
- #include <limits.h>
-
--#if !defined(ANDROID) && !defined( __USE_FILE_OFFSET64 )
-+#if defined(__GLIBC__) && !defined( __USE_FILE_OFFSET64 )
- #error "__USE_FILE_OFFSET64 isn't defined"
- #endif
-
-@@ -916,7 +916,7 @@ int vc_hostfs_set_attr(const char *path, fattributes_t attr)
-
- if (pathbuf)
- {
-- __mode_t mode = 0;
-+ mode_t mode = 0;
- struct stat sb;
-
- backslash_to_slash(pathbuf);
diff --git a/testing/raspberrypi/fix-stdc99.patch b/testing/raspberrypi/fix-stdc99.patch
deleted file mode 100644
index 4cdda94c7..000000000
--- a/testing/raspberrypi/fix-stdc99.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- userland-ffcc4bd7c4875b71376c4240116e251652c9bec0.orig/containers/CMakeLists.txt
-+++ userland-ffcc4bd7c4875b71376c4240116e251652c9bec0/containers/CMakeLists.txt
-@@ -13,7 +13,7 @@
-
- SET( GCC_COMPILER_FLAGS -Wall -g -O2 -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wcast-qual -Wwrite-strings -Wundef )
- SET( GCC_COMPILER_FLAGS ${GCC_COMPILER_FLAGS} -Wextra )#-Wno-missing-field-initializers )
--SET( GCC_COMPILER_FLAGS ${GCC_COMPILER_FLAGS} -D__STDC_VERSION__=199901L )
-+SET( GCC_COMPILER_FLAGS ${GCC_COMPILER_FLAGS} -std=c99 )
- SET( GCC_COMPILER_FLAGS ${GCC_COMPILER_FLAGS} -Wno-missing-field-initializers )
- SET( GCC_COMPILER_FLAGS ${GCC_COMPILER_FLAGS} -Wno-unused-value )
-
---- userland-ffcc4bd7c4875b71376c4240116e251652c9bec0.orig/interface/vcos/pthreads/vcos_platform.h
-+++ userland-ffcc4bd7c4875b71376c4240116e251652c9bec0/interface/vcos/pthreads/vcos_platform.h
-@@ -44,6 +44,10 @@
- extern "C" {
- #endif
-
-+#ifndef _POSIX_C_SOURCE
-+#define _POSIX_C_SOURCE 199309L
-+#endif
-+
- #include <pthread.h>
- #include <semaphore.h>
- #include <unistd.h>