summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2009-08-05 11:29:57 +0000
committerMichael Mason <ms13sp@gmail.com>2009-08-05 11:29:57 +0000
commit7b913b7019ed0bcb950e7a58927759a72eabee70 (patch)
tree819eca8437fc5f91fefa4f036cdde53e842659f5
parent32db0ab7e85e4b927abf289faddbc07cf8b9591c (diff)
parent8154f165f6a1e4cca5c699ed2b28a746e6c039f3 (diff)
downloadaports-7b913b7019ed0bcb950e7a58927759a72eabee70.tar.bz2
aports-7b913b7019ed0bcb950e7a58927759a72eabee70.tar.xz
Merge branch 'master' of git://git.alpinelinux.org/aports
-rw-r--r--main/autoconf/APKBUILD6
-rw-r--r--main/openssh/APKBUILD26
-rw-r--r--main/sysklogd/APKBUILD12
-rwxr-xr-xmain/sysklogd/sysklogd.daily82
-rw-r--r--main/sysklogd/sysklogd.logrotate12
-rw-r--r--main/sysklogd/syslog.conf6
-rw-r--r--main/syslinux/APKBUILD4
-rw-r--r--main/sysstat/APKBUILD4
-rw-r--r--main/usbutils/APKBUILD6
-rw-r--r--testing/gcc/APKBUILD9
-rw-r--r--testing/gcc/uclibc-getipinfo.patch19
11 files changed, 155 insertions, 31 deletions
diff --git a/main/autoconf/APKBUILD b/main/autoconf/APKBUILD
index 8de79f6ef..a74d9ae07 100644
--- a/main/autoconf/APKBUILD
+++ b/main/autoconf/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=autoconf
-pkgver=2.63
-pkgrel=1
+pkgver=2.64
+pkgrel=0
pkgdesc="A GNU tool for automatically configuring source code"
license="GPL2 GPL3"
url="http://www.gnu.org/software/autoconf"
@@ -19,4 +19,4 @@ build() {
rm -f "$pkgdir"/usr/share/info/standards.info
}
-md5sums='43d76649fb86cd21d64f68c48d5abdcf autoconf-2.63.tar.gz'
+md5sums="30a198cef839471dd4926e92ab485361 autoconf-2.64.tar.gz"
diff --git a/main/openssh/APKBUILD b/main/openssh/APKBUILD
index b81ae46ef..0282e9693 100644
--- a/main/openssh/APKBUILD
+++ b/main/openssh/APKBUILD
@@ -2,20 +2,20 @@
pkgname=openssh
pkgver=5.2_p1
_myver=5.2p1
-pkgrel=1
+pkgrel=2
pkgdesc="Port of OpenBSD's free SSH release"
url="http://www.openssh.org/portable.html"
license="as-is"
-depends="openssl zlib"
+depends="openssh-client"
makedepends="openssl-dev zlib-dev"
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-client"
source="ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/$pkgname-$_myver.tar.gz
sshd.initd
sshd.confd
"
-build ()
-{
+build ()
+{
cd $startdir/src/$pkgname-$_myver
sed -i -e '/_PATH_XAUTH/s:/usr/X11R6/bin/xauth:/usr/bin/xauth:' \
pathnames.h || return 1
@@ -42,6 +42,22 @@ build ()
install -D -m755 "$srcdir"/sshd.initd "$pkgdir"/etc/init.d/sshd
install -D -m644 "$srcdir"/sshd.confd "$pkgdir"/etc/conf.d/sshd
}
+
+client() {
+ pkgdesc="OpenBSD's SSH client"
+ replaces="openssh"
+ install -d "$subpkgdir"/usr/bin \
+ "$subpkgdir"/usr/lib/ssh \
+ "$subpkgdir"/etc/ssh \
+ "$subpkgdir"/var/run \
+ "$subpkgdir"/var/empty
+
+ mv "$pkgdir"/usr/bin/* "$subpkgdir"/usr/bin/
+ mv "$pkgdir"/usr/lib/ssh/ssh-keysign "$subpkgdir"/usr/lib/ssh/
+ mv "$pkgdir"/etc/ssh/ssh_config "$pkgdir"/etc/ssh/moduli \
+ "$subpkgdir"/etc/ssh/
+}
+
md5sums="ada79c7328a8551bdf55c95e631e7dad openssh-5.2p1.tar.gz
f71564ffab359faead63717920c3086b sshd.initd
b35e9f3829f4cfca07168fcba98749c7 sshd.confd"
diff --git a/main/sysklogd/APKBUILD b/main/sysklogd/APKBUILD
index 43ce5aa54..ea561d1f6 100644
--- a/main/sysklogd/APKBUILD
+++ b/main/sysklogd/APKBUILD
@@ -1,15 +1,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sysklogd
pkgver=1.5
-pkgrel=1
+pkgrel=2
pkgdesc="System and kernel log daemons"
url="http://www.infodrom.org/projects/sysklogd/"
license="GPL BSD"
subpackages="$pkgname-doc"
-depends="logrotate"
+depends=
makedepends=""
source="http://www.infodrom.org/projects/$pkgname/download/$pkgname-$pkgver.tar.gz
sysklogd.logrotate
+ sysklogd.daily
sysklogd.initd
sysklogd.confd
sysklogd-1.4.2-caen-owl-klogd-drop-root.diff
@@ -37,13 +38,16 @@ build ()
make INSTALL=install prefix="$pkgdir" install
install -D -m644 ../sysklogd.logrotate \
"$pkgdir"/etc/logrotate.d/sysklogd
+ install -D -m755 ../sysklogd.daily \
+ "$pkgdir"/etc/periodic/daily/sysklogd
install -D -m755 ../sysklogd.initd "$pkgdir"/etc/init.d/sysklogd
install -D -m644 ../sysklogd.confd "$pkgdir"/etc/conf.d/sysklogd
install -D -m644 ../syslog.conf "$pkgdir"/etc/syslog.conf
install -D -m644 ../LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
md5sums="e053094e8103165f98ddafe828f6ae4b sysklogd-1.5.tar.gz
-40304e92b2f6a92e252de24c5e3ca88e sysklogd.logrotate
+6bc1d1c65076b104a8f78d0fb4f21db7 sysklogd.logrotate
+c9274a06835b95feb8aab31523418847 sysklogd.daily
9332657663a9f4286e5c61d22c46378f sysklogd.initd
e25d7b583b7e4bd8be503b89e1771e90 sysklogd.confd
3b7ba3aa6519f96f11165a7d5900a8b1 sysklogd-1.4.2-caen-owl-klogd-drop-root.diff
@@ -51,5 +55,5 @@ e25d7b583b7e4bd8be503b89e1771e90 sysklogd.confd
6c0a416e40a678cf99c454b0e98185c9 sysklogd-1.4.2-caen-owl-syslogd-drop-root.diff
c71826d1a4f3f7e8ffa57adbfc24f1ce sysklogd-1.5-build.patch
8e70cdf98cce9defae0c28a3d2db4410 ksym-fclose-fix.diff
-49ba209742f1651f4bda6c5e92cbb3eb syslog.conf
+16019757e6af519be8cf3398b97e0f1b syslog.conf
7930f7ff5038e1318511624e348581cc LICENSE"
diff --git a/main/sysklogd/sysklogd.daily b/main/sysklogd/sysklogd.daily
new file mode 100755
index 000000000..79e85fb46
--- /dev/null
+++ b/main/sysklogd/sysklogd.daily
@@ -0,0 +1,82 @@
+#!/bin/sh
+# This is a shell script replacement for the sysklogd's logrotate cron script
+# and syslogd-listfiles perl script.
+# Copyright (C) 2008 N. Angelacos for the Alpine Linux project - GPL2
+
+
+CONF="/etc/syslog.conf"
+
+
+syslogd_listfiles() {
+ # List the target files from syslog.conf
+
+ local skip="auth"
+ [ "$1" = "--auth" ] && skip=" "
+
+ # the while loop joins lines that end in "\"
+ # the sed (in order)-
+ # strips comments;
+ # collapses spaces/tabs to 1 space;
+ # deletes the "-" in front of the filename;
+ # deletes lines that have the "skip" facility
+ # deletes the facility (leaving just the filename)
+ # deletes lines that are not filenames with leading "/"
+ while read a ; do echo "$a"; done < $CONF |\
+ sed -n "/^ *#/D; /^[ ]*$/D; s/[ ]\+/ /g; \
+ s+ -/+ /+g; /^.*\($skip\)[^ ]* /D; \
+ s/^[^ ]* //; /^[^\\/]/D; P" |\
+ sort | uniq
+}
+
+# dumb little savelog - no error checking here
+savelog () {
+ local group="adm"
+ local mode="644"
+ local user="root"
+ local cycle=2
+ local logfile=""
+
+ # parse args
+ while getopts "g:u:m:c:" opt; do
+ case $opt in
+ g) group=$OPTARG ;;
+ u) user=$OPTARG ;;
+ m) mode=$OPTARG ;;
+ c) cycle=$OPTARG ;;
+ *) echo "unknown option: $opt" >&2 && return 1;;
+ esac
+ done
+ shift $(( $OPTIND - 1 ))
+ logfile=$1
+
+ # Cycle the logs
+ while [ $cycle -ne 0 ]; do
+ p=$cycle
+ cycle=$(( $cycle - 1 ))
+ a=$logfile.$cycle*
+ b=$( echo $a | sed "s/\.$cycle/\.$p/")
+ [ -f $a ] && mv $a $b
+ done
+
+ # compress .1 and let .0 be uncompressed
+ [ -f $logfile.1 ] && gzip $logfile.1
+ [ -f $logfile ] && mv $logfile $logfile.0
+
+ # set permissions
+ chown $user:$group $logfile.* 2>/dev/null
+ chmod $mode $logfile.* 2>/dev/null
+}
+
+
+# Main script
+
+for LOG in $( syslogd_listfiles ); do
+ [ -f $LOG ] && savelog -g adm -m 640 -u root -c 7 $LOG
+done
+
+for LOG in $(syslogd_listfiles --auth); do
+ [ -f $LOG ] && savelog -g adm -m 640 -u root -c 7 $LOG
+done
+
+killall -HUP syslogd
+
diff --git a/main/sysklogd/sysklogd.logrotate b/main/sysklogd/sysklogd.logrotate
index 29afd15bd..0fd0be2ff 100644
--- a/main/sysklogd/sysklogd.logrotate
+++ b/main/sysklogd/sysklogd.logrotate
@@ -1,6 +1,6 @@
-/var/log/messages /var/log/auth /var/log/mail /var/log/errors /var/log/kernel {
- sharedscripts
- postrotate
- /etc/init.d/sysklogd --quiet reload
- endscript
-}
+# we do logrotatation in a separate cron script that parses syslog.conf
+# and rotates whatever user have configured.
+#
+# That is better than having users to maunally update this logrotate config
+# whenever they touch syslog.conf
+#
diff --git a/main/sysklogd/syslog.conf b/main/sysklogd/syslog.conf
index 855ee6e3e..aead955cc 100644
--- a/main/sysklogd/syslog.conf
+++ b/main/sysklogd/syslog.conf
@@ -18,9 +18,9 @@ user.* -/var/log/user.log
# Logging for the mail system. Split it up so that
# it is easy to write scripts to parse these files.
#
-mail.info -/var/log/mail.info
-mail.warning -/var/log/mail.warn
-mail.err /var/log/mail.err
+#mail.info -/var/log/mail.info
+#mail.warning -/var/log/mail.warn
+#mail.err /var/log/mail.err
# Some `catch-all' logfiles.
#
diff --git a/main/syslinux/APKBUILD b/main/syslinux/APKBUILD
index e7036c0f8..65c9bbf67 100644
--- a/main/syslinux/APKBUILD
+++ b/main/syslinux/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=syslinux
-pkgver=3.81
+pkgver=3.82
pkgrel=0
pkgdesc="a boot loader for the Linux operating system which operates off an MS-DOS/Windows FAT filesystem."
url="http://syslinux.org"
@@ -21,5 +21,5 @@ build ()
make INSTALLROOT="$pkgdir" MANDIR=/usr/share/man local-install
}
-md5sums="9be7f19e65aa8ffad325ccff1b6175a4 syslinux-3.81.tar.bz2
+md5sums="c9f4e73e385c86b3a8faf9b615a04836 syslinux-3.82.tar.bz2
c08398d165d29e48711e55058e2897de syslinux-3.72-nopie.patch"
diff --git a/main/sysstat/APKBUILD b/main/sysstat/APKBUILD
index f9a1408b7..90a81b3c6 100644
--- a/main/sysstat/APKBUILD
+++ b/main/sysstat/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sysstat
-pkgver=9.0.3
+pkgver=9.0.4
pkgrel=0
pkgdesc="Performance monitoring tools for Linux"
url="http://pagesperso-orange.fr/sebastien.godard/"
@@ -24,4 +24,4 @@ build() {
}
-md5sums="0b464951596db934418259737cf50a31 sysstat-9.0.3.tar.gz"
+md5sums="961ff56564c1fbf9db9baa5aa4ad0ea5 sysstat-9.0.4.tar.gz"
diff --git a/main/usbutils/APKBUILD b/main/usbutils/APKBUILD
index 7dc7905c3..b035c67e0 100644
--- a/main/usbutils/APKBUILD
+++ b/main/usbutils/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=usbutils
-pkgver=0.82
-pkgrel=1
+pkgver=0.84
+pkgrel=0
pkgdesc="USB Device Utilities"
url="http://linux-usb.sourceforge.net/"
license="GPL"
@@ -21,4 +21,4 @@ build ()
make || return 1
make DESTDIR="$pkgdir" install
}
-md5sums="6e393cc7423b5d228fa3d34c21481ae4 usbutils-0.82.tar.gz"
+md5sums="87612c82e66393a395db91361d168c1b usbutils-0.84.tar.gz"
diff --git a/testing/gcc/APKBUILD b/testing/gcc/APKBUILD
index 8f78827e9..0dd1f35bc 100644
--- a/testing/gcc/APKBUILD
+++ b/testing/gcc/APKBUILD
@@ -3,7 +3,7 @@ pkgname=gcc
pkgver=4.4.1
_specsver=0.1.4
_espfver=0.3.1
-pkgrel=0
+pkgrel=1
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
license="GPL LGPL"
@@ -16,6 +16,7 @@ source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-core-$pkgver.tar.bz2
http://weaver.gentooenterprise.com/hardened/patches/gcc-$pkgver-specs-$_specsver.tar.bz2
gcc4-stack-protector-uclibc-no_tls.patch
pt_gnu_eh_frame.patch
+ uclibc-getipinfo.patch
"
# ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-objc-$pkgver.tar.bz2
build ()
@@ -60,7 +61,8 @@ build ()
--enable-shared \
--enable-target-optspace \
--with-arch=i486 \
- --with-system-zlib
+ --with-system-zlib \
+ --without-system-libunwind
make || return 1
make -j1 DESTDIR="${pkgdir}" install || return 1
@@ -119,4 +121,5 @@ d449047b5761348ceec23739f5553e0b gcc-g++-4.4.1.tar.bz2
43d0bbd676bbb2acd67ddabd0ea1bc2b gcc-4.4.1-espf-0.3.1.tar.bz2
da8d9165e828bbb9809ef86f1c72886f gcc-4.4.1-specs-0.1.4.tar.bz2
15e77082db0e1a131af98debd3016290 gcc4-stack-protector-uclibc-no_tls.patch
-2db1e3482c5dd59dab70f701afa2ca80 pt_gnu_eh_frame.patch"
+2db1e3482c5dd59dab70f701afa2ca80 pt_gnu_eh_frame.patch
+6cc2385c5bbd6d0da6eaedd53c8bf547 uclibc-getipinfo.patch"
diff --git a/testing/gcc/uclibc-getipinfo.patch b/testing/gcc/uclibc-getipinfo.patch
new file mode 100644
index 000000000..3abbbdd7a
--- /dev/null
+++ b/testing/gcc/uclibc-getipinfo.patch
@@ -0,0 +1,19 @@
+--- a/libstdc++-v3/configure 2009-08-04 15:41:02.000000000 +0000
++++ b/libstdc++-v3/configure 2009-08-04 15:46:20.000000000 +0000
+@@ -113523,14 +113523,14 @@
+ # Based on system-libunwind and target, do we have ipinfo?
+ if test x$with_system_libunwind = xyes; then
+ case ${target} in
+- ia64-*-*) have_unwind_getipinfo=no ;;
++ ia64-*-*|*-uclibc*) have_unwind_getipinfo=no ;;
+ *) have_unwind_getipinfo=yes ;;
+ esac
+ else
+ # Darwin before version 9 does not have _Unwind_GetIPInfo.
+
+ case ${target} in
+- *-*-darwin[3-8]|*-*-darwin[3-8].*) have_unwind_getipinfo=no ;;
++ *-*-darwin[3-8]|*-*-darwin[3-8].*|*-uclibc*) have_unwind_getipinfo=no ;;
+ *) have_unwind_getipinfo=yes ;;
+ esac
+