summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-11-26 13:56:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-11-26 13:56:39 +0000
commiteec958fe0d531223ec6857ea925aca7c8835b410 (patch)
tree6e63e3f707dc4f47add035efb84c93c65816e62f
parenta9e41e4df2ce32c78f2f255fb5ab25a4f5ace671 (diff)
downloadaports-eec958fe0d531223ec6857ea925aca7c8835b410.tar.bz2
aports-eec958fe0d531223ec6857ea925aca7c8835b410.tar.xz
main/mkinitfs: add boot option for nofbcon
-rw-r--r--main/mkinitfs/0001-init-fix-loading-of-fbcon.patch42
-rw-r--r--main/mkinitfs/APKBUILD12
2 files changed, 50 insertions, 4 deletions
diff --git a/main/mkinitfs/0001-init-fix-loading-of-fbcon.patch b/main/mkinitfs/0001-init-fix-loading-of-fbcon.patch
new file mode 100644
index 000000000..485229a2c
--- /dev/null
+++ b/main/mkinitfs/0001-init-fix-loading-of-fbcon.patch
@@ -0,0 +1,42 @@
+From 8427257b986105d09c4c287e739af152dc6ccfce Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Wed, 26 Nov 2014 13:53:23 +0000
+Subject: [PATCH] init: fix loading of fbcon
+
+we check if /sys/class/graphics/fb0 exists before loading fbcon and
+allow user to disable tiwh nofbcon as boot option
+---
+ initramfs-init.in | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/initramfs-init.in b/initramfs-init.in
+index 7831995..4b010f6 100755
+--- a/initramfs-init.in
++++ b/initramfs-init.in
+@@ -386,7 +386,7 @@ eval set -- `cat /proc/cmdline`
+
+ myopts="alpine_dev autodetect autoraid chart cryptroot cryptdm debug_init
+ dma init_args keep_apk_new modules ovl_dev pkgs quiet root_size root
+- usbdelay ip alpine_repo apkovl alpine_start"
++ usbdelay ip alpine_repo apkovl alpine_start nofbcon"
+
+ for opt; do
+ case "$opt" in
+@@ -524,11 +524,11 @@ scan_drivers
+ scan_drivers
+ eend 0
+
+-ebegin "Setting up framebuffer console"
+-if [ -d /lib/modules/`uname -r`/kernel/drivers/gpu ]; then
++if [ -z "$KOPT_nofbcon" ] && [ -e /sys/class/graphics/fb0 ]; then
++ ebegin "Setting up framebuffer console"
+ modprobe -q fbcon &>/dev/null
++ eend 0
+ fi
+-eend 0
+
+ # check if root=... was set
+ if [ -n "$KOPT_root" ]; then
+--
+2.1.3
+
diff --git a/main/mkinitfs/APKBUILD b/main/mkinitfs/APKBUILD
index bbd064569..23a7fd653 100644
--- a/main/mkinitfs/APKBUILD
+++ b/main/mkinitfs/APKBUILD
@@ -2,7 +2,7 @@
pkgname=mkinitfs
pkgver=2.7.0
_ver=${pkgver%_git*}
-pkgrel=1
+pkgrel=2
pkgdesc="Tool to generate initramfs images for Alpine"
url=http://git.alpinelinux.org/cgit/mkinitfs
depends="busybox apk-tools>=2.0 lddtree>=1.25"
@@ -10,6 +10,7 @@ install="$pkgname.pre-upgrade"
triggers="$pkgname.trigger=/usr/share/kernel/*"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$_ver.tar.xz
0001-init-lvm-run-vgchange-even-if-vgscan-does-not-return.patch
+ 0001-init-fix-loading-of-fbcon.patch
"
arch="noarch"
license="GPL-2"
@@ -36,8 +37,11 @@ package() {
make install DESTDIR="$pkgdir" || return 1
}
md5sums="fbf7a5ec2530490f9edd8df4541eff99 mkinitfs-2.7.0.tar.xz
-de01f4ac9c44fe84ce0022bd56f1f386 0001-init-lvm-run-vgchange-even-if-vgscan-does-not-return.patch"
+de01f4ac9c44fe84ce0022bd56f1f386 0001-init-lvm-run-vgchange-even-if-vgscan-does-not-return.patch
+324e26c1648699a1500add5095157220 0001-init-fix-loading-of-fbcon.patch"
sha256sums="99019951e0ea914f00bf94dea69a0f9456bdb4f5934d8c6de3e5ed628b4734e6 mkinitfs-2.7.0.tar.xz
-a1ee3fdffbf2bf8311e8d37f6e8b3d6c0b787dc3e1e6a02bf45fa9dfe84baa33 0001-init-lvm-run-vgchange-even-if-vgscan-does-not-return.patch"
+a1ee3fdffbf2bf8311e8d37f6e8b3d6c0b787dc3e1e6a02bf45fa9dfe84baa33 0001-init-lvm-run-vgchange-even-if-vgscan-does-not-return.patch
+cfc5af8542966624ef7b5afc1f0c70117ae393d4446386dcf6940d2ef9d1885f 0001-init-fix-loading-of-fbcon.patch"
sha512sums="ec0bad81773374ae7221da53cc889b3bddc2749c207715817f691ba1fbba5ee3967c1656283212525f0486a23b9b05379900473ee6188474bdbd6325ee50d1da mkinitfs-2.7.0.tar.xz
-3f053f0956697cb38e1248b52365d033e22910ae44437a4f64eef85fe426a2f4e90b66557c06f053c8220466fc2f54c6d4de8da1a8db7466b4ddac4bf13372a7 0001-init-lvm-run-vgchange-even-if-vgscan-does-not-return.patch"
+3f053f0956697cb38e1248b52365d033e22910ae44437a4f64eef85fe426a2f4e90b66557c06f053c8220466fc2f54c6d4de8da1a8db7466b4ddac4bf13372a7 0001-init-lvm-run-vgchange-even-if-vgscan-does-not-return.patch
+434af8d7867f13c6820ea2e45e53ce2d9129d664809c1a6605b5a1c8250dcec32109fecae47972853cf6b8cefc2fe1863c08d222cd95c5ee626bbf78c8a3bb15 0001-init-fix-loading-of-fbcon.patch"