summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmatcoder <amatcoder@gmail.com>2014-12-01 04:08:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-12-01 10:27:14 +0000
commit7f7e180cf1fd282dc6c6e0642a16be75bde4a343 (patch)
tree836b6027c9910a5648eef0749e98eb840d485f28
parent6b20ecac89098aaa157fe2b9edc3966f659bb4d4 (diff)
downloadaports-7f7e180cf1fd282dc6c6e0642a16be75bde4a343.tar.bz2
aports-7f7e180cf1fd282dc6c6e0642a16be75bde4a343.tar.xz
testing/mednafen: Fix textrels on x86 and rebuild against new libcdio
-rw-r--r--testing/mednafen/01-fix_help.patch6
-rw-r--r--testing/mednafen/03-fix_textrels.patch11
-rw-r--r--testing/mednafen/APKBUILD22
3 files changed, 27 insertions, 12 deletions
diff --git a/testing/mednafen/01-fix_help.patch b/testing/mednafen/01-fix_help.patch
index f05798ebb..48c35d7cd 100644
--- a/testing/mednafen/01-fix_help.patch
+++ b/testing/mednafen/01-fix_help.patch
@@ -5,7 +5,7 @@
{
printf(_("No command-line arguments specified.\n\n"));
- printf(usage_string, argv[0]);
-+ printf(usage_string, "/usr/bin/mednafen");
++ printf(usage_string, "mednafen");
printf(_("\tPlease refer to the documentation for option parameters and usage.\n\n"));
return(0);
}
@@ -14,12 +14,12 @@
if(ShowCLHelp)
{
- printf(usage_string, argv[0]);
-+ printf(usage_string, "/usr/bin/mednafen");
++ printf(usage_string, "mednafen");
ShowArgumentsHelp(MDFNArgs, false);
printf("\n");
printf(_("Each setting(listed in the documentation) can also be passed as an argument by prefixing the name with a hyphen,\nand specifying the value to change the setting to as the next argument.\n\n"));
- printf(_("For example:\n\t%s -pce.stretch aspect -pce.pixshader autoipsharper \"Hyper Bonk Soldier.pce\"\n\n"), argv[0]);
-+ printf(_("For example:\n\t/usr/bin/mednafen -pce.stretch aspect -pce.pixshader autoipsharper \"Hyper Bonk Soldier.pce\"\n\n"));
++ printf(_("For example:\n\tmednafen -pce.stretch aspect -pce.pixshader autoipsharper \"Hyper Bonk Soldier.pce\"\n\n"));
printf(_("Settings specified in this manner are automatically saved to the configuration file, hence they\ndo not need to be passed to future invocations of the Mednafen executable.\n"));
printf("\n");
return(0);
diff --git a/testing/mednafen/03-fix_textrels.patch b/testing/mednafen/03-fix_textrels.patch
new file mode 100644
index 000000000..1ebbea5b1
--- /dev/null
+++ b/testing/mednafen/03-fix_textrels.patch
@@ -0,0 +1,11 @@
+--- origin/configure
++++ mednafen/configure
+@@ -26907,7 +26907,7 @@
+ fi
+
+
+- CPPFLAGS="-fno-pic -fno-pie $CPPFLAGS"
++ CPPFLAGS="$CPPFLAGS"
+
+ MMX_CFLAGS="-mmmx"
+ SSE_CFLAGS="-msse"
diff --git a/testing/mednafen/APKBUILD b/testing/mednafen/APKBUILD
index 12fb6cae3..bc058faab 100644
--- a/testing/mednafen/APKBUILD
+++ b/testing/mednafen/APKBUILD
@@ -2,10 +2,10 @@
# Maintainer: August Klein <amatcoder@gmail.com>
pkgname=mednafen
pkgver=0.9.36.5
-pkgrel=2
+pkgrel=3
pkgdesc="A command-line multi-system emulator"
url="http://mednafen.sourceforge.net"
-arch="x86_64"
+arch="all"
license="GPL2"
depends=""
depends_dev="alsa-lib-dev libcdio-dev libsndfile-dev sdl-dev zlib-dev"
@@ -14,7 +14,8 @@ install=""
subpackages="$pkgname-lang"
source="https://prdownloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2
01-fix_help.patch
- 02-sdl_by_default.patch"
+ 02-sdl_by_default.patch
+ 03-fix_textrels.patch"
_builddir="$srcdir"/$pkgname
prepare() {
@@ -58,11 +59,14 @@ __EOF__
}
md5sums="a0841f0073322414858c22e247344502 mednafen-0.9.36.5.tar.bz2
-0eca9d6e2b75e1687c231130994e9ec6 01-fix_help.patch
-af94272d82816ca74db585c7c5f96bf6 02-sdl_by_default.patch"
+259d9396e292b0446f3837799c3ff091 01-fix_help.patch
+af94272d82816ca74db585c7c5f96bf6 02-sdl_by_default.patch
+355403c74108baaa6b65fc5521c87be0 03-fix_textrels.patch"
sha256sums="1f3ac7dd705e71a77ccbac0e74e07609bb90b15dfdce04d8f452d8cddd878d0e mednafen-0.9.36.5.tar.bz2
-3428cd835d68dda2476b01facbf46d960d24deffbbaa58a70ce8b84d6081583f 01-fix_help.patch
-22744df0ece6e67d2c61d8f014e3dbe65d3f425819be742e547a07e676efc5ee 02-sdl_by_default.patch"
+511509758cd80cb2472bc95a8c790ae69565869a081a6d70acffb5d57c6c4b4a 01-fix_help.patch
+22744df0ece6e67d2c61d8f014e3dbe65d3f425819be742e547a07e676efc5ee 02-sdl_by_default.patch
+36d96b1e5829a67e7458a338d3c296e56f1cae5f3ba11453949be7e7ef52ed02 03-fix_textrels.patch"
sha512sums="76e8534f91f70100d0e0c0c3e490c71929cce24b47880d1271eaf7d581ec488427194c23ba96d6400ad4d0a80134479442b8a5448776d484dbf4d1940deb61da mednafen-0.9.36.5.tar.bz2
-55110e6b3d62d716e6c572a2abbc3914d10461b90ae6a1b2a433c4508fb17bca1ac7010cb3bd25938b937744725c577dae177a598ce4142dfc4da53f3a54f6c2 01-fix_help.patch
-ab52224218c972a2f5f470ad5fe2db7fc37422466c1edd3c6170feefafbf6b55c83b5f92b09fc86648444e835a8b38b0a773b9aae462fa5d3a3c203ef534c574 02-sdl_by_default.patch"
+80e549698687fbe61021ccf964979bb83243ba86d5651fb648ca134822b6b0147c79d0491d076cdfbd579236b5e9db314fcda6d0df46b17a4e856e3677314c56 01-fix_help.patch
+ab52224218c972a2f5f470ad5fe2db7fc37422466c1edd3c6170feefafbf6b55c83b5f92b09fc86648444e835a8b38b0a773b9aae462fa5d3a3c203ef534c574 02-sdl_by_default.patch
+361522814a514c7bb21c3d3c3451b80817a6de80c224f839071590ae6469a994e144100b67f7e33d4259e4dd3af6b115fe8e12470aaff143920b8193e54db343 03-fix_textrels.patch"