summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2014-12-05 08:55:22 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2014-12-05 08:55:40 +0000
commit61e53274600c0ab7fc52b6e1cd6b5367fec2e5d4 (patch)
tree63da582dc8305b886398d5841c115ebf7fc73c15
parentbb2ea437caa260d21eb03dff1883bf1cb4908fd5 (diff)
downloadaports-61e53274600c0ab7fc52b6e1cd6b5367fec2e5d4.tar.bz2
aports-61e53274600c0ab7fc52b6e1cd6b5367fec2e5d4.tar.xz
main/lsyncd: more lpostcmd patching
-rw-r--r--main/lsyncd/APKBUILD8
-rw-r--r--main/lsyncd/lpostcmd.patch18
2 files changed, 22 insertions, 4 deletions
diff --git a/main/lsyncd/APKBUILD b/main/lsyncd/APKBUILD
index b7c80baaa..7e3e59779 100644
--- a/main/lsyncd/APKBUILD
+++ b/main/lsyncd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lsyncd
pkgver=2.1.5
-pkgrel=0
+pkgrel=1
pkgdesc="Live Syncing (Mirror) Daemon"
url="http://code.google.com/p/lsyncd/"
arch="all"
@@ -55,13 +55,13 @@ package() {
md5sums="fb10547494ec5ec662fe88343047c364 lsyncd-2.1.5.tar.gz
a14565df7274ebd0b605301ca39ae885 fix-realpath.patch
-b84df7c8f645e284357e0b4fc0afaa8a lpostcmd.patch
+51e42290519bb2f4492d18b0209dfab1 lpostcmd.patch
c9e77dddc6dc3eef6f35bf2d23658818 lsyncd.initd"
sha256sums="4a793056c4ed833edb59436d7711bb65f7e38a4d8d44371cc9dc5eb91fbc461f lsyncd-2.1.5.tar.gz
26454c77bb005c165c10b05b232c587669d35ab98e0ac889a11923106126f98e fix-realpath.patch
-b14b2784942f304486ac7451fcd2e15d9eac42e489e224809c4c795a5dadc759 lpostcmd.patch
+1e7cdd7fa8e510faaf4a04f4ee43b03c6d6ab8a754e576d630f54e882bf7bdb1 lpostcmd.patch
770b2c123d062ddcbf7c9eb709c56f9dd812cce66bf5e76b88a86609cc9925b0 lsyncd.initd"
sha512sums="7be939e979525f8e4687432ffe952b1d09b8a34b4d7f92ebe86b5cddb765dbd602258682612529e9cc51305d6d001e72de9e6da62761397df23ecda30fd6a12b lsyncd-2.1.5.tar.gz
2cebaf59d960321c2eda4ef1e0d850f62eb7eedb7ba8922a5db33a7f78c769d1a52839fbb597ae06ba576632e2abc7b92a6ba2eaf58b71b93bc877db83e25576 fix-realpath.patch
-a7c3ae7d3062bd186c2b5576ce0f1134e0fc8f8a9422220d14d5a9ebb2c9fe27ca508fad82c468d51aa262492fc17408e2e0abfcccc311e1e5248e2e92a56020 lpostcmd.patch
+389bd6857ac075a27c00b06bbceffb82a501b67c352a43982add42bf58f506b9bfb765486937c3776b213286da1bd5c566dd3ee2435b64aa899a9b807eee028c lpostcmd.patch
e283f81c4d8c2c5b7cc333920a7f69f059846eb537a1c8700bfaf9e07f65740e76afe4726348d785c00fae11067fabb0917cacb42193b96d550807cc9b65a445 lsyncd.initd"
diff --git a/main/lsyncd/lpostcmd.patch b/main/lsyncd/lpostcmd.patch
index cf0254573..c5d694419 100644
--- a/main/lsyncd/lpostcmd.patch
+++ b/main/lsyncd/lpostcmd.patch
@@ -1,5 +1,14 @@
--- a/examples/lpostcmd.lua
+++ b/examples/lpostcmd.lua
+@@ -6,7 +6,7 @@
+ -- after every successfullycompleted rsync operation.
+ -- for example to restart servlets on the target host or so.
+
+-local rsyncpostcmd = {
++rsyncpostcmd = {
+
+ -- based on default rsync.
+ default.rsync,
@@ -25,7 +25,7 @@
-- uses rawget to test if "isPostcmd" has been set without
-- triggering an error if not.
@@ -9,6 +18,15 @@
spawn(event, "/usr/bin/ssh",
config.host, config.postcmd)
return
+@@ -58,7 +58,7 @@
+ return default.collect(agent,exitcode)
+ end
+ error("this should never be reached")
+- end
++ end,
+
+ -- called before anything else
+ -- builds the target from host and targetdir
@@ -75,13 +75,3 @@
return default.rsync.prepare(config)
end