summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeff Bilyk <jbilyk@gmail.com>2011-03-20 20:43:56 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2011-03-21 12:52:57 +0000
commit33dd75b8f2ac51f8f1a2a63c7e5883d8b263358f (patch)
treeaaaa1581cb27ce671f43a73b078cf4de9b0a3fd0
parent03b24828ff913c3734e7c9ecfd817e59fb666a36 (diff)
downloadaports-33dd75b8f2ac51f8f1a2a63c7e5883d8b263358f.tar.bz2
aports-33dd75b8f2ac51f8f1a2a63c7e5883d8b263358f.tar.xz
testing/putty: new aport - cli tools only
cli tools only for putty
-rw-r--r--testing/putty/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/putty/APKBUILD b/testing/putty/APKBUILD
new file mode 100644
index 000000000..69f4cb94b
--- /dev/null
+++ b/testing/putty/APKBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Jeff Bilyk <jbilyk@alpinelinux.org>
+pkgname=putty
+pkgver=0.60
+pkgrel=0
+pkgdesc="SSH and telnet client"
+url="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
+arch="all"
+license="custom"
+depends=
+depends_dev=
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://the.earth.li/~sgtatham/putty/latest/putty-$pkgver.tar.gz"
+
+_builddir="$srcdir"/putty-$pkgver/unix
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+
+ # We only make all-cli, so no need to try to install these`
+ sed -i 's#$(INSTALL_PROGRAM) -m 755 pterm $(DESTDIR)$(bindir)/pterm##' Makefile.in
+ sed -i 's#$(INSTALL_PROGRAM) -m 755 putty $(DESTDIR)$(bindir)/putty##' Makefile.in
+ sed -i 's#$(INSTALL_PROGRAM) -m 755 puttytel $(DESTDIR)$(bindir)/puttytel##' Makefile.in
+
+ ./configure --prefix=/usr
+ make all-cli || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -dm755 $pkgdir/usr/bin
+ install -dm755 $pkgdir/usr/share/man/man1
+ make DESTDIR="$pkgdir" install || return 1
+ install -D -m644 ../LICENCE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+
+md5sums="07e65fd98b16d115ae38a180bfb242e2 putty-0.60.tar.gz"