summaryrefslogtreecommitdiffstats
path: root/extra/oidentd
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-24 08:01:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-24 08:01:31 +0000
commitb70981b68efcce5256eb11c6cd26ae123b10b6ea (patch)
treea38be6efae5e2ba15c2e839504632f9b7bfd5f91 /extra/oidentd
parent2b4df81538b8398442d5296650905c70341dd8d3 (diff)
downloadaports-b70981b68efcce5256eb11c6cd26ae123b10b6ea.tar.bz2
aports-b70981b68efcce5256eb11c6cd26ae123b10b6ea.tar.xz
moved extra/* to main/
and fixed misc build issues
Diffstat (limited to 'extra/oidentd')
-rw-r--r--extra/oidentd/APKBUILD34
-rw-r--r--extra/oidentd/oidentd.conf22
-rw-r--r--extra/oidentd/oidentd.confd4
-rw-r--r--extra/oidentd/oidentd.initd42
4 files changed, 0 insertions, 102 deletions
diff --git a/extra/oidentd/APKBUILD b/extra/oidentd/APKBUILD
deleted file mode 100644
index 130283f72..000000000
--- a/extra/oidentd/APKBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-pkgname=oidentd
-pkgver=2.0.8
-pkgrel=0
-pkgdesc="Configurable IDENT server that supports NAT/IP masq."
-url="http://dev.ojnk.net/"
-license="GPL"
-depends="uclibc"
-makedepends=""
-subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/ojnk/$pkgname-$pkgver.tar.gz
-oidentd.conf
-oidentd.initd
-oidentd.confd"
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info
- make || return 1
- make DESTDIR="$pkgdir" install
- install -D -m755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- install -D -m644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
- install -D -m644 "$srcdir"/$pkgname.conf "$pkgdir"/etc/$pkgname.conf
-
-}
-
-md5sums="c3d9a56255819ef8904b867284386911 oidentd-2.0.8.tar.gz
-d9c40e4d6a0bde685a359ad49b4eada2 oidentd.conf
-89a027c3b8245f6c5e79930d16d485f7 oidentd.initd
-05a43d3987754f179f4e31bbe61ff315 oidentd.confd"
diff --git a/extra/oidentd/oidentd.conf b/extra/oidentd/oidentd.conf
deleted file mode 100644
index 03b28d827..000000000
--- a/extra/oidentd/oidentd.conf
+++ /dev/null
@@ -1,22 +0,0 @@
-# Configuration for oidentd
-# see oidentd.conf(5)
-#
-default {
- default {
- deny spoof
- deny spoof_all
- deny spoof_privport
- allow random
- allow random_numeric
- allow numeric
- deny hide
- }
-}
-
-# you may want to hide root connections
-#user "root" {
-# default {
-# force reply "UNKNOWN"
-# }
-#}
-
diff --git a/extra/oidentd/oidentd.confd b/extra/oidentd/oidentd.confd
deleted file mode 100644
index 3116889e6..000000000
--- a/extra/oidentd/oidentd.confd
+++ /dev/null
@@ -1,4 +0,0 @@
-# oidentd start-up options
-USER="nobody"
-GROUP="nobody"
-OPTIONS=""
diff --git a/extra/oidentd/oidentd.initd b/extra/oidentd/oidentd.initd
deleted file mode 100644
index c40b058da..000000000
--- a/extra/oidentd/oidentd.initd
+++ /dev/null
@@ -1,42 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/net-misc/oidentd/files/oidentd-2.0.7-init,v 1.4 2007/10/24 11:38:14 uberlord Exp $
-
-depend() {
- need net
-}
-
-check_config() {
- if [ -z "${USER}" ]
- then
- eerror "Please set \$USER in /etc/conf.d/oidentd!"
- return 1
- fi
- if [ -z "${GROUP}" ]
- then
- eerror "Please set \$GROUP in /etc/conf.d/oidentd!"
- return 1
- fi
-
- if [ "$(sysctl -n security.bsd.see_other_uids 2>/dev/null)" = "0" ]; then
- eerror "${SVCNAME} cannot work if the sysctl security.bsd.see_other_uids is 0"
- return 1
- fi
-}
-
-
-start() {
- check_config || return 1
- ebegin "Starting oidentd"
- OPTIONS="${OPTIONS} -u ${USER} -g ${GROUP}"
- start-stop-daemon --start --quiet --exec /usr/sbin/oidentd -- $OPTIONS
- eend $?
-}
-
-stop() {
- ebegin "Stopping oidentd"
- start-stop-daemon --stop --quiet --exec /usr/sbin/oidentd
- eend $?
-}
-