summaryrefslogtreecommitdiffstats
path: root/main/apk-tools
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2011-02-26 12:50:07 +0200
committerTimo Teräs <timo.teras@iki.fi>2011-02-26 12:50:07 +0200
commit45915b09c8453ceb72821fd33729fa54aeb66086 (patch)
treec828e34d1328a0333119c86c032efdcc7eace5f4 /main/apk-tools
parent0feee02f95ced07bd1379470d79e0713fdafcab1 (diff)
downloadaports-45915b09c8453ceb72821fd33729fa54aeb66086.tar.bz2
aports-45915b09c8453ceb72821fd33729fa54aeb66086.tar.xz
main/apk-tools: update to 2.0.8
Diffstat (limited to 'main/apk-tools')
-rw-r--r--main/apk-tools/0001-db-fix-package-caching.patch28
-rw-r--r--main/apk-tools/0001-gunzip-fix-ordering-of-boundary-callbacks.patch81
-rw-r--r--main/apk-tools/0001-info-return-error-if-owning-package-was-not-found.patch44
-rw-r--r--main/apk-tools/APKBUILD12
4 files changed, 3 insertions, 162 deletions
diff --git a/main/apk-tools/0001-db-fix-package-caching.patch b/main/apk-tools/0001-db-fix-package-caching.patch
deleted file mode 100644
index e4173c7db..000000000
--- a/main/apk-tools/0001-db-fix-package-caching.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 1c6ab67984b20b49ed12a0576e59cd446a44ae84 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
-Date: Fri, 21 Jan 2011 09:37:19 +0200
-Subject: [PATCH] db: fix package caching
-
----
- src/database.c | 4 ++--
- 1 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/database.c b/src/database.c
-index c985233..53a18c7 100644
---- a/src/database.c
-+++ b/src/database.c
-@@ -2061,9 +2061,9 @@ static int apk_db_unpack_pkg(struct apk_database *db,
-
- if (need_copy) {
- if (r == 0)
-- renameat(db->cachetmp_fd, file, db->cache_fd, file);
-+ renameat(db->cachetmp_fd, item, db->cache_fd, item);
- else
-- unlinkat(db->cachetmp_fd, file, 0);
-+ unlinkat(db->cachetmp_fd, item, 0);
- }
-
- if (r != 0) {
---
-1.7.1
-
diff --git a/main/apk-tools/0001-gunzip-fix-ordering-of-boundary-callbacks.patch b/main/apk-tools/0001-gunzip-fix-ordering-of-boundary-callbacks.patch
deleted file mode 100644
index 44711d227..000000000
--- a/main/apk-tools/0001-gunzip-fix-ordering-of-boundary-callbacks.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-From f126316c791371bd3dfd7c348b10e93e49f5e2d4 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
-Date: Fri, 17 Dec 2010 09:36:19 +0200
-Subject: [PATCH] gunzip: fix ordering of boundary callbacks
-
-The boundary callback should not happen until all the uncompressed
-data has been consumed. This previously seems to have worked
-because normally gzip library returns "no error" instead of the
-"stream end" if we extract exactly the amount of bytes remaining
-in the archive. (Perhaps this was changed in new zlib.) In any
-case, verification was broken with some apks due to this callback
-ordering issue.
----
- src/gunzip.c | 32 ++++++++++++++++++++++++--------
- 1 files changed, 24 insertions(+), 8 deletions(-)
-
-diff --git a/src/gunzip.c b/src/gunzip.c
-index aebaf76..df2bbbb 100644
---- a/src/gunzip.c
-+++ b/src/gunzip.c
-@@ -27,6 +27,7 @@ struct apk_gzip_istream {
- apk_multipart_cb cb;
- void *cbctx;
- void *cbprev;
-+ apk_blob_t cbarg;
- };
-
- static ssize_t gzi_read(void *stream, void *ptr, size_t size)
-@@ -48,6 +49,18 @@ static ssize_t gzi_read(void *stream, void *ptr, size_t size)
- gis->zs.next_out = ptr;
-
- while (gis->zs.avail_out != 0 && gis->err == 0) {
-+ if (!APK_BLOB_IS_NULL(gis->cbarg)) {
-+ r = gis->cb(gis->cbctx,
-+ gis->err ? APK_MPART_END : APK_MPART_BOUNDARY,
-+ gis->cbarg);
-+ if (r > 0)
-+ r = -ECANCELED;
-+ if (r != 0) {
-+ gis->err = r;
-+ goto ret;
-+ }
-+ gis->cbarg = APK_BLOB_NULL;
-+ }
- if (gis->zs.avail_in == 0) {
- apk_blob_t blob;
-
-@@ -86,19 +99,22 @@ static ssize_t gzi_read(void *stream, void *ptr, size_t size)
- gis->zs.avail_in == 0)
- gis->err = 1;
- if (gis->cb != NULL) {
-+ gis->cbarg = APK_BLOB_PTR_LEN(gis->cbprev, (void *) gis->zs.next_in - gis->cbprev);
-+ gis->cbprev = gis->zs.next_in;
-+ }
-+ /* If we hit end of the bitstream (not end
-+ * of just this gzip), we need to do the
-+ * callback here, as we won't be called again.
-+ * For boundaries it should be postponed to not
-+ * be called until next gzip read is started. */
-+ if (gis->err) {
- r = gis->cb(gis->cbctx,
- gis->err ? APK_MPART_END : APK_MPART_BOUNDARY,
-- APK_BLOB_PTR_LEN(gis->cbprev, (void *) gis->zs.next_in - gis->cbprev));
-+ gis->cbarg);
- if (r > 0)
- r = -ECANCELED;
-- if (r != 0) {
-- gis->err = r;
-- goto ret;
-- }
-- gis->cbprev = gis->zs.next_in;
-- }
-- if (gis->err)
- goto ret;
-+ }
- inflateEnd(&gis->zs);
- if (inflateInit2(&gis->zs, 15+32) != Z_OK)
- return -ENOMEM;
---
-1.7.3.4
-
diff --git a/main/apk-tools/0001-info-return-error-if-owning-package-was-not-found.patch b/main/apk-tools/0001-info-return-error-if-owning-package-was-not-found.patch
deleted file mode 100644
index a22ef1b40..000000000
--- a/main/apk-tools/0001-info-return-error-if-owning-package-was-not-found.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From 4d6e25a8545a647cf80cb48eedb2a4b36715ec3a Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Wed, 15 Dec 2010 10:20:30 +0000
-Subject: [PATCH] info: return error if owning package was not found
-
----
- src/info.c | 9 ++++++---
- 1 files changed, 6 insertions(+), 3 deletions(-)
-
-diff --git a/src/info.c b/src/info.c
-index 19a3f48..b16f188 100644
---- a/src/info.c
-+++ b/src/info.c
-@@ -101,13 +101,16 @@ static int info_who_owns(struct info_ctx *ctx, struct apk_database *db,
- struct apk_package *pkg;
- struct apk_dependency_array *deps;
- struct apk_dependency dep;
-- int i;
-+ int i, r=0;
-
- apk_dependency_array_init(&deps);
- for (i = 0; i < argc; i++) {
- pkg = apk_db_get_file_owner(db, APK_BLOB_STR(argv[i]));
-- if (pkg == NULL)
-+ if (pkg == NULL) {
-+ apk_error("%s: Could not find owner package", argv[i]);
-+ r++;
- continue;
-+ }
-
- if (apk_verbosity < 1) {
- dep = (struct apk_dependency) {
-@@ -130,7 +133,7 @@ static int info_who_owns(struct info_ctx *ctx, struct apk_database *db,
- }
- apk_dependency_array_free(&deps);
-
-- return 0;
-+ return r;
- }
-
- static void info_print_description(struct apk_package *pkg)
---
-1.7.3.3
-
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index b73583075..b820e6643 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -1,15 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
-pkgver=2.0.7
-pkgrel=6
+pkgver=2.0.8
+pkgrel=0
pkgdesc="Alpine Package Keeper - package manager for alpine"
subpackages="$pkgname-static"
depends=
makedepends="zlib-dev openssl-dev pkgconfig"
source="http://git.alpinelinux.org/cgit/$pkgname.git/snapshot/$pkgname-$pkgver.tar.bz2
- 0001-info-return-error-if-owning-package-was-not-found.patch
- 0001-gunzip-fix-ordering-of-boundary-callbacks.patch
- 0001-db-fix-package-caching.patch
"
url="http://git.alpinelinux.org/cgit/apk-tools/"
@@ -51,7 +48,4 @@ static() {
"$subpkgdir"/sbin/apk.static
}
-md5sums="3c4591c594f9b2261ab588446a50d183 apk-tools-2.0.7.tar.bz2
-1364d38e784ad6cc04e157665903ef0c 0001-info-return-error-if-owning-package-was-not-found.patch
-e47a96010eafab0b24588a7f6bb2800b 0001-gunzip-fix-ordering-of-boundary-callbacks.patch
-dab65917565e998a345847f2b61f3f43 0001-db-fix-package-caching.patch"
+md5sums="6d6f1728aef13888a246b134b0231e3c apk-tools-2.0.8.tar.bz2"