summaryrefslogtreecommitdiffstats
path: root/main/duplicity
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2011-03-30 19:56:03 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2011-03-30 19:56:03 +0000
commit91ec719475cff9c7d949c4d7020eec820abc9ca0 (patch)
tree41dbf4480f0a34367e73cdffd528e7f796e9aba7 /main/duplicity
parent140c56e4b3ea0c5796dc0867bf8b9a7d6727395d (diff)
parent556b9732698a2c9aedb4c4a32bd62305e7b7db15 (diff)
downloadaports-91ec719475cff9c7d949c4d7020eec820abc9ca0.tar.bz2
aports-91ec719475cff9c7d949c4d7020eec820abc9ca0.tar.xz
Merge branch 'master' of git://git.alpinelinux.org/msmith/aports
Diffstat (limited to 'main/duplicity')
-rw-r--r--main/duplicity/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/main/duplicity/APKBUILD b/main/duplicity/APKBUILD
new file mode 100644
index 000000000..2562ee2d4
--- /dev/null
+++ b/main/duplicity/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Matt Smith <mcs@darkregion.net>
+# Maintainer: Matt Smith <mcs@darkregion.net>
+pkgname=duplicity
+pkgver=0.6.12
+pkgrel=0
+pkgdesc="Encrypted bandwidth-efficient backup using the rsync algorithm"
+url="http://duplicity.nongnu.org/"
+arch="all"
+license="GPL"
+depends="python py-boto ncftp librsync gnupg"
+makedepends="wget python-dev py-setuptools librsync-dev"
+install=
+subpackages="$pkgname-doc"
+source="https://code.launchpad.net/$pkgname/${pkgver:0:3}-series/$pkgver/+download/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root "$pkgdir"
+}
+
+md5sums="9b84c984054550bbb2ba29b553567b7b duplicity-0.6.12.tar.gz"