summaryrefslogtreecommitdiffstats
path: root/main/firefox
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-04-02 08:24:21 +0300
committerTimo Teräs <timo.teras@iki.fi>2014-04-02 08:24:21 +0300
commit683ba614ebbb0986a9a4611768638e712c7b8e53 (patch)
treedabb647a42aa538f4c2b0cb02911367e11f6f87e /main/firefox
parent1930b6d8b95088b87f8855b595a9f11dce45bee5 (diff)
downloadaports-683ba614ebbb0986a9a4611768638e712c7b8e53.tar.bz2
aports-683ba614ebbb0986a9a4611768638e712c7b8e53.tar.xz
main/firefox: fix pax mark on x86
Diffstat (limited to 'main/firefox')
-rw-r--r--main/firefox/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/main/firefox/APKBUILD b/main/firefox/APKBUILD
index d59bcc5b1..791b1c96e 100644
--- a/main/firefox/APKBUILD
+++ b/main/firefox/APKBUILD
@@ -4,7 +4,7 @@ pkgname=firefox
pkgver=26.0
_pkgver=$pkgver
_xulver=$pkgver
-pkgrel=3
+pkgrel=4
pkgdesc="firefox web browser"
url="http://www.firefox.com"
arch="all"
@@ -108,7 +108,10 @@ package() {
install -m644 ${srcdir}/firefox-safe.desktop ${pkgdir}/usr/share/applications/firefox-safe.desktop
# firefox currently does not work with mprotect. disable it for now
- paxctl -c -m "$pkgdir"/$_mozappdir/firefox || return 1
+ local paxflags="-m"
+ [ "$CARCH" = "x86" ] && paxflags="-msp"
+
+ paxctl -c $paxflags "$pkgdir"/$_mozappdir/firefox || return 1
# xulrunner stub launcher has changed to using a symlink overlay...
# go figure