summaryrefslogtreecommitdiffstats
path: root/main/firefox
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-10-14 13:40:08 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-10-14 13:41:02 +0000
commit6d1cc08829d61d03331edc414d85ffca0ea82c78 (patch)
tree6b4ca94aaf9990716ea30a607e3e4eeb6d06e252 /main/firefox
parent744a0be9c7ec513960140df0929218ffbc06140d (diff)
downloadaports-6d1cc08829d61d03331edc414d85ffca0ea82c78.tar.bz2
aports-6d1cc08829d61d03331edc414d85ffca0ea82c78.tar.xz
main/firefox: fix musl build
Diffstat (limited to 'main/firefox')
-rw-r--r--main/firefox/APKBUILD8
-rw-r--r--main/firefox/mozconfig3
2 files changed, 8 insertions, 3 deletions
diff --git a/main/firefox/APKBUILD b/main/firefox/APKBUILD
index ba53eff30..533fc65eb 100644
--- a/main/firefox/APKBUILD
+++ b/main/firefox/APKBUILD
@@ -73,6 +73,8 @@ prepare() {
done
cp "${srcdir}/mozconfig" .mozconfig
+ sed -e "s/#${CLIBC}#//g" -i .mozconfig
+
echo "ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)" >> .mozconfig
echo "ac_add_options --enable-debug-symbols" >> .mozconfig
echo "ac_add_options --disable-install-strip" >>.mozconfig
@@ -133,21 +135,21 @@ pdfjs() {
}
md5sums="06a4c0fe8d3a979aea2fce8d0fdbf328 firefox-24.0.source.tar.bz2
-98bcd8b2d33037f12ca513882fc5d831 mozconfig
+67652a71a7a7ffc6c2b6ec80bd8fdcb1 mozconfig
2328df219e042f6aaec361cbf83cf9e9 firefox-5.0-asciidel.patch
6b8d481d8fba55fa0ad4f26c02164da8 duckduckgo.patch
1515663477ce427cbdc42f04d8d5ca4e vendor.js
ba96924ece1d77453e462429037a2ce5 firefox.desktop
6f38a5899034b7786cb1f75ad42032b8 firefox-safe.desktop"
sha256sums="86a6efa501e1b106b597a8506757f3a2db9d3a5cfcc61ea29a9ad0c834bea83b firefox-24.0.source.tar.bz2
-0988b03a0532293fbacfd995cdc93df2a10b873cebf4912e1a96cb86f2321312 mozconfig
+99ceca2a4d00303933673687f4222cca34252938c07c6507213205817fd9866b mozconfig
e1e5b6ab3337a6af5c74be392d32fccfa315191191c622dac4f660157ebf4e7a firefox-5.0-asciidel.patch
db057fd5448c3e4d40459fb8ee178296cc723e19efadb1e02a85a4e22a6e560a duckduckgo.patch
d72ca759792cc8c88efc664d30087a139fed7fc3d7d058e4cd9ab287bb80ea46 vendor.js
b571c4a49884a3c98806246c9cc3e60c73d5a8f4aeb7f96217db0be1d6210eda firefox.desktop
4b6de45753856a890f4482055666e77f9b01bdfb7e0df08bafaa3a4d9937eed3 firefox-safe.desktop"
sha512sums="541a26eb939a2cf9a2ec4f4469fdc12008f097c4f615cb196299cbdb855931df5aea288f842dce57e2bb0069ec76e2a748823474e30a6077a9138db5ddb3ee46 firefox-24.0.source.tar.bz2
-f5a3842a04d3fbf433f70fbbbefbf8ee2fce2f25fa041bf4920f99c8842c8a16e0aeaf44e64af14cffcb743c8816ba7aebbbe13e07d0b17ee6a50dbad8f7f645 mozconfig
+91e0c3bd9954af9877429d34c85684950c7fb74e2074f14b5f5810571c709e5e6aea0e67e43171bb9b1ff00e2572b866fca7e915b7d7f882791737a0bd222826 mozconfig
9ccc74883fa4f3861a5ddde1af9c3c0d151fda8ff64df979ee0565ecd2013a875894e5670a0c1d0a28fbb81fb88759777ce7fcb196e582caeb903c760859a1b1 firefox-5.0-asciidel.patch
a7d6a0420f70374a2fa6a74a18ab15c77451f45dc9226ec251f5635a970dbd45ed6cf571ae5ab81b8126951667fc61b1fc5dfb7b8a4d7cc6d465d39e842dc985 duckduckgo.patch
93570f821e59af4d233fc4b1df85e1d145a5e041ad402fd72921987a5a2f5218538d7a13d59bbf0bda5e7df1d5281407674a3765625936340106d1185b15b5d8 vendor.js
diff --git a/main/firefox/mozconfig b/main/firefox/mozconfig
index dd7460ea6..c0951f079 100644
--- a/main/firefox/mozconfig
+++ b/main/firefox/mozconfig
@@ -35,6 +35,9 @@ ac_add_options --enable-gio
ac_add_options --disable-gnomevfs
ac_add_options --disable-static
ac_add_options --enable-official-branding
+#uclibc#ac_add_options --enable-jemalloc
+#uclibc#ac_add_options --enable-replace-malloc
+#musl#ac_add_options --disable-jemalloc
export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1