summaryrefslogtreecommitdiffstats
path: root/main/firefox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-14 16:00:10 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-14 16:00:10 +0200
commit715f8030a2acf3c7a9d1591dfcc90157942e8a49 (patch)
tree6f4b589be826077abc3d8fdce082deea20f31b72 /main/firefox
parent6d1cc08829d61d03331edc414d85ffca0ea82c78 (diff)
downloadaports-715f8030a2acf3c7a9d1591dfcc90157942e8a49.tar.bz2
aports-715f8030a2acf3c7a9d1591dfcc90157942e8a49.tar.xz
main/firefox: don't build with debugging unless DEBUG is set
Diffstat (limited to 'main/firefox')
-rw-r--r--main/firefox/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/main/firefox/APKBUILD b/main/firefox/APKBUILD
index 533fc65eb..f28130749 100644
--- a/main/firefox/APKBUILD
+++ b/main/firefox/APKBUILD
@@ -4,7 +4,7 @@ pkgname=firefox
pkgver=24.0
_pkgver=$pkgver
_xulver=$pkgver
-pkgrel=0
+pkgrel=1
pkgdesc="firefox web browser"
url="http://www.firefox.com"
arch="all"
@@ -56,8 +56,6 @@ source="ftp://ftp.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgve
firefox.desktop
firefox-safe.desktop"
-options="!strip"
-
_builddir="${srcdir}/mozilla-release"
_mozappdir=/usr/lib/firefox-$pkgver
@@ -76,8 +74,10 @@ prepare() {
sed -e "s/#${CLIBC}#//g" -i .mozconfig
echo "ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)" >> .mozconfig
- echo "ac_add_options --enable-debug-symbols" >> .mozconfig
- echo "ac_add_options --disable-install-strip" >>.mozconfig
+ if [ -n "$DEBUG" ]; then
+ echo "ac_add_options --enable-debug-symbols" >> .mozconfig
+ echo "ac_add_options --disable-install-strip" >>.mozconfig
+ fi
}
build() {