summaryrefslogtreecommitdiffstats
path: root/main/firefox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-06-16 06:24:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-06-16 06:25:04 +0000
commitb5a5d7e5839eba5da4579f229ac47c3e5060b421 (patch)
tree918d305d339de6ec19c7d28e7cee60e5b51fd806 /main/firefox
parented714ed787db82d7d4476a919e6c9cadd2d44bab (diff)
downloadaports-b5a5d7e5839eba5da4579f229ac47c3e5060b421.tar.bz2
aports-b5a5d7e5839eba5da4579f229ac47c3e5060b421.tar.xz
main/firefox: disable pageexec
seems like JIT compiler makes it segfault
Diffstat (limited to 'main/firefox')
-rw-r--r--main/firefox/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/firefox/APKBUILD b/main/firefox/APKBUILD
index da1efacdc..03b5ffadf 100644
--- a/main/firefox/APKBUILD
+++ b/main/firefox/APKBUILD
@@ -4,7 +4,7 @@ pkgname=firefox
pkgver=30.0
_pkgver=$pkgver
_xulver=$pkgver
-pkgrel=0
+pkgrel=1
pkgdesc="firefox web browser"
url="http://www.firefox.com"
arch="all"
@@ -109,7 +109,7 @@ package() {
install -m644 ${srcdir}/firefox-safe.desktop ${pkgdir}/usr/share/applications/firefox-safe.desktop
# firefox currently does not work with mprotect. disable it for now
- local paxflags="-m"
+ local paxflags="-mp"
[ "$CARCH" = "x86" ] && paxflags="-msp"
paxctl -c $paxflags "$pkgdir"/$_mozappdir/firefox || return 1