summaryrefslogtreecommitdiffstats
path: root/main/flac
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-29 08:45:29 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-29 08:47:22 +0000
commit8f6f2e3166478b14b208ecfb94ddf01d69dd7bdc (patch)
treee1bdd0bbb491926306c1e43e72dabbbe235f4b62 /main/flac
parent832a032dd3794c5cc3e67f4ee580e171996e8e29 (diff)
downloadaports-8f6f2e3166478b14b208ecfb94ddf01d69dd7bdc.tar.bz2
aports-8f6f2e3166478b14b208ecfb94ddf01d69dd7bdc.tar.xz
main/[various]: update config.sub (and remove charset.alias)
for musl build. the changes are automatically done based on previous build log errors, so this does not guarantee successful build, but is a required.
Diffstat (limited to 'main/flac')
-rw-r--r--main/flac/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/main/flac/APKBUILD b/main/flac/APKBUILD
index 7ebcf4dc1..5c3d75fca 100644
--- a/main/flac/APKBUILD
+++ b/main/flac/APKBUILD
@@ -11,8 +11,15 @@ depends=
makedepends="libogg-dev !libiconv"
source="http://downloads.xiph.org/releases/flac/flac-${pkgver}.tar.xz"
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build () {
- cd "$srcdir"/$pkgname-$pkgver || return 1
+ cd "$_builddir"
./configure \
--build=$CBUILD \
@@ -30,7 +37,7 @@ build () {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver || return 1
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
rm "$pkgdir"/usr/lib/*.la