summaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2010-09-02 12:19:05 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2010-09-17 15:26:45 +0000
commit26a29718b2a9cb029b27c68c819cf2fa2285a221 (patch)
tree58e1181f499bb95e2f50828b5978fd5ba4be6ff2 /main/gcc
parent9ee6c9e7c7836fbc5a5867326cc2cd3fc5e8ec49 (diff)
downloadaports-26a29718b2a9cb029b27c68c819cf2fa2285a221.tar.bz2
aports-26a29718b2a9cb029b27c68c819cf2fa2285a221.tar.xz
main/gcc: make gcc eglibc aware
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 5dc287321..b430cecb4 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -5,8 +5,13 @@ _pv=4.4.2
_specsver=0.1.7
_espfver=0.3.6
_uclibc_abiver=0.9.32
+if [ "$ALPINE_LIBC" = "eglibc" ]; then
+ _chost="i686-pc-linux-gnu"
+else
+ _chost="i486-alpine-linux-uclibc"
+fi
-pkgrel=4
+pkgrel=5
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
license="GPL LGPL"
@@ -16,8 +21,8 @@ subpackages="$pkgname-doc libstdc++:libcxx g++:gpp libgcc libgomp objc"
source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-core-$pkgver.tar.bz2
ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-g++-$pkgver.tar.bz2
ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-objc-$pkgver.tar.bz2
- http://weaver.gentooenterprise.com/hardened/patches/gcc-$_pv-espf-$_espfver.tar.bz2
- http://weaver.gentooenterprise.com/hardened/patches/gcc-$_pv-specs-$_specsver.tar.bz2
+ http://build.alpinelinux.org:8010/distfiles/gcc-$_pv-espf-$_espfver.tar.bz2
+ http://build.alpinelinux.org:8010/distfiles/gcc-$_pv-specs-$_specsver.tar.bz2
gcc-spec-env.patch
pt_gnu_eh_frame.patch
uclibc-getipinfo.patch
@@ -50,7 +55,7 @@ build ()
../configure --prefix=/usr \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --build=${CHOST:-i486-alpine-linux-uclibc} \
+ --build=${CHOST:-$_chost} \
--disable-altivec \
--disable-checking \
--disable-fixed-point \
@@ -102,7 +107,7 @@ libcxx() {
gpp() {
pkgdesc="GNU C++ standard library and compiler"
depends="libstdc++"
- local libexec=usr/libexec/gcc/${CHOST:-i486-alpine-linux-uclibc}/$pkgver
+ local libexec=usr/libexec/gcc/${CHOST:-$_chost}/$pkgver
mkdir -p "$subpkgdir/$libexec" \
"$subpkgdir"/usr/bin \
"$subpkgdir"/usr/include \