summaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-02-26 21:14:16 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-02-26 21:14:16 -0600
commit5840fb368374b8bff1c12ea711dc36f3e4fb03fe (patch)
tree6c009c28e6c338d7a2a69dbdf2a590899ba7ffad /main/gcc
parentf00bacedea607dec88102c34af096565cdc35d5f (diff)
downloadaports-5840fb368374b8bff1c12ea711dc36f3e4fb03fe.tar.bz2
aports-5840fb368374b8bff1c12ea711dc36f3e4fb03fe.tar.xz
main/gcc: fix compilation using -Os on powerpc (upstream PR 43810)
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD6
-rw-r--r--main/gcc/gcc-powerpc-target-optspace.patch13
2 files changed, 17 insertions, 2 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 222960d31..e69d23163 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -7,7 +7,7 @@ _specs_gcc_ver=4.4.3
_uclibc_abiver=0.9.32
-pkgrel=3
+pkgrel=4
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
arch="all"
@@ -42,6 +42,7 @@ source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-core-$pkgver.tar.bz2
PR32219.patch
boehem-gc-uclibc.patch
gcc-pure64.patch
+ gcc-powerpc-target-optspace.patch
"
# we build out-of-tree
@@ -305,4 +306,5 @@ c4045bfa85d8be780affd465be9d8ca8 gcc-spec-env.patch
7f35da0f88f4d9c3d3839498bbda0eb3 gcc-4.5-dynamic-linker.patch
6c866c7fb8d56deb8f6d652bee64e228 PR32219.patch
2c6cb49bb9bfd8b6e690222e66ccc901 boehem-gc-uclibc.patch
-d1d3ad2b0c185b5548125a1b81bee154 gcc-pure64.patch"
+d1d3ad2b0c185b5548125a1b81bee154 gcc-pure64.patch
+ee7285772e6818c3cc96f781d5d2e92e gcc-powerpc-target-optspace.patch"
diff --git a/main/gcc/gcc-powerpc-target-optspace.patch b/main/gcc/gcc-powerpc-target-optspace.patch
new file mode 100644
index 000000000..d812863ea
--- /dev/null
+++ b/main/gcc/gcc-powerpc-target-optspace.patch
@@ -0,0 +1,13 @@
+--- a/libgcc/config/rs6000/t-ppccomm 2010/04/06 11:07:48 157989
++++ b/libgcc/config/rs6000/t-ppccomm 2011/02/23 18:06:29 170443
+@@ -15,7 +15,9 @@
+ e500crtsavg64gpr.S \
+ e500crtsavg64gprctr.S
+
+-EXTRA_PARTS += ecrti$(objext) ecrtn$(objext) ncrti$(objext) ncrtn$(objext)
++EXTRA_PARTS += crtbegin$(objext) crtend$(objext) \
++ crtbeginS$(objext) crtendS$(objext) crtbeginT$(objext) \
++ ecrti$(objext) ecrtn$(objext) ncrti$(objext) ncrtn$(objext)
+
+ # We build {e,n}crti.o and {e,n}crtn.o, which serve to add begin and
+ # end labels to all of the special sections used when we link using gcc.