summaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorLeslie P. Polzer <polzer@port-zero.com>2013-11-24 12:41:20 +0100
committerTimo Teräs <timo.teras@iki.fi>2013-11-29 08:11:04 +0200
commit0936270035ddfe77616752672c4464a92b7f2674 (patch)
treed4e1d839d4db51ee12ef7be24189dcfc3121b18f /main/gcc
parentcabc8699a0156880e5955a6ac5de6f6647629f47 (diff)
downloadaports-0936270035ddfe77616752672c4464a92b7f2674.tar.bz2
aports-0936270035ddfe77616752672c4464a92b7f2674.tar.xz
main/gcc: update fix to compile Ada with -fno-stack-check.
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 45c7609b9..1aa6003c0 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -13,7 +13,7 @@ _cross=""
&& _cross="-$CTARGET"
pkgname="$pkgname$_cross"
-pkgrel=1
+pkgrel=2
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
arch="all"
@@ -225,14 +225,6 @@ prepare() {
return 1
fi
- # fix ada bootstrap
- # piepatches adds -fstack-check to spec which breaks ada bootstrap
- # TODO: upstream this to piepatches
- sed -i -e 's/stage1_cflags="$stage1_cflags -fno-stack-protector"/stage1_cflags="$stage1_cflags -fno-stack-protector -fno-stack-check"/g' \
- configure
- sed -i -e 's/^ESP_NOSSP_CFLAGS = -fno-stack-protector$/ESP_NOSSP_CFLAGS = -fno-stack-protector -fno-stack-check/g' \
- Makefile.in
-
# genautomata crashes with a "Bus Error" when compiled with PIC
# mostly affecting cross-builds as on native build bootstrapping
# somehow seems to build proper genautomata
@@ -357,6 +349,11 @@ build() {
--with-system-zlib \
|| return 1
+ # fix ada bootstrap
+ # piepatches adds -fstack-check to spec which breaks ada bootstrap
+ # TODO: upstream this to piepatches
+ export ADA_CFLAGS='-fno-stack-check'
+
make || return 1
}