summaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-10-02 13:18:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-10-02 13:18:18 +0000
commit0c1a669bb5ecdf0e75c6f190c3f556de2ef59c2c (patch)
treec1c8cef2d5e73ef708ae5a83e13c94f60a41e3f4 /main/gcc
parentfc414f819a691cf8272156eb7f70b5bb586e3894 (diff)
downloadaports-0c1a669bb5ecdf0e75c6f190c3f556de2ef59c2c.tar.bz2
aports-0c1a669bb5ecdf0e75c6f190c3f556de2ef59c2c.tar.xz
main/gcc: upgrade to 4.7.2
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD8
-rw-r--r--main/gcc/gcc-4.7-dynamic-linker.patch8
2 files changed, 8 insertions, 8 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 2b7b747c9..9a6da11d0 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gcc
-pkgver=4.7.1
+pkgver=4.7.2
_piepatchver=0.5.3
_specs_ver=0.2.0
_specs_gcc_ver=4.4.3
@@ -87,7 +87,7 @@ prepare() {
# thanks to Zorry for hard work on those patches
for i in "$srcdir"/piepatch/*.patch; do
msg "Applying $i"
- patch -p0 -i $i || patch -p1 -i $i || return 1
+ patch -t -p0 -i $i || patch -t -p1 -i $i || return 1
done
# Gentoo and uclibc patches
@@ -397,7 +397,7 @@ gfortran() {
"$subpkgdir"/$gcclibs
}
-md5sums="933e6f15f51c031060af64a9e14149ff gcc-4.7.1.tar.bz2
+md5sums="cc308a0891e778cfda7a151ab8a6e762 gcc-4.7.2.tar.bz2
2e1d99664efcdbd86549a40ddf37d405 gcc-4.7.1-piepatches-v0.5.3.tar.bz2
441c76504e1d97170117c294e65c7a72 gcc-4.4.3-specs-0.2.0.tar.bz2
d7cd6a27c8801e66cbaa964a039ecfdb ecj-latest.jar
@@ -413,7 +413,7 @@ f24f07ed008324eaecb0f75417c99116 74_all_gcc47_cloog-dl.patch
a695d7648509b4f8e18b389a19e6037c gcc-spec-env.patch
ab83248e10b2bf4b3d9240de0fefb52b pt_gnu_eh_frame.patch
6cc2385c5bbd6d0da6eaedd53c8bf547 uclibc-getipinfo.patch
-3d8131bdfa70e51be4ae186114097173 gcc-4.7-dynamic-linker.patch
+ac11128f201ee00287f8852697cb86a6 gcc-4.7-dynamic-linker.patch
32e8e4c0e23ed8f5de95a591cb30f1da gcc-4.6-pr32219.patch
2c6cb49bb9bfd8b6e690222e66ccc901 boehem-gc-uclibc.patch
94c36cc724f5c5d6c8cb8650195ee83d gcc-pure64.patch
diff --git a/main/gcc/gcc-4.7-dynamic-linker.patch b/main/gcc/gcc-4.7-dynamic-linker.patch
index 3dbc4d7e9..7fe57a49f 100644
--- a/main/gcc/gcc-4.7-dynamic-linker.patch
+++ b/main/gcc/gcc-4.7-dynamic-linker.patch
@@ -161,10 +161,10 @@ index dbbeea5..0147ece 100644
#define BIONIC_DYNAMIC_LINKER "/system/bin/linker"
#define BIONIC_DYNAMIC_LINKER32 "/system/bin/linker"
#define BIONIC_DYNAMIC_LINKER64 "/system/bin/linker64"
-@@ -104,3 +104,8 @@ see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
- /* Whether we have sincos that follows the GNU extension. */
- #undef TARGET_HAS_SINCOS
- #define TARGET_HAS_SINCOS (OPTION_GLIBC || OPTION_BIONIC)
+@@ -107,3 +107,8 @@ see the files COPYING3 and COPYING.RUNTIME respectively. If not, see
+ /* Whether we have Bionic libc runtime */
+ #undef TARGET_HAS_BIONIC
+ #define TARGET_HAS_BIONIC (OPTION_BIONIC)
+
+#ifdef NOSTDINC
+#undef STANDARD_INCLUDE_DIR