summaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-26 11:07:31 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-26 11:08:38 +0000
commit16dfeac411098e18ef450ab740a5a71c51bc41b0 (patch)
tree35fcd3329b571642a27763f0083c7f9f22030e0f /main/gcc
parentd718403aebb2e68c5271c75469a23f671b321fb0 (diff)
downloadaports-16dfeac411098e18ef450ab740a5a71c51bc41b0.tar.bz2
aports-16dfeac411098e18ef450ab740a5a71c51bc41b0.tar.xz
main/gcc: revert gentoo's addition of -fstack-check
I disagree, we don't want it as default.
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/40_all_gcc48_config_esp.patch21
-rw-r--r--main/gcc/APKBUILD8
2 files changed, 14 insertions, 15 deletions
diff --git a/main/gcc/40_all_gcc48_config_esp.patch b/main/gcc/40_all_gcc48_config_esp.patch
index 1612d8177..83630f2e7 100644
--- a/main/gcc/40_all_gcc48_config_esp.patch
+++ b/main/gcc/40_all_gcc48_config_esp.patch
@@ -1,23 +1,23 @@
-2013-08-10 Magnus Granberg <zorry@gentoo.org>
+2013-02-14 Magnus Granberg <zorry@gentoo.org>
* gcc/esp.h New file to support --enable-esp
- Version 20130810.1
+ Version 20130214.1
---- ./gcc/config/esp.h 2010-04-09 16:14:00.000000000 +0200
-+++ ./gcc/config/esp.h 2012-06-23 01:00:31.248348491 +0200
-@@ -0,0 +1,128 @@
+--- gcc/config/esp.h 2010-04-09 16:14:00.000000000 +0200
++++ gcc/config/esp.h 2012-06-23 01:00:31.248348491 +0200
+@@ -0,0 +1,127 @@
+/* License terms see GNU GENERAL PUBLIC LICENSE Version 3.
-+ * Version 20130810.1
++ * Version 20130214.1
+ * Magnus Granberg (Zorry) <zorry@gentoo.org> */
+#ifndef GCC_ESP_H
+#define GCC_ESP_H
+
-+/* This file will add -fstack-protector-all, -fstack-check, -fPIE, -pie and -z now
++/* This file will add -fstack-protector-all, -fPIE, -pie and -z now
+ as default if the defines and the spec allow it.
+ Added a hack for gcc-specs-* in toolchain-funcs.eclass and _filter-hardened in flag-o-matic.eclass
+ to support older hardened GCC patches and we don't need to change the code on gcc-specs-* and _filter-hardened.
+ This will add some unsupported upstream commands options as -nopie and -nonow.
-+ -D__KERNEL__ is added so we don't have -fPIE, -pie and -fstack-protector-all and -fstack-check when building kernels.
++ -D__KERNEL__ is added so we don't have -fPIE, -pie and -fstack-protector-all when building kernels.
+ ESP_CC1_SPEC is added to CC1_SPEC.
+ ESP_CC1_STRICT_OVERFLOW_SPEC is added so we don't disable the strict-overflow check.
+ ESP_LINK_PIE_CHECK_SPEC check for -pie, -p, -pg, -profile and -static.
@@ -28,7 +28,7 @@
+ /* Hack to support gcc-specs-* in toolchain-funcs.eclass and _filter-hardened in flag-o-matic.eclass */
+ #define ESP_CC1_SPEC " %(esp_cc1_ssp) %(esp_cc1_pie) %(esp_cc1_strict_overflow)"
+ #if defined ( EFAULT_SSP ) || defined ( EFAULT_PIE_SSP )
-+ #define ESP_CC1_SSP_SPEC "%{!fno-stack-protector: %{!fno-stack-protector-all: %{!fno-stack-check: }}}"
++ #define ESP_CC1_SSP_SPEC "%{!fno-stack-protector: %{!fno-stack-protector-all: }}"
+ #else
+ #define ESP_CC1_SSP_SPEC ""
+ #endif
@@ -54,8 +54,7 @@
+ #if defined ( EFAULT_SSP ) || defined ( EFAULT_PIE_SSP )
+ #define ESP_OPTIONS_SSP_SPEC \
+ "%{nostdlib|nodefaultlibs|fno-stack-protector| \
-+ fstack-protector|fstack-protector-all:;:-fstack-protector-all} \
-+ %{fstack-check|fstack-check=*:;: -fstack-check}"
++ fstack-protector|fstack-protector-all:;:-fstack-protector-all}"
+ #else
+ #define ESP_OPTIONS_SSP_SPEC ""
+ #endif
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 1aa6003c0..1676b2cfa 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -13,7 +13,7 @@ _cross=""
&& _cross="-$CTARGET"
pkgname="$pkgname$_cross"
-pkgrel=2
+pkgrel=3
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
arch="all"
@@ -654,7 +654,7 @@ ad7dbd7ac3fdcfb30d430b1d6069816f 20_all_gcc46_config_crtbeginp.patch
607a1144179e47cfc06df8eb674eb7d0 24_all_gcc44_invoke.texi.patch
b0910da9f2eb4fe6a684e680f6336491 34_all_gcc48_config_i386.patch
adcc78e93f54b80210bc436041c1a6e7 35_all_gcc48_config_arm.patch
-d43214e763cba712f2afc0301147b313 40_all_gcc48_config_esp.patch
+3023d60ef8658587e351b5201ccc7fd5 40_all_gcc48_config_esp.patch
f28e9334c58ce14f69a9e988026bc772 12_all_default-warn-trampolines.patch
7eb9ad894dfdf1b3d4a8a407a339a6f1 15_all_libgfortran-Werror.patch
452e457a0ac45e6f8f75eb6d6ba4d04b 16_all_libgomp-Werror.patch
@@ -698,7 +698,7 @@ f301cce95609650f57c5212b38daf5288b4e7c5fa37ae2892664d4c8ceaadfbf 02_all_gcc48_c
38c9f4fdbf25a2e032a99f85d1a6428dd446ecc0ec3b9df7078ae61afecd368f 24_all_gcc44_invoke.texi.patch
150f17367d7f514fda9e0aac283e059b190a2251d7d9dfa2b5686b2bdc67b725 34_all_gcc48_config_i386.patch
48e22b2794ae70985c418832f7845814d65e78abcf56d38205db4b760a1c5ffa 35_all_gcc48_config_arm.patch
-5ecd7153106f36c607ae55c7a2db67849725a41afcb9454b9cca1b7f4982d4a8 40_all_gcc48_config_esp.patch
+08cfcaf322bc4479d24b764e63dc6e012709d7f5d9a2a46b256f1736323564d7 40_all_gcc48_config_esp.patch
ce7774aa13be5da274220258772ccbdd6f54abdad97a3798ba282865c809f042 12_all_default-warn-trampolines.patch
8b1450d5a7756af2b890588005690785a663601e2b1533671b609aa8cce0f718 15_all_libgfortran-Werror.patch
1f106fe03cede7c697bde7d81732e0d3bb2c7197e4967789182a5fd8db532900 16_all_libgomp-Werror.patch
@@ -742,7 +742,7 @@ b0dd448e25d4ca8313eb2004b2bb020d5e1c0ff51d347686312625d1102093ba95a3b1267b4ec10b
5d3f5ea46eef4cdbb3172c65b17dcf55acf936c9319177a7958ac283ea3651f5e00a76da3ee323bc39302210add36861329f085ba54c737f2942c19dd243b7d5 24_all_gcc44_invoke.texi.patch
dd5b9b30eb7716cb3c010ca79a83ed6219ff6e6f2557deb4e1d26cecac0f2b14c4ef7bf4dc5c2aec88aae5463763f5f64454b8a627ebd1d0a5c92984017025ad 34_all_gcc48_config_i386.patch
8829f85323d8b11e26e3c19ced4a51875fc63f1483cfdc4d0f579a6cb37e1b6e23fcf33a87a574a6e0007250374ea46d117a136e73a40fbe43f0e39d9b2dd1a8 35_all_gcc48_config_arm.patch
-3d7c39d35c10e155c835ef07400490aa17fa3913350b2b8c668af882f645f579b25d1de65ed8da9dd7b935091e029c3e7e7cc6c6da95dcf63e94c8f21706aad5 40_all_gcc48_config_esp.patch
+d8d1b546f22e0e6082a69a45afbc895fc8c3a572eb0b662c7960f0cf6ae77f740512ae2addd166cec93c00695fd15541bf994d88dd882bff207f4801cf1b13c1 40_all_gcc48_config_esp.patch
5069e4b741488913a646a9b5d871af8e7f7a606158ea09305d0ddd46257c5b659770627bc2ca3abeaae039da1717b3ba6c9cd90554a441da74eb4ecf24c13074 12_all_default-warn-trampolines.patch
c18a99b7303a734fe4dca9d4e90e21d18e5bd71c7d91e1a26c86b1354c73f567590a875941bfe64ce59f0393023b91c606c96b30885c55b98a790c3ab0c84ca7 15_all_libgfortran-Werror.patch
433404fd9bfa172d69fff4a5505e8648cbbbf5f052d2b4235608ff7af0c4063d557d25d80c85c5bd0d1e1ed64b568e7bbc0cdbce11cc74db4c0189af3a01634a 16_all_libgomp-Werror.patch