summaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-10-18 23:49:59 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-10-18 23:49:59 +0000
commit4d7f02c5f191e840263bf8c226a9e2bc0e4ba31e (patch)
tree9780658c8f82bfbc54c3c5055642a7f491099c0e /main/gcc
parent31244fed0df5f208ba5501ed7c0fa888d35c989b (diff)
downloadaports-4d7f02c5f191e840263bf8c226a9e2bc0e4ba31e.tar.bz2
aports-4d7f02c5f191e840263bf8c226a9e2bc0e4ba31e.tar.xz
main/gcc: fix cross compiler creation and cross compiling native compiler
- paxctl is needed always, make it unconditional dependency - when cross building native compiler, the configury breaks unless all the host libraries are present (it tries to include them) so make sure builder has whatever the host needs
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD3
1 files changed, 1 insertions, 2 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 088243596..45c7609b9 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -20,7 +20,7 @@ arch="all"
license="GPL LGPL"
_gccrel=$pkgver-r$pkgrel
depends="binutils$_cross"
-makedepends_build="bison flex texinfo gawk zip"
+makedepends_build="paxctl bison flex texinfo gawk zip gmp-dev mpfr-dev mpc1-dev zlib-dev cloog-dev"
makedepends_host="gmp-dev mpfr-dev mpc1-dev zlib-dev cloog-dev !libiconv-dev !gettext-dev"
makedepends="$makedepends_build $makedepends_host"
subpackages=" "
@@ -127,7 +127,6 @@ if $LANG_OBJC; then
fi
if $LANG_JAVA; then
subpackages="$subpackages libgcj gcc-java$_cross:java"
- makedepends="$makedepends paxctl"
_languages="$_languages,java"
fi
if $LANG_GO; then