summaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-09-06 13:42:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-06 13:42:15 +0000
commit5a9711930c24180b00d4f31e0c99b67c4be65753 (patch)
treeab193dd511dd4c4a19a5bd8f3c9514ddd896b675 /main/gcc
parentd31d5ef1b41ce50532ffeef45470f778db8f47e9 (diff)
downloadaports-5a9711930c24180b00d4f31e0c99b67c4be65753.tar.bz2
aports-5a9711930c24180b00d4f31e0c99b67c4be65753.tar.xz
main/gcc: enable ada
This require manual bootstrapping on build servers...
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 105b4936e..76f1e845d 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -7,7 +7,7 @@ _specs_gcc_ver=4.4.3
_uclibc_abiver=0.9.32
-pkgrel=1
+pkgrel=2
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
arch="all"
@@ -23,9 +23,7 @@ replaces="libstdc++"
: ${LANG_JAVA:=true}
: ${LANG_GO:=true}
: ${LANG_FORTRAN:=true}
-# to build ada you need a working bootstrap gnat in PATH
-# and then run: LANG_ADA=true abuild -r
-: ${LANG_ADA:=false}
+: ${LANG_ADA:=true}
if [ "$CBUILD" != "$CHOST" ]; then
# fixup flags. seems gcc treats CPPFLAGS as global without
@@ -45,7 +43,8 @@ if [ "$CBUILD" != "$CHOST" ]; then
LANG_JAVA=false
LANG_GO=false
LANG_FORTRAN=false
- LANG_ADA=false
+ # ada needs bootstrapping
+ LANG_ADA=true
fi
_languages=c,c++