summaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-03-12 11:00:27 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-03-12 11:00:27 +0000
commitb6352f8b9855dc4ef7cf5c27c7f7efd8ef4026e3 (patch)
tree37218cecf7e5545293f2f6225b3d7521de486212 /main/gcc
parent43835917805d4b09c6a077eee2feeda0bc324c5b (diff)
downloadaports-b6352f8b9855dc4ef7cf5c27c7f7efd8ef4026e3.tar.bz2
aports-b6352f8b9855dc4ef7cf5c27c7f7efd8ef4026e3.tar.xz
main/gcc: upggrade to 4.6.3
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/74_all_gcc46_cloog-dl.patch42
-rw-r--r--main/gcc/APKBUILD18
2 files changed, 29 insertions, 31 deletions
diff --git a/main/gcc/74_all_gcc46_cloog-dl.patch b/main/gcc/74_all_gcc46_cloog-dl.patch
index 21ceb25b7..43c2f9622 100644
--- a/main/gcc/74_all_gcc46_cloog-dl.patch
+++ b/main/gcc/74_all_gcc46_cloog-dl.patch
@@ -29,8 +29,12 @@ was modified to work on FreeBSD (http://bugs.gentoo.org/317211).
* Makefile.in (BACKENDLIBS): Use DL_LIB.
* graphite-cloog-compat.h: Add missing symbols.
+2012-03-12 Natanael Copa <ncopa@alpinelinux.org>
+ * Rebase against gcc 4.6.3
+diff --git a/gcc/Makefile.in b/gcc/Makefile.in
+index 872956d..7d89f08 100644
--- a/gcc/Makefile.in
+++ b/gcc/Makefile.in
@@ -984,6 +984,8 @@ GCC_PLUGIN_H = gcc-plugin.h highlev-plugin-common.h $(CONFIG_H) $(SYSTEM_H) \
@@ -106,7 +110,7 @@ was modified to work on FreeBSD (http://bugs.gentoo.org/317211).
graphite-sese-to-poly.h
tree-vect-loop.o: tree-vect-loop.c $(CONFIG_H) $(SYSTEM_H) coretypes.h \
$(TM_H) $(GGC_H) $(TREE_H) $(BASIC_BLOCK_H) $(DIAGNOSTIC_H) $(TREE_FLOW_H) \
-@@ -3482,6 +3484,11 @@ $(out_object_file): $(out_file) $(CONFIG_H) coretypes.h $(TM_H) $(TREE_H) \
+@@ -3483,6 +3485,11 @@ $(out_object_file): $(out_file) $(CONFIG_H) coretypes.h $(TM_H) $(TREE_H) \
$(COMPILER) -c $(ALL_COMPILERFLAGS) $(ALL_CPPFLAGS) \
$(out_file) $(OUTPUT_OPTION)
@@ -118,6 +122,8 @@ was modified to work on FreeBSD (http://bugs.gentoo.org/317211).
# Build auxiliary files that support ecoff format.
mips-tfile: mips-tfile.o version.o $(LIBDEPS)
$(LINKER) $(LINKERFLAGS) $(LDFLAGS) -o $@ \
+diff --git a/gcc/configure b/gcc/configure
+index 9b87171..0cf3795 100755
--- a/gcc/configure
+++ b/gcc/configure
@@ -602,6 +602,7 @@ ac_subst_vars='LTLIBOBJS
@@ -128,25 +134,7 @@ was modified to work on FreeBSD (http://bugs.gentoo.org/317211).
CLOOGINC
CLOOGLIBS
PPLINC
-@@ -17505,7 +17506,7 @@ else
- lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
- lt_status=$lt_dlunknown
- cat > conftest.$ac_ext <<_LT_EOF
--#line 17508 "configure"
-+#line 17509 "configure"
- #include "confdefs.h"
-
- #if HAVE_DLFCN_H
-@@ -17611,7 +17612,7 @@ else
- lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
- lt_status=$lt_dlunknown
- cat > conftest.$ac_ext <<_LT_EOF
--#line 17614 "configure"
-+#line 17615 "configure"
- #include "confdefs.h"
-
- #if HAVE_DLFCN_H
-@@ -26284,6 +26285,7 @@ $as_echo "unable to check" >&6; }
+@@ -26282,6 +26283,7 @@ $as_echo "unable to check" >&6; }
fi
# Check -ldl
@@ -154,7 +142,7 @@ was modified to work on FreeBSD (http://bugs.gentoo.org/317211).
saved_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing dlopen" >&5
$as_echo_n "checking for library containing dlopen... " >&6; }
-@@ -26343,7 +26345,9 @@ fi
+@@ -26341,7 +26343,9 @@ fi
if test x"$ac_cv_search_dlopen" = x"-ldl"; then
pluginlibs="$pluginlibs -ldl"
@@ -164,9 +152,11 @@ was modified to work on FreeBSD (http://bugs.gentoo.org/317211).
LIBS="$saved_LIBS"
# Check that we can build shared objects with -fPIC -shared
+diff --git a/gcc/configure.ac b/gcc/configure.ac
+index c574fb6..228fb9f 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
-@@ -4841,11 +4841,14 @@ if test x"$enable_plugin" = x"yes"; then
+@@ -4839,11 +4839,14 @@ if test x"$enable_plugin" = x"yes"; then
fi
# Check -ldl
@@ -181,6 +171,8 @@ was modified to work on FreeBSD (http://bugs.gentoo.org/317211).
LIBS="$saved_LIBS"
# Check that we can build shared objects with -fPIC -shared
+diff --git a/gcc/graphite-clast-to-gimple.c b/gcc/graphite-clast-to-gimple.c
+index 41356dc..e93cafe 100644
--- a/gcc/graphite-clast-to-gimple.c
+++ b/gcc/graphite-clast-to-gimple.c
@@ -738,10 +738,10 @@ clast_get_body_of_loop (struct clast_stmt *stmt)
@@ -196,6 +188,8 @@ was modified to work on FreeBSD (http://bugs.gentoo.org/317211).
struct clast_user_stmt *body = clast_get_body_of_loop (stmt);
CloogStatement *cs = body->statement;
poly_bb_p pbb = (poly_bb_p) cloog_statement_usr (cs);
+diff --git a/gcc/graphite-cloog-compat.h b/gcc/graphite-cloog-compat.h
+index 011377d..550df7a 100644
--- a/gcc/graphite-cloog-compat.h
+++ b/gcc/graphite-cloog-compat.h
@@ -272,4 +272,269 @@ static inline int cloog_matrix_nrows (CloogMatrix * m)
@@ -468,6 +462,8 @@ was modified to work on FreeBSD (http://bugs.gentoo.org/317211).
+
+
#endif /* GRAPHITE_CLOOG_COMPAT_H */
+diff --git a/gcc/graphite-poly.h b/gcc/graphite-poly.h
+index 3bf87b0..3ed95b7 100644
--- a/gcc/graphite-poly.h
+++ b/gcc/graphite-poly.h
@@ -22,6 +22,8 @@ along with GCC; see the file COPYING3. If not see
@@ -479,6 +475,8 @@ was modified to work on FreeBSD (http://bugs.gentoo.org/317211).
typedef struct poly_dr *poly_dr_p;
DEF_VEC_P(poly_dr_p);
DEF_VEC_ALLOC_P (poly_dr_p, heap);
+diff --git a/gcc/graphite.c b/gcc/graphite.c
+index b013447..5637d37 100644
--- a/gcc/graphite.c
+++ b/gcc/graphite.c
@@ -56,6 +56,35 @@ along with GCC; see the file COPYING3. If not see
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 379d9ae02..da967dbb4 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gcc
-pkgver=4.6.2
+pkgver=4.6.3
_piepatchver=0.4.5
_specs_ver=0.2.0
_specs_gcc_ver=4.4.3
_uclibc_abiver=0.9.32
-pkgrel=5
+pkgrel=0
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
arch="all"
@@ -388,12 +388,12 @@ gfortran() {
"$subpkgdir"/$gcclibs
}
-md5sums="780f614ab18c7a9066dec6387d7490b2 gcc-core-4.6.2.tar.bz2
-87ecd60431e41096419dd8a10f76e46b gcc-g++-4.6.2.tar.bz2
-94043cc0d08394eddebed73f30ecad89 gcc-objc-4.6.2.tar.bz2
-52de580642d7092b7b2790d9a81ab7a6 gcc-java-4.6.2.tar.bz2
-0b7bdd9bd3096075f035fa9def33c314 gcc-go-4.6.2.tar.bz2
-216ecc8dbf99a562e837c48b5c4e7979 gcc-fortran-4.6.2.tar.bz2
+md5sums="766091220c6a14fcaa2c06dd573e3758 gcc-core-4.6.3.tar.bz2
+37515158a0fb3d0800ec41a08c05e69e gcc-g++-4.6.3.tar.bz2
+48ba23770c34b1cb468f72618b4452c5 gcc-objc-4.6.3.tar.bz2
+ea47e796f9e53118cd6e262fa220085c gcc-java-4.6.3.tar.bz2
+92166ef431c165054467a9524d0819c8 gcc-go-4.6.3.tar.bz2
+26a18d5727f7c8c18581ba924cce1e5f gcc-fortran-4.6.3.tar.bz2
5dc7efd84b526801b94fed21462aea62 gcc-4.6.1-piepatches-v0.4.5.tar.bz2
441c76504e1d97170117c294e65c7a72 gcc-4.4.3-specs-0.2.0.tar.bz2
d7cd6a27c8801e66cbaa964a039ecfdb ecj-latest.jar
@@ -403,7 +403,7 @@ a78022925c0ecb1f13384238b81adbe7 12_all_default-warn-trampolines.patch
6862cb5268fef68a4a1906e0c4ea0d46 15_all_libgomp-Werror.patch
1a8ce6b7a0b9a115e37fdda311704451 34_all_ia64_note.GNU-stack.patch
d8692c56f04b92667096f59d843e95c5 51_all_libiberty-pic.patch
-656565d2e2c30ea12a398ef6959a9391 74_all_gcc46_cloog-dl.patch
+a90d4d1ee358b19f2068fe2e4fd5d001 74_all_gcc46_cloog-dl.patch
a695d7648509b4f8e18b389a19e6037c gcc-spec-env.patch
2db1e3482c5dd59dab70f701afa2ca80 pt_gnu_eh_frame.patch
6cc2385c5bbd6d0da6eaedd53c8bf547 uclibc-getipinfo.patch