summaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-25 07:29:56 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-25 07:30:29 +0000
commitc1a172eeffd00a81e1f6c3ebc6f92d5edafc8a4f (patch)
tree0cfbde9d5f9377902ea935d6647e5f7754b073d2 /main/gcc
parentf898570b73ebd04954436b04b927270b3df93388 (diff)
downloadaports-c1a172eeffd00a81e1f6c3ebc6f92d5edafc8a4f.tar.bz2
aports-c1a172eeffd00a81e1f6c3ebc6f92d5edafc8a4f.tar.xz
main/gcc: fix crossbuild failure
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 864a66cde..488dde45d 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -227,6 +227,12 @@ prepare() {
return 1
fi
+ # genautomata crashes with a "Bus Error" when compiled with PIC
+ # mostly affecting cross-builds as on native build bootstrapping
+ # somehow seems to build proper genautomata
+ sed -i gcc/Makefile.in -e 's|^build/genautomata$(build_exeext) .*|& -fno-PIC|' \
+ || return 1
+
# enable hardened cflags by default
# building gcc wih PIE seem to hit some strange bug. we probably run
# out of some resource. so we disable PIE for gcc while enabling it