summaryrefslogtreecommitdiffstats
path: root/main/gexiv2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-11-20 07:55:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-11-20 07:55:35 +0000
commit34ef1a6fce6aed8e738a51ad2f497e207bd8379d (patch)
treeac8db61dbc92fad662ce96d9f096ec3e6a849dd3 /main/gexiv2
parentcc21987e66fd5639e41deeeb1377d70889680348 (diff)
downloadaports-34ef1a6fce6aed8e738a51ad2f497e207bd8379d.tar.bz2
aports-34ef1a6fce6aed8e738a51ad2f497e207bd8379d.tar.xz
main/gexiv2: rename from libgexiv2 and upgrade to 0.7.0
Diffstat (limited to 'main/gexiv2')
-rw-r--r--main/gexiv2/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/main/gexiv2/APKBUILD b/main/gexiv2/APKBUILD
new file mode 100644
index 000000000..c696b9ca2
--- /dev/null
+++ b/main/gexiv2/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gexiv2
+pkgver=0.7.0
+pkgrel=0
+pkgdesc="a GObject-based wrapper around the Exiv2 library"
+url="http://trac.yorba.org/wiki/gexiv://wiki.gnome.org/gexiv2"
+arch="all"
+license="GPL"
+depends=
+depends_dev="glib-dev exiv2-dev"
+makedepends="exiv2-dev glib-dev libtool m4 gobject-introspection-dev"
+install=
+subpackages="$pkgname-dev"
+source="http://ftp.gnome.org/pub/gnome/sources/gexiv2/${pkgver%.*}/gexiv2-$pkgver.tar.xz"
+replaces="libgexiv2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-introspection \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/*.la || return 1
+}
+
+md5sums="de3619e5d2b621c19fdcf77b17d25d25 gexiv2-0.7.0.tar.xz"
+sha256sums="b631fe02402014cb52f22647b384972776ada31cbd3c3f187014b6535461ee8a gexiv2-0.7.0.tar.xz"
+sha512sums="7ce5a90494b421e18ea75e4be8c8f4ddaad053acb8a29ed8a04a0c15b77170d0c4807f9d49b1f80b40f5a25f54221cf785fe907a8a12bf9495e5ab4a00db804e gexiv2-0.7.0.tar.xz"